Jump to content

Recommended Posts

Hi all! I am a proud owner of a PodXTLive and I'm really happy with it!
I'm also a developer and my project is to create a VST Host under Raspberry Pi2.. all is going well, but (as far as I know) there aren't Line6 drivers for Linux based on ARM architecture.. There is someone that can help me with the project or that can give me some hint or ideas to make it work?
Raspberry Pi2 would be perfect for a vst host and It would be nice to make my PodXTLive do the sound processing like I do (for example) on windows!
Thank you all and I hope to get a clear answer just to understand if I have to give up and try with some other solution.

 

Luca

Share this post


Link to post
Share on other sites

at least in kernel 4.4 are included line6 modules. In ubuntu if you go to /lib/modules/4.4.0-36-generic/kernel/sound/usb/line6 you will see the modules:

snd-usb-line6
snd-usb-podhd
snd-usb-pod
snd-usb-toneport
snd-usb-variax

you should be able to load them with: modprobe
example:
sudo modprobe snd-usb-podhd

unfortunnately I haven't been able to bring my hd500x running, I don't know if it is because of the X or not. modprobe work's fine but I don't see it with

cat /proc/asound/cards

nor I see it in alsamixer.

hope this help, let us know how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×