Jump to content

Recommended Posts

My FBV express Mk2 when hooked up to my amplifi 75 used to change through ABCD on bank selected. Now it will always go back to bank 1 and does the ABCD Channels. It will not stay in the bank selected. Is this due to the new pedal board??

Not happy as when in Bank 20 for the blues channels volume works wha works but soon as change to ABCD it goes back to the bank 1 tried updating going back to defaults and still Bank 1 ABCD.

This sucks as it was very helpful now seems like I have to use the iPad if not in bank 1. Please bring out an update or tell me how to fix the problem. As I own a spider 4 75 and a hd500. On a army pension and hate to have wasted money on my FBV express 2. Or are you pushing us to spend more money on your new 100 board. Not impressed, may as well go to fender tube with stomp boxes.

Please help tried everything, used to just plug in the back and the Bank you where on was the one that you could change each channel.

Share this post


Link to post
Share on other sites

This sounds like a problem with the amp, not the FBV.  The FBV just sends the channel-select signal, it doesn't have any capacity to send a bank change.

  • Downvote 1

Share this post


Link to post
Share on other sites

Try posing yoru question in the Amplifi section of these forums.

Share this post


Link to post
Share on other sites

Thanks. I guess that would be under Forums??

First time user at this type of programming or whatever you call it lol.

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×