Jump to content
svenseel

G70 -- Drop out experiences?

Recommended Posts

I FIXED THIS PROBLEM

 

i opened the receiver, and had to disassemble the entire thing to get to the four antennas.... connecting them and the actual transmitter circuit are these pretty standard micro coaxial connectors, every single one on mine was loose... not disconnected but clearly loose... i gently squeezed the each one, and pressed them back in place, feeling that they were clearly connected much tighter, reassembled the device and voila! works like day one.

did you just take off the bottom plate?  I see the 4 mini coax connectors.  Are these the 4 you made fit tighter?  The 4 under the yellow tape right?

Share this post


Link to post
Share on other sites

yes those four, but also the antenna PCBs each one connects to, which requires you to disassemble almost the entire unit. those ones were looser, in my experience, than the cable ends connecting to the main PCB.

Share this post


Link to post
Share on other sites

Any more feedback on this thread..?  Still having issues..?  Resolved with firmware update or antenna connector issues..?

Would like to buy the Line 6 G70, but after these comments and issues, leaning toward the Shure GLXD16.

Thanks!
 

Share this post


Link to post
Share on other sites

Hi, i have also been having these drop out very frequently over the last few months of playing shows, i have updated the firmware to the latest last week and had it drop out yesterday. I had to borrow a G30 for the set. Other then that it has been an amazing unit.

I use it on my strap about half way up, also our bass player has a G90, i have heard they can interfere with G70's? But when the G90 is switched off i still experience the drop outs.

Thank you.

 

Share this post


Link to post
Share on other sites

I have a problem of my own

I bought the relay g70 and all the sites I read about said to update it with the new software so I downloaded the updater and when I plugged the g70 into my computer it came up as a g75. Thinking it would be the same software I installed 1.04 on it. Now all my buttons are mixed up and no matter what way I turn the toggle it scrolls the same way so I can not get to places I need to go on the screen. I have wrote line 6 and will call them tomorrow to see if they can fix this if not it will be going back to the store. So a warning to all do not update your g70 with 1.04 software.

Share this post


Link to post
Share on other sites

I´m having serious problems with my G70. For the last few months it have stopped working completely after one or two hour of use. It starts with dropouts and after a few minutes it goes completly silent. If I changes batteries in the ttransmitter it will work for an hour or so again.
I have updated to the latest firmware so that can not be the problem.

Share this post


Link to post
Share on other sites

I've bought a dozen line 6 products over the years and this is the only one that is not even usable for practice; same problems with dropouts every few seconds. I've had wireless systems since the late 80's; this was the most expensive one for me, and by far the worst. Completely unusable, with firmware upgrade, different cable, different everything. It just can't hold a wireless signal for more than 5 seconds. Wow, I vote for a recall. Even if they fixed each unit and sent it back to us, they would still be WAY ahead financially, and would keep customers happy. 

Share this post


Link to post
Share on other sites

I just played a venue with my new G70 that was notorious for dropouts using my old X2 SDS-95, and not a single dropout, even though I tried very hard to make it happen.  Same pedalboard, same position on the board, same monitor in front of it, and not a single dropout. 

Share this post


Link to post
Share on other sites

New firmware didn't work for me. I'm on 1.05 and still dropping out like crazy... at least at my last show. But I had the transmitter in my pocket and I was locked into a particular channel. I'm going to try it outside and use the channel scan this weekend. We'll see how it goes.

Share this post


Link to post
Share on other sites

I had numerous issues with dropouts... even with the latest firmware updates and channel scanning at the gig. I returned the g70 and bought a new g50, shipped in RF2 mode. Had tons of dropouts. Switched it back to RF1 mode and NOT ONE. The "new" technology seems to me to be the issue, and the g70 offers no alternative to get back to RF1. It's a shame, cuz it's a beautiful unit otherwise.

Share this post


Link to post
Share on other sites

Very sorry to hear that. There is always the possibility of WiFi interference. This can be avoided by doing a channel scan during setup.

 

Actually, it can't. I tried it numerous times with horrible results. My new g50 in RF2 mode has the exact same issues. I put it back in RF1 mode, and ZERO dropouts. Why was the option to do that taken away with the g70? It seems to me that if I could, it would be the perfect wireless, and worth the $200 more than every other one out there.

Share this post


Link to post
Share on other sites

I've been working through the same issues as everyone else. In my case, I had a run of success in the beginning. Like everyone else though, I've had bad connectivity and it became unuseable in my last three situations. One gig at a bar, one gig at a golf club house, and one rehearsal at my typical band space. So if the wifi router strength is the issue, how can we even control that and more appropriately, why should we have to? What doesn't make sense either is I was told from Line 6 support that the G70 has better connectivity than the G50 I owned. I never had one interference or connectivity issue, ever, using the G50. Granted I didn't use the G50 for every gig and I only gig about 10-12 times a year, but the G70 has been horribly unpredictable. So that's the main point here. There are tons of people having serious issues with this product and it's not stable enough for paid gigs, IMO.

 

Besides going back to a G50, what are some other options that are dependable and sound good. I will give the G70 kudos on sound quality. I don't care as much about the additional feature set. I want sound and connectivity. Anyone have any thoughts on a pro solution that works well?

 

I went back to a g50 and couldn't be happier. I got so frustrated with that expensive box of bells and whistles that can't even perform it's main function. I have too many gigs to experiment with buying another transmitter (for $300) and seeing if it worked better than the one that came with it. When you're spending $600 on a piece of gear, the one that comes in the box should work just fine.

 

I also found that my g50 was shipped in RF2 mode, which they're calling their new technology on the packaging. SAME EXACT PROBLEM. I switched it to RF1 mode, and NO dropouts at all. I've gone 250 feet from my receiver and had no dropouts at all.. even walking through a crowd of people, which I do every show. The fact that no one carries the g70 anymore means it's not selling. You would think in the last 2 years of problems that they would have fixed it.

Share this post


Link to post
Share on other sites

I experience drop outs too. So I try to update the firmware 1.3 to 1.5 directly to my mac laptop using with macOS 12.12.4 it didn't work. And so I went to my wife's iMac with the same MacOS 12.12.4 and try do the same update still didn't work. So I took it in to line6 in Calabasas California (head quarters) myself, when I got there told them that was experiencing dropouts (as we called taking a hit). I find out it was brorken USB in the receiver unit. I told them the USB is a poor design, they should have include the line 6 9V power adapter instead of the USB power cable. In which USB power cable is not road worthy! Cut to the chase.

Well the technicians repaired USB it and updated with firmware 1.5 . And was ready to pick up.

It two nice ladys they greeted me and got me my unit ( receiver in the transmiter) so I told them about the design flaw, so they went back and got the technician/designer I couldn't recall his name. For some reason he couldn't look me in my face and he just shined me on and told everything is ok fixed. This weekend I had a major show in Cancún, Mexico at sound check. Fired up the G70, it took all kind hits through all 16 channels it was a big disappointment. Thanks line6 for all most trusting in your product😬 In which it cost me a lot of money in time & travel. PS I have the video to prove it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×