Please ensure Javascript is enabled for purposes of website accessibility Jump to content

USB and DAW issues!! AMPLIFi TT - Help please...


Recommended Posts

I cant get a USB-connection going in my DAW when I connect my amplifi tt to my computer via. USB. Thats my problem. It doesn't appear as a device in Reaper at all.. 

When I plug in my amplifi to my computer via. usb it tells me it fails to install unit drivers? I've had a lot of trouble updating my Amplifi to latest patch and Im not even sure it's done correctly. I tried locating amplifi drivers and updates on my PC, in the hope that I could do it manually, but nope. Line 6 dont have any software for amplifi products available for downloading I guess. 

Im very frustrated, please help

Link to comment
Share on other sites



LIFi 150, 75 and FX100, and can be downloaded via the AMPLIFi Remote iOS and Android apps, as well as the AMPLIFi Utility for PC. The ASIO driver for PC is available at


* Camera Connection Kit required.

I found this in the "announcement"-section. It only adds to my confusion:

s it because amplifi tt isn't supported????! When I go to the link to get the ASIO drivers, THERE IS NOTHING available for download. Is this the drivers I need? How can I get them? Anyone has a direct link? 

And what the heck is "amplifi utility software"? Sure sounds like something I should have on my computer as an amplifi owner? How do I get that? I checked a million times now and theres is nothing I can download from Line 6's homepage... 


I bought this product with the sole intent of being able to do some recordings on my computer. Right now its looking bad. 

Link to comment
Share on other sites

Go to the downloads page on the Line 6 website....


Choose your product (Amplifi TT), Choose "All Software" and "All OS" and you'll get a list of everything available to download.


The drivers, PC utility, and latest version of the firmware are all there to download.

Hey thanks for your advice, Im totally embarassed - did as you wrote and it worked without a hassle. No problem at all. Just me being a retard :) Thanks, Im gonna continue making laying down guitartracks now. :)

Link to comment
Share on other sites

  • 1 year later...



I just purchased the Amplifi TT unit, have some newbie questions.


1. I am using the Focusrite Scarlett 6i6 as my interface to a mac. From the back of Amplifi TT, i connect two 1/4 inch jacks out to line input 1 & 2 of the scarlet and the amplifi TT usb cable directly to my mac. 


Am i doing this correctly?


To record, i am recording stereo from line input 1 & 2 via the 1/4 jacks. Can i record via usb without the 1/4 jacks stereo outputs?

Link to comment
Share on other sites

Similar issue:

I just went through a lengthy chat on line with Apple Support to find out why my Mac with El Capitan (10.11.4) cannot find or see my Amplifi 75 via USB. They went directly to Line 6's tech info and quoted a paragraph stating that only Mac OS up to Yosemite (10.10) is supported!! This is after about 4 or 5 tickets to Line 6 asking for the same help. No one from Line 6 could actually tell me straight out that El Capitan is not supported for recording via USB!! If this is not the case, I need to find out if any of you have had the same problem or can deny that this problem exists because you are using El Capitan on a Mac connected to your amp via USB! If this problem is real, when will Line 6 admit it and release an update so newer computers can see the amp! [bTW: I am running the latest firmware and app on the Line 6 side and I tested the connection on an older Mac computer running System 10.8 which worked perfectly fine!]

Any suggestions? Thx!


Link to comment
Share on other sites

  • 3 months later...



Same prolem. I can't use it for recording... I've tried everything, downloaded all the drivers, installed them all, got the last actuallisation, and applied latest version of firmware (bluetooth to device thing), everything... apparently it all goes alright, not a single issue while installing, but then, for my laptop the unit simply isn't there...


Line6 updater installed too. It doesn't recognize any device connected to the pc.


My daw is Ableton and it doesn't recognize it either... even in the menu sound of te computer it doesn't appear...


I'm not very gifted with computers, and maybe I'm missing something basic or something, but I can't make it work... Could it be a laptop problem?


Please help, I'm very frustrated and quite angry... I've spent the last 2 days trying to fix this without a result. I read the manuals, consulted a lot of forums, watched videos, and I still at the same point...



Thank you in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...