Jump to content
ladcandide

AMPLIFI 75, Windows 8.1 64 : USB Device Not Recognized

Recommended Posts

Hello,

 

Device : AMPLIFI 75

 

OS : Windows 8.1 64

 

I installed AMPLIFI Utility 1.00.

When I turn on the AMPLIFI 75, Windows tells : "USB Device Not Recognized".

And AMPLIFI Utility tells : "No AMPLIFI Devices were detected."

 

I checked on "Device Manager" and I see "Unknown USB device" so I choose "Update driver" and I select the one I download for you site. And Windows tells me "The driver is up to date" but it is still Unknown.

 

Can you help me?

 

Thank you.

Best Regards.

 

Share this post


Link to post
Share on other sites

It might have older firmware.

Do you have an iOS device to check the firmware, or try the Utility on another computer.

Share this post


Link to post
Share on other sites

Actually, I tried already with 3 PC 2 in Windows 8.1 and 1 in Windows 7.

 

Now I update an iPad to 8.3 to install AMPLIFI... Will see!

Share this post


Link to post
Share on other sites

No, in fact, the iPad sees the new firmware (2.10) but the PC and Android do not see it.

I do not know what to do now.

Share this post


Link to post
Share on other sites

Again me :)

I haven't try again with the PC, but now Android is OK.

 

I forgot the BT AMPLIFI 75 7a in the Android device (THL T200 Android 4.2.2).

I uninstalled Amplifi remote in the THL T200.

I made a factory reset on the Amplifi 75.

I start Amplifi 75 and I connect with BT the THL T200.

I installed Amplifi remote in the THL T200.

I loging.

And it's works!!!

 

Thank you.

Best Regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×