Jump to content
Huambo81a

Podfarm, UX2, and Windows 10

Recommended Posts

its my guess they wont work...Windows 10 wont even play youtube videos for me correctly.  I hooked up my guitar port yesterday.  my patches will work and play through my studio monitors but, if I try to use the player to practice along with Mp3;s nothing....no sound of the mp3 and the player doesn't even start.  I have not tried my podx3 live with it yet so well see..curse you bill gates and your fellow nerds,,give me Win95 back please

Share this post


Link to post
Share on other sites

I'm also having problems....

 

Bizarrely, if I open POD Farm or Reaper audio works fine. But that's it, I can't get audio from Spotify or any web browser, and if I test the device it fails to play the test tone. Installed the latest driver and that made no difference.

 

I have a gig I'm rehearsing for and now I can't play along to music now, I have students to teach and I need to be able to play music for the lessons. So I really hope there's a solution to this.

Share this post


Link to post
Share on other sites

To get basic sound output on the UX2 in Windows 10 do this:

 

QcTuT7T.png

 

 

You can usually have 'allow exclusive mode' on, turn it off you experience any issues with certain apps.

 

Thank you! I can stop freaking out now.

  • Upvote 2

Share this post


Link to post
Share on other sites

Same as others, updated the drivers yesterday...UX2/Pod Farm 2...works when default format (DVD Quality) is changed but audacity won't work which I use for effects and editing. I have a workaround but look forward to a final resolution.

  • Upvote 1

Share this post


Link to post
Share on other sites

Same here not getting any inputs on skype, mumble etc. Really would like to get driver update for this...

Share this post


Link to post
Share on other sites

So, most of you lads are still having trouble getting the mic/input working with basic Windows apps like Skype, Mumble, TeamSpeak, Audacity, etc.

 

Yet, I've got it working on mine.

 

fumX92E.png

 

 

Audacity works with the MME, DirectX and WASAPI drivers.

 

YqYKC1Q.png

 

 

The only other significant configuration differences I can think of is that I have all my USB ports 'selective suspend' and 'allow Windows to power down' settings disabled in Device Manager and Power Options. But, perhaps the biggest difference is the following.

 

Have you noticed that when booting up after shutting down Windows 10 it's significantly faster than restarting?

 

This is because when starting from the PC being off Windows 10 uses an accelerated method called fast startup. It basically stores various parts of your machine's memory state in a hibernation file and loads it when you turn on. This is faster than loading the drivers and other system files individually as is the norm.

 

fZbrhOc.png

 

 

On my system I disabled hibernation, and consequently fast startup, because I never use it and it leaves a large file (hiberfil.sys) on the disk.

 

I did this by opening a command prompt and typing: powercfg -h off

 

You may not want to do this, so instead you may want to just try disabling fast startup via the Control Panel:

 

0b1MCRc.png

 

XJkLLUY.png

 

O2dxg0e.png

 

This may be connected with gl0ry's boot issue?

 

Let us know if you have any success with these tweaks.

  • Upvote 1

Share this post


Link to post
Share on other sites

So, most of you lads are still having trouble getting the mic/input working with basic Windows apps like Skype, Mumble, TeamSpeak, Audacity, etc.

 

Yet, I've got it working on mine.

 

fumX92E.png

 

 

Audacity works with the MME, DirectX and WASAPI drivers.

 

YqYKC1Q.png

 

 

The only other significant configuration differences I can think of is that I have all my USB ports 'selective suspend' and 'allow Windows to power down' settings disabled in Device Manager and Power Options. But, perhaps the biggest difference is the following.

 

Have you noticed that when booting up after shutting down Windows 10 it's significantly faster than restarting?

 

This is because when starting from the PC being off Windows 10 uses an accelerated method called fast startup. It basically stores various parts of your machine's memory state in a hibernation file and loads it when you turn on. This is faster than loading the drivers and other system files individually as is the norm.

 

fZbrhOc.png

 

 

On my system I disabled hibernation, and consequently fast startup, because I never use it and it leaves a large file (hiberfil.sys) on the disk.

 

I did this by opening a command prompt and typing: powercfg -h off

 

You may not want to do this, so instead you may want to just try disabling fast startup via the Control Panel:

 

0b1MCRc.png

 

XJkLLUY.png

 

O2dxg0e.png

 

This may be connected with gl0ry's boot issue?

 

Let us know if you have any success with these tweaks.

 

Thanks for the info just startin', I will look these settings over.

Share this post


Link to post
Share on other sites

I've tried disabling fast startup, different usb ports, the new drivers from Pod Farm, running Pod Farm in Win8 compatibility and the 48k 16bit settings. None work and any audio outputting through the UX1 is garbled/distorted and youtube videos play 10x slower. 

Share this post


Link to post
Share on other sites

ChucklesM had the right fix for me.  I went to advanced speaker properties for UX6 default speakers and put the quality at 16 bit (DVD).  Now all works well.

  • Upvote 1

Share this post


Link to post
Share on other sites

I spent so many hours now fixing this, and it still doesn't work, I tried every single solution written here over and over.

 

@syotani, your solution sounds super plausible but unfortunately the MIC still doesn't work. It worked for me for a couple of days by randomly switching USB ports but its broken again.

Share this post


Link to post
Share on other sites

Same problem with me, my Ux2 is picking up my mic just fine but Win 10 doesn't pick up any input from my Ux2. Tried changing the sound advanced options, changing USB, turning off fast startup and using different versions of the driver. Nothing

Share this post


Link to post
Share on other sites

hello there, i have changed my OS from Windows 7 to Windows 8.1 Pro. And i have no serious issues, except for the fact that

in the advanced options of my UX2 i no longer have the 48/24-bit option. It says "not suported by the device".

 

Will this problem ever be fixed? ..it sucks.. 

Share this post


Link to post
Share on other sites

OK, so I've hacked the crap out of the streamlined Win 10 box that I've been testing the UX2 on. It would be impractical to go through all the Microsoft and Windows things I've disabled, removed, configured, etc.

 

If none of the previous things I have posted have worked for you then you may be heading into 'clutching at straws' territory. So, it probably won't hurt if I just start posting the tweaks on my box that might have some relevance, as they occur to me.

 

 

For the record, I'm running a clean install of Windows 10 Pro 64bit, 4.2.7.1 drivers and Pod Studio UX2.

 

 

Here's two, disable app access to mic and disable background apps.

 

RlR5OWj.png

 

lieaK7w.png
 

Share this post


Link to post
Share on other sites

I know that Line 6 is aware of and working to resolve the Win10 issues. I don't know when they'll get things worked out, but they're on it.

Share this post


Link to post
Share on other sites

My issue has mostly been with using Audacity (Internal port audio error)...I installed an older version 2.0.2 and it works...so I can work fine until all issues are sorted out.

Rock on!

Share this post


Link to post
Share on other sites

Spent another 2-3 hourse on fixing it, nope it won't work. everything worked so perfectly with Windows 8, I'm done. everything works except my Line 6 products.

Share this post


Link to post
Share on other sites

Launch under Windows 10 on compatibily mode windows 7. Click right on icon then properties and It's ok

Share this post


Link to post
Share on other sites

Yesterday I posted a similar problem on the Audacity forums after trying to get this sorted out with a Cycling '74 tech over email. 

We definitely have a pattern here - I've been looking at this all day. Plug in an ASIO USB soundcard and Audacity does not "see" any MME, WASAPI or DirectSound drivers/devices. Unplug and Audacity comes up.

Windows 10 upgrade (build 10240)
Audacity 2.1.1
Line 6 Toneport UX1 - 4.2.7.4 driver
Realtek High Def Audio on board - 6.0.1.7535 driver (was disabled until today)
My audio cable setup now is the MME on board device feeding into the monitor in on the Toneport (a typical setup)

This also happens for Cycling 74 Max 6 & 7
Max 4 Live in Ableton Live can open devices but can't edit
I believe that MSP (associated with Max) can only run under MME as well, so there appears to be a link. 

Ableton Live 9.2 cannot see MME until USB is unplugged
Reason 7.1.1 & FL Studio 11.1.1 can see everything all the time

BTW the Toneport cannot be controlled by the Windows Audio tray icon (Control Panel applet). You can only change volume with the hardware knob on it.

I've tried 
- writing to Cycling - they said the audio driver loads right before the Max program crashes
- Using just the TonePort (my on board Realtek card has been disabled pre-Win 10 - I only enabled it in BIOS when I saw other users were having these types of results)
- with Max 6, I uninstalled both 64 and 32 bit versions and then reinstalled 32...then reached for Max 6, 32 bit - only works if Toneport is unplugged
- 41 and 48K for both devices
- swapping default device
- toggling the exclusive device checkboxes on both soundcards
- reinstalling all the Line 6 software - suspiciously, their Win10 driver has a date of 2013 on it!

I was subsequently asked on the Audacity forum if Audacity 2.0.3 worked, so I installed it into another folder and it worked...now if I can only get Max and Max4Live to work.    

Share this post


Link to post
Share on other sites

I've tried disabling fast startup, different usb ports, the new drivers from Pod Farm, running Pod Farm in Win8 compatibility and the 48k 16bit settings. None work and any audio outputting through the UX1 is garbled/distorted and youtube videos play 10x slower. 

I have the same issue. :(

Share this post


Link to post
Share on other sites

For the record, I'm running the latest Audacity, 2.1.1, without issues.

 

MS is rolling out a major update, going by the name of Service Release 1, starting tomorrow.

 

Let's hope this will sort out some of you out.

 

 

Oh, and my thought for the day is this:

  • Right click on the Start button
  • Select Command Prompt (Admin)
  • Type: sfc /scannow
  • Hit ENTER

It will probably take a while to run. What it does is repairs/replaces corrupted system files and configurations. It usually clears up a ton of problems with Windows 10 upgrades and installs.

  • Upvote 1

Share this post


Link to post
Share on other sites

To get basic sound output on the UX2 in Windows 10 do this:

 

QcTuT7T.png

 

 

You can usually have 'allow exclusive mode' on, turn it off you experience any issues with certain apps.

you are my hero!

Share this post


Link to post
Share on other sites

you are my hero!

 

No worries.

 

Haven't they release the service pack 1 a few days ago already? Called KB3081424.

 

That was a cumulative update.

 

SR1 is supposed to have major fixes for all the upgraders with problems plus some new features.

Share this post


Link to post
Share on other sites

Okay, I hope this will fix something, I don't know what to do beside waiting for a miracle, I tried everything over and over. All I want is green moving bars on my output :(

 

Btw I tried your scan, it didn't find any errors.

Share this post


Link to post
Share on other sites

Haven't they release the service pack 1 a few days ago already? Called KB3081424.

 

I don't think that was a service update it was a cumulative update. Cumulative Update for Windows 10 for x64-based Systems (KB3081424)

Share this post


Link to post
Share on other sites

Same problem here. Sound works with 48000Hz but no mic on Skype or Teamspeak. Only in Podfarm and Reaper i can record with my mic. Anyone knows how long it will take until the driver gets released? I really really need a working mic here. (sorry for bad english)

Share this post


Link to post
Share on other sites

Hi, 

 

also encountered the same issues  with my Line 6 POD UX 2 after the installation of  windows 10. Changing to 48 khz also solved the playback issue for me.

 

After disabling and enabling the line 6 device on the recording tab in sound properties, recording in Audacity is now working for me!! Even after rebooting windows 10 it's still working (sample rate: 44100 Hz) .Hope this helps!

 

Hint: after disabling the device in sound properties make sure you have the option "show disabled devices" checked in order to enable it again.

 

Greetings from Germany

Share this post


Link to post
Share on other sites

I've been having the same issue with the UX1 :/. Yesterday I got the latest driver and it worked perfectly! The next day I boot up, doesn't work again...

Share this post


Link to post
Share on other sites

Wanted to post what worked for me,

 

In sound playback properties set your default format to 16 bit 48000 DVD quality

 

BUT...most importantly your USB device MUST be plugged directly into a USB 2.0 port (no hub and NOT 3.0) 

 

EVERY SINGLE OTHER CONFIG I tried was bunk, but this one is working ACES!  ;)

Share this post


Link to post
Share on other sites

Wanted to post what worked for me,

 

In sound playback properties set your default format to 16 bit 48000 DVD quality

 

BUT...most importantly your USB device MUST be plugged directly into a USB 2.0 port (no hub and NOT 3.0) 

 

EVERY SINGLE OTHER CONFIG I tried was bunk, but this one is working ACES!  ;)

OMG! This worked for me! What a stupid bug but thank you, now it works. Hope they will fix it, so it works on USB 3.0 too .

 

Edit: On my Front USB 3.0 it works too. but on my rear USB 3.0 i doesn't work.

Share this post


Link to post
Share on other sites

Wanted to post what worked for me,

 

In sound playback properties set your default format to 16 bit 48000 DVD quality

 

BUT...most importantly your USB device MUST be plugged directly into a USB 2.0 port (no hub and NOT 3.0) 

 

EVERY SINGLE OTHER CONFIG I tried was bunk, but this one is working ACES!  ;)

 

This doesnt work, I have already been there a week ago.

Share this post


Link to post
Share on other sites

Wanted to post what worked for me,

 

In sound playback properties set your default format to 16 bit 48000 DVD quality

 

BUT...most importantly your USB device MUST be plugged directly into a USB 2.0 port (no hub and NOT 3.0) 

 

EVERY SINGLE OTHER CONFIG I tried was bunk, but this one is working ACES!  ;)

Yeah I tried this before, as well as a moment ago. I have the settings for the device to 16 bit 48000 DVD Quality. Also plugged into a USB 2.0 port. No difference still no audio through to my PC. I see that PodFarm picks up sound, but in the audio control panel, no movement on the audio levels for the device...:/

 

Thanks for the help though!

Share this post


Link to post
Share on other sites

No worries.

 

 

That was a cumulative update.

 

SR1 is supposed to have major fixes for all the upgraders with problems plus some new features.

 

I'm still having issues with getting any sort of microphone input after trying all of your suggestions.

The only thing that is working for me is going to Devices and Printer, right clicking and removing the UX2 and then plugging it into a different USB port. Weird thing I noticed when the UX2 is working is that it starts using drivers that date back to 2006 from Microsoft and not the Line 6 4.2.7.4 drivers.

 

I never upgraded to Windows 10 from Windows 8.1, I did a fresh install from USB when the ISO's were released for MSDN users so I don't think the service pack update is really going to have much of an effect on my install.

Share this post


Link to post
Share on other sites

I'm still having issues with getting any sort of microphone input after trying all of your suggestions.

The only thing that is working for me is going to Devices and Printer, right clicking and removing the UX2 and then plugging it into a different USB port. Weird thing I noticed when the UX2 is working is that it starts using drivers that date back to 2006 from Microsoft and not the Line 6 4.2.7.4 drivers.

 

I never upgraded to Windows 10 from Windows 8.1, I did a fresh install from USB when the ISO's were released for MSDN users so I don't think the service pack update is really going to have much of an effect on my install.

I know that wasn't in response to me, but I just tried it. Removes my UX1 (I know it's different to what you said) then replugged in new port. It installed, still doesn't work. Thanks for the open advice though :P. I'm guessing it's just a driver bug that'll be fixed hopefully soon. Like I stated earlier, when I first installed the driver update for win 10 support, it worked fine.

Share this post


Link to post
Share on other sites

  Weird thing I noticed when the UX2 is working is that it starts using drivers that date back to 2006 from Microsoft and not the Line 6 4.2.7.4 drivers.

 

For reference, these are the drivers I'm using:

 

GbeC1AO.png

 

dOlf0bT.png

 

je4qg4c.png

 

fvE6oqs.png

 

Share this post


Link to post
Share on other sites

I was in the same boat and minus my SLI.  SLI started working yesterday mic input for my KB37 started today!!  I have no particualr reason.

 

Mell

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×