Jump to content

Podfarm, UX2, and Windows 10

Recommended Posts

Hi, having been driven crazy for a few days the setup below go my system working FIRST MAKE SURE POD FARM IS NOT RUNNING Then

open line6 audio midi devices from start menu. 

select Inputs and recording Tab >> Select Source (Example Inst. & Mic1.)

Select Driver Tab >> Click on <Sound control panel> and set to Dvd Quality as per earlier posts.

Click <Apply> then <Ok> to close Audio midi devices control panel.

Now start POD Farm

you should now have the ability to select Instrument / Mic1 for tone A or if set to Dual for BOTH.


Everything should be working ok from them on.


Oh also had really bad crackling audio and found setting buffers to EXTRA SMALL fixed it, was not expecting that had been making them bigger and bigger with no effect.


hope it helps someone.




Share this post

Link to post
Share on other sites


After spending hours working through all the previous solutions updating BIOS, updated chipset, tried the bit rate, nothing was working. drivers were installed properly It recognized my toneport ux2 but in the hardware settings showed it as inactive. couldn't get sound in or out. found that

There is an issue with UAC.


Turn off user account control in windows. works fine now. :D


windows 10 build 15063.138

toneport ux2


Share this post

Link to post
Share on other sites

Here's some more straw-clutching things for desperadoes to try:


1) Only have the UX2 connected to a USB 2 port. USB 3 ports will typically be coloured blue.


2) Check your motherboard manufacturers website for updated Windows 10 drivers for chipsets and USB. If you don't know your motherboard make/model/chipset then you can use CPU-Z to get this information.


3) If your motherboard has no updated drivers, and you have an Intel chipset, then try the Intel Chipset Update Utility (ignore the fact that it does not show support for Windows 10 yet). You can also try the Intel Driver Update Utility.


4) If your motherboard has no updated drivers, and you have an AMD chipset, then try the latest AMD chipset drivers.


5) Open Device Manager, expand Universal Serial Bus controllers and determine which USB Root Hub your UX2 is connected to and uninstall the hub. Reboot and the hub will be detected and drivers will be reinstalled.










6) For good measure you can also make sure power management is turned off on that hub.





Switching to USB 2.0 ports works for mine. Thanks for the information although this is really weird.

Was ready to gave up on it no thanks to Line 6 lack of help...

Share this post

Link to post
Share on other sites
On 6/10/2015 at 3:37 AM, Huambo81a said:

Hi there, 


Just wondering if Podfarm and my UX2 are going to work if i upgrade to Windows 10?


I have asked Line 6 support, and they havent been able to offer a satisfactory answer. 



am, currently installing W 10 . I am having difficulties installing it as some drivers are outdated so recommendation is to download on line however that seems to require Winsip Update and Steinberg Downloader!!!!    needless to say after tooo many h ours  this thing better work !!!  gimme somme feedback  BTW  this is my first install using any type of electronic device(audio interface) so this is all new too me but I hope I was able to assist someone  and help me out at the same time


Share this post

Link to post
Share on other sites

no!!!! Line 6 pod x2 does not works under windows 10!! That I have to install another windows 7 on my pc!! That pissing me off but

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...