Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod HD500 not working.


Recommended Posts

Hi. i was updating my pod Firmware. i tried updating it for atleast 10 times. it was showing an error saying "please check if the cable is connected". I tried fixing that issue. connected my usb cable gain. turned off and turned on my POD but couldnt get through the firmware update. later i realised that the pod has stopped working. Now i cant switch my patches. There is no sound coming out. It is turned on but nothing is working. i can see the display. it shows everything normal. but nothing is working but a display and footswitch LEDs. i tried global reset and it is still not working. Please help me with this asap. I have attached 2 photos to show the current status of my pod.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...