Please ensure Javascript is enabled for purposes of website accessibility Jump to content

UX2 Surface Pro 2 and various powered HUBs

Recommended Posts

To begin with, I'm aware that Hubs are not supported by Line 6 and the TonePort UX2, but I'm hoping someone with a bit more knowledge and experience than myself can make some suggestions to nail a particular incompatibility, or confirm the same problem with their own Surface Pro 2.


So the Surface Pro 2 has a single USB3 port and pretty good overall performance. If I plug my UX2 directly in to this USB port, all works well. Very well! Windows 8.1 (full not RT), i5 2.5GHz 4 core, 8GB RAM, x64, 256GB SSD.


When I introduce a bus powered USB hub, the device red lights and does not have enough power to fire up - as expected.


With a powered USB hub (with nothing else connected), it fires up. I can connect to it fine through PodFarm, Monkey, License manager etc. However, any and all audio sounds like either there is a significant playback rate mis-match (slow, garbled and distorted), or a continually stuttering bus flow.


So I've tried several different USB powered Hubs. I've also used a USB analyser (USBlyzer) and when comparing the state between direct connection and via hub, all is identical (connection speed, power usage etc.). Even the event log of playing a windows test sound in both scenarios issue the same commands and get the same close connection results.


I also note that while TonePort via a powered hub is not supported, there are instances it works. So I am hopeful there is something further I can uncover here.


Any help would be gratefully appreciated!


TIA - Omar

Link to comment
Share on other sites

So as an update... here is a video of the TonePort UX2 connected via one of literally 10 powered USB hubs I've tried, connected in to the Surface through it's single USB port (all with the same result).


In the first video I play the test tone through the built in speakers. Then I play the test tone via the UX2 interface. The sound is via speakers connected to the headphone port, but the same is experienced on the line outs and the SPDIF out.


The second video is the TonePort UX2 connected directly (no Hub) to the same USB port.



I know, I know, USB hubs aren't supported. Given the number of systems I've tried this on and number of powered hubs I've been through, and given there are people out there with some success (even problem resolution) by using a powered hub... I can't help but feel there is a setting or driver issue specifically causing the problem.


One other important point. I can replicate this behaviour across multiple machines when the port on the PC is USB3 (works fine with USB2). The problem I have with the Surface is it only has a single USB and it is USB 3!?


:( sad times.

  • Upvote 1
Link to comment
Share on other sites

  • 4 years later...


I have dusted off my UX2 after several years of not using it.

I got the Surface pro and ran into the same problem as you.

It has only one USB port and I am trying to use a MIDI controller at the same time with UX2.

Tried several HUBs, 2.0, 3.0, powered and unpowered.

Same problem - garbled output.

Did you ever find a solution?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...