Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Win 10 Audacity, Max, Max4Live won't work unless Ux1 Toneport is unplugged

Recommended Posts

I posted this under a general Win 10 topic yesterday but the thread went in another I'll post again in hopes that someone else is seeing this same issue.  To clarify, audio works fine for most default applications and Toneport ASIO works fine in DAWs like Live, Reason & FL Studio.  Other programs - those that need to see drivers other than ASIO - will not be able to use their driver unless the Toneport USB is disconnected.  Please read through the post before offering standard troubleshooting advice - thanks.  

USB 2.0 & 3.0 were also tried. 

On 8/7, I posted this on the Audacity forums after trying to get this sorted out with a Cycling '74 tech over email. 

We definitely have a pattern here - I've been looking at this all day. Plug in an ASIO USB soundcard and Audacity does not "see" any MME, WASAPI or DirectSound drivers/devices. Unplug and Audacity comes up.

Windows 10 upgrade (build 10240)
Audacity 2.1.1
Line 6 Toneport UX1 - driver
Realtek High Def Audio on board - driver (was disabled until today)
My audio cable setup now is the MME on board device feeding into the monitor in on the Toneport (a typical setup)

This also happens for Cycling 74 Max 6 & 7
Max 4 Live in Ableton Live can open devices but can't edit
I believe that MSP (associated with Max) can only run under MME as well, so there appears to be a link. 

Ableton Live 9.2 cannot see MME until USB is unplugged
Reason 7.1.1 & FL Studio 11.1.1 can see everything all the time

BTW the Toneport cannot be controlled by the Windows Audio tray icon (Control Panel applet). You can only change volume with the hardware knob on it.

I've tried 
- writing to Cycling - they said the audio driver loads right before the Max program crashes
- Using just the TonePort (my on board Realtek card has been disabled pre-Win 10 - I only enabled it in BIOS when I saw other users were having these types of results)
- with Max 6, I uninstalled both 64 and 32 bit versions and then reinstalled 32...then reached for Max 6, 32 bit - only works if Toneport is unplugged
- 41 and 48K for both devices
- swapping default device
- toggling the exclusive device checkboxes on both soundcards
- reinstalling all the Line 6 software - suspiciously, their Win10 driver has a date of 2013 on it!

I was subsequently asked on the Audacity forum if Audacity 2.0.3 worked, so I installed it into another folder and it if I can only get Max and Max4Live to work   Of course, I'd rather use the latest Audacity.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...