Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Amplifi Android - Can't connect as amp


Recommended Posts

Hi all,


I've got a combination of:


Google Nexus 4 running Android 5.1.1

Amplifi Remote app v2.13.0

Amplifi 75 v 2.10.0


I can connect to the unit using Bluetooth, and play audio out, but the Amplifi never shows up as a connected device.  If I go to settings, I get a message of "It appears you are connected to an AMPLIFi device, but its firmware is not up to date.  Please update your AMPLIFi"


PC based Amplifi Utility confirms it's on latest firmware.


Any suggestions?

Link to comment
Share on other sites

Several factory resets, and Utility shows 2.10.0.  I've since raised a support ticket, and they've pointed me in the direction of the Line 6 Updater software, as well as some more recent drivers.  


Unfortunately I can't seem to use the PC based tools to update the unit, so I'm a bit stuck again!  Running Windows 7, 64-bit (which looks like it might have some issues based on a couple of forum posts I've read) I get an error message along the lines of "Don't unplug your unit whilst it's updating".  I've tried various USB ports, and have ensured the software was launched with admin rights, but no improvements.

Link to comment
Share on other sites

Success!  Part of the support ticket suggested I also do the following:


"Now go to Bluetooth settings of your Android, forget the Amplifi, turn Bluetooth off. Delete the Remote App, power cycle the Android, reinstall the app, turn Bluetooth on and re-pair the devices.

Launch the Amplifi Remote App and see if it works now."


Even though the amp update didn't work, re-doing this on my phone solved the issue.

Link to comment
Share on other sites

  • 2 months later...

He needed help to connect the amplifi 75 ( v.2.50 ) with a tablet , Android ( 4:42 ) .

I can hear the Amplifi , mp3 coming from the tablet , but not AMPremote not recognize the Amplifi 75 .

The AMPLIFIremote menu below " voice search " appears " Buy Now " instead of " Amplifi CONNECTED "

I did all updates ( amplifications and Android ) , but I can not connect.

Can sombody help me, please?

thank you

Link to comment
Share on other sites

Hi nbanda - can you get access to an iPad?- this worked for me..



My Amplifi 75 needed to be updated in order to work with Amplifi Remote on Android.
The Amp connected by Bluetooth to my Android Samsung Pad but Amplifi Remote told me the Amp would have to be updated.
Unfortunately The amp was unable to connect by USB to 3 different Windows 7 computers - so no update via Line 6 Updater software.
As it is currently not possible to update the firmware version of my (new) amp by Bluetooth using android - I had to borrow an iPad and setup the Amplify Remote app so I could carry out the update. (this required the owners passwords etc)
After rebooting my Samsung Tab , the Amplify Remote App was able to see the Amplifi 75, and I finally was able to start using them together.
I was fortunate that I could borrow an iPad, but I suspect that not everyone will be in a position to do this and that I am not alone in having to jump through hoops in order to get the Amplifi 75 to work as advertised.
A real hassle. I suggest that Line 6 should look into this as a matter of urgency with Christmas less than a month away.
  • Upvote 1
Link to comment
Share on other sites

  • 1 month later...

Hi, i had a similar problem. Support send me these steps which i executed exactly and this worked for me:


first, please reinstall the firmware of the Amplifi using the latest version of Line 6 Updater for Mac or PC:


If you are using a PC, install the latest ASIO driver as well.

Connect the amp via USB to your computer and put it into update mode before updating: 

Boot the unit while holding Tone+Tap.


Launch the updater, login and update to the latest firmware version. Line 6 Updater should recognize the Amplifi automatically. If not, try different USB ports/cables. Don't connect to a hub.

Please perform a factory reset on the Amplifi afterwards:

Press and hold the Master Volume knob and Tone button as you power up the amp.


Now go to the bluetooth menu of your mobile device, forget the Amplifi, turn off bluetooth, delete the remote app and power cycle the mobile device. Then reinstall the app, turn on bluetooth and re-pair the devices by pressing and holding the bluetooth button on the amp until it flashes fast.

Run the app and see if it works now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...