Jump to content
Sign in to follow this  
Palico

DT25 Effects looper buffered?

Recommended Posts

I suspect it's not and normally most amps would not be. Just curious, my POD recently died and I decided for the time being not to replace it. I'm using about 25 ft of cable to and back from the effects loop to a Vox Time Machine pedal. The pedal is a buffered bypass but If I'm correct the amp would still see any capacitance on the 25ft going to the pedal.  And I do notice a slight roll off of high end, not horrible mind you but just trying to make sure I understand the problem so I can adjust address it. 

 

If the amp was buffered out then I would expect to see no roll off of treble, of course the slight coloring could be the pedal itself too. Just curious if anyone knew. 

Share this post


Link to post
Share on other sites

Okay I think I found the answer to my own question. The DT25 is using a line level send on the effects loop. Explains the slight loss of high end on the loop, likely not related to the length of the cable as much as just level mismatch.

Share this post


Link to post
Share on other sites

Okay I think I found the answer to my own question. The DT25 is using a line level send on the effects loop. Explains the slight loss of high end on the loop, likely not related to the length of the cable as much as just level mismatch.

 

Is it possible to award one's self with the "correct answer?"   :huh:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×