Jump to content
Sign in to follow this  
lordalladin

Helix Expression Pedals

Recommended Posts

I was wondering if someone could tell me if the secondary expression output on the back of the unit is a TRS? Also what expression pedals can be used with the Helix?

Share this post


Link to post
Share on other sites

It's TS, and the EXP jacks are auto-sensing and auto-calibrating, so they should work with just about any potentiometer based pedal out there.

Share this post


Link to post
Share on other sites

I have a POD HD and the line 6 pedal has about a 1/4" of travel before it starts working. Would this still be an issue with the Helix?

Share this post


Link to post
Share on other sites

I have a POD HD and the line 6 pedal has about a 1/4" of travel before it starts working. Would this still be an issue with the Helix?

Nope.

Share this post


Link to post
Share on other sites

I hate to say it, but that annoyance with my second pedal is enough to seriously consider this, that and changing parameters on the HD is so cumbersome I have lived with the tones I setup the first week for a very long time...

Share this post


Link to post
Share on other sites

 

 

I have a POD HD and the line 6 pedal has about a 1/4" of travel before it starts working. Would this still be an issue with the Helix?

 

FWIW  - the Roland EV-5 with TRS cable connection to HD500X works immediately and smoothly

 

Many "poo-poo" the EV-5 - but mines been flawless for 19 years ( got it for my 1996 Boss GT-5)

and Dweezil loves them

1432406281_1049512123_IMG_10621.JPG

 

 

 

1430362792_1773100619_IMG_1050.JPG

  • Upvote 1

Share this post


Link to post
Share on other sites

I have 2 x EV5 and have had no problems making them control HD500, Yamaha Motif and loads of other gear (although you do need to make sure the minimum volume is set to zero with the HD500) - must be about 25 years old.

  • Upvote 1

Share this post


Link to post
Share on other sites

FWIW  - the Roland EV-5 with TRS cable connection to HD500X works immediately and smoothly

 

Many "poo-poo" the EV-5 - but mines been flawless for 19 years ( got it for my 1996 Boss GT-5)

and Dweezil loves them

 

 

Nice setup! I mounted my HD500 in a box top like that along with my aging Crate Powerblocks so minus the cabs everything was in one spot.

 

I just bought the Line 6 pedal and their support said that little bit of travel before it kicks in was normal. I am ordering an EV-5 now!

Share this post


Link to post
Share on other sites

I use a "insert" cable (TRS -> 2-TS)  coupled (with a stereo TRS coupler) to my EV-5. I plug in the "tip" TS cable into my Helix (and the "ring" TS cable end is not plugged in). It works great!

(I'm using the "insert" cable to bypass the ring connection—I could rewire the pedal so it is TS only).

If I plug the pedal in normally, the volume (or other parameter) works correctly from "heel down" to mid-pedal. Then the volume (parameter) start to decrease until it is off at "toe down". It's an interesting effect, but I don't want that behavior. I just use my adapter "system" instead of rewiring the pedal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...