Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Sonic Port Vx 1.76 drivers Win10 and Riffworks


Recommended Posts

  • 3 weeks later...
  • 3 weeks later...

the sonic port just damaged a few of my PCs, once unplugged it destroyed the dll files for my recording section of the control panel, now i cannot acces ANY of my recording devices, and reaper will not open because it cannot find any recording interface whatsoever, as soon as i click on the "recording" tab in the control panel it says not responding, so i cannt access ANY OF MY recording devices or softwares, because i put the sonic port vx in and when it came out it somehow raped my Registration, LOOK AT YOUR CODING there is something wrong if ur device is destroying and crippling ppls PCs im sure im not the only one who has seen this, i used such seperate PCs and the same results within moments of a first recording of each, seriously guys send this message to your developers there is a DLL Mistake if its removing components or leaves false imprints on the memory of PCs

Link to comment
Share on other sites

  • 3 months later...

I cannot seem to get any of the drivers to work with Windows 10 ( 64 bit ) no matter what I do. Both 1.76 and 1.52 seems to crash the audio settings in the control panel, and when selecting it as an ASIO source, it just causes the program to hang. I cannot even get it to work with ASIO4ALL ( even if I could it wouldn't be good enough, as it only goes down to 512 samples which is too much latency ).


I'm under the impression that Windows 10 is not really a supported operating system after all. Is it realistic that we'll see a new driver release in the future, or do I really have to dual-boot a windows 7 setup to enjoy the VX in a desktop environment?


Link to comment
Share on other sites

  • 9 months later...

Just validated the same solution for the Windows 10 x64 (bit) issue with the ASIO drivers.


v1.76 didn't work on 64-bit Windows 10 initially, worked fine with WIndows 7 x64.


v1.52 worked fine - shows up immediately in the Control Panel -> USB Devices -> Sonicport VX


I did Run as Administrator... and I didn't uninstall 1.76 before running the 1.52 installer - I just sent the install to the same location.


And shows up in Audacity as both an available Recording and Playback device.


And I checked Reaper (x64) v5.30 Windows - working with both the Line6 ASIO 1.52 driver and the ASIO4ALL driver.


HOWEVER... I notice I currently cannot use both my AmpliFi ASIO Inputs at the same time as the Sonic Port (if I plug one USB in, the 2nd one will cut off the 1st one.) using the older 1.52 driver. Simultaneous use requires upgrading to the 1.76 Sonic driver and the 1.77 AmpliFi driver.  When both are updated, you can then use the AmpliFi to record while the Sonic VX is your FX processor.


AND, I notice that while I can get the Mobile POD on the iPhone working with output via the Sonic Port Line Outs (to address another observation about latency, I find the latency when trying to record from the Sonic out routed back into another ASIO line-in, such as my AmpliFi, or via a Presonus I/O, .)


The Sonic VX will disable the ASIO Recording and Playback inputs (to Windows) if both the USB to PC and Lightning are used simultaneously.  If I then disconnect the iPhone from the Sonicport, the ASIO/USB port re-activates again. This is true regardless of driver version, and in both Windows 7 and 10.  I think this is by design.  The USB port is only providing pass-through power if the Lightning is enabled (which answers someone else's question about trying to use the iPhone/iPod as an FX loop while recording in Windows (you would need another interface to connect the line-outs from the Sonic VX to the PC/Mac; in my case, I can use the AmpliFi as a route back into the PC to record the post-effects signal by the iPhone.)


Also both Recording and Playback devices show up in the Control Panel -> Sound as long as you don't have the Lightning port connected.


And of course, worked fine on Lightning to my iPhone SE on iOS 10.1.1 (about to see what happens with iOS 10.2...  And it looks fine so far with 10.2 on an SE.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...