Jump to content
Sign in to follow this  
Digital_Igloo

Helix Firmware v1.01.2

Recommended Posts

Helix Firmware v1.01.2 Release Notes

Helix v1.01.2 is a free firmware update that includes fixes and optimizations. It is highly recommended that all Helix users perform this update.

It is also recommended that you back up your current presets by using the Helix application to create a preset bundle, allowing you to install new presets as part of the update process.

The easiest way to perform the update process is by installing the latest version of Line 6 Updater. Once you've connected Helix to your computer via USB port (hubs are not supported), Line 6 Updater will recognize the unit and take you through the update process. The Line 6 Updater application may be downloaded here: http://line6.com/software/

Bug Fixes

  • In certain situations, while in Pedal Edit mode only, effects parameters may fail to appear on the scribble strips if an Amp+Cab block was previously selected. This only happens when navigating to an effects block’s parameters after viewing the third page of Amp+Cab parameters. â€”FIXED
  • Other minor bug fixes and optimizations

Other Improvements

  • Minor improvements made to the factory preset bundle

Loading the Newest Factory Presets (Optional)
IMPORTANT! Loading the factory presets will completely overwrite all existing presets and setlists! Back up your presets before proceeding!

  1. Turn off Helix.
  2. While holding footswitches 7 and 8 (two left-most switches on the bottom row), turn on Helix. Wait for the message “Will restore stock Presets and Setlists...†to appear and let go.

Known Issues

  • While a loop is playing, changing from a preset with the Looper block on Path 1 to one with the Looper block on Path 2 may cause a small portion of the recorded loop to play
  • If the Helix application is open, FS6 (EXIT LOOPER) may fail to work after changing presets while in Looper footswitch mode
  • Minor pops and clicks may be present when Helix is streaming audio from a Mac® running OS X 10.11 (El Capitan)
  • Minor pops and clicks may be present when Helix is streaming audio from an iOS® device with Apple® Camera Kit
  • On rare occasions while booting, noisy graphics artifacts may appear on the main display
  • The underscore character (“_â€) should not be used in Preset names or IR names. Redwirez IR names commonly contain underscore characters; in the meantime, rename these IRs until a fix is available
  • Streaming audio over USB while the Helix application is open may cause it to disconnect
  • In rare cases, pressing the Variax/Mags knob on a Variax (connected via VDI) while the Helix application is open may cause Helix to freeze
  • When using the stereo version of the Looper (almost all factory presets use a mono looper), pressing Undo may remove only the left channel
  • While in Pedal Edit mode, the expression pedal may only select values 0 and above for Pitch parameters; in the meantime, pressing FS10 can manually select negative values
  • The firmware version number will incorrectly appear as 1.01.02 in the Line 6 Updater and Helix applications
  • Upvote 1
  • Downvote 1

Share this post


Link to post
Share on other sites

no, usb, using the line6 updater utility (not monkey....)

Can updates be done with a flash drive?

Share this post


Link to post
Share on other sites

Please keep this up! I'm not saying that updates need to come out every week, but not so far out like with the HD500.

 

Thanks!

Share this post


Link to post
Share on other sites

I tried to run this update on a Mac w/ El Captian - it crashed halfway through and now my Helix is just stating 'Update failed please reboot and try again!'. I keep trying that but nothing is happening. I also tried the factory reset (holding 7&8) and that didn't work. Any other way to at least give it a complete restore to v1?

Share this post


Link to post
Share on other sites

I had the same issue... you have to try on a non cap machine...

i used an old windows laptop i had....

nothing is really ready for el cap yet...

 

I tried to run this update on a Mac w/ El Captian - it crashed halfway through and now my Helix is just stating 'Update failed please reboot and try again!'. I keep trying that but nothing is happening. I also tried the factory reset (holding 7&8) and that didn't work. Any other way to at least give it a complete restore to v1?

Share this post


Link to post
Share on other sites

I am on OS Yosemite and I am having problems updating. I can get 1.01 to load all day long but 1.01.2 keeps asking me for the application to load it into and Line 6 updater doesnt show my Helix.  I know im stupid but this can't be that hard.

 

Plus is there an available editor on your computer to create and edit patches like the HD500 because currently all I get when the Helix is opened is the patches on the left side of my screen and I can only change from one patch to another, or copy and paste patches. I tried to download from Customtone and got only two of four to actually load and play?

Share this post


Link to post
Share on other sites

there is no editor for helix... yet...

i'd try different usb ports and a reboot... (power cycle helix as well)

i've flashed many times on yosemite.... but the updater has to see it

Share this post


Link to post
Share on other sites

I tried a Windows 7 laptop. Installed L6 drivers and updater. It's crashing the laptop when I connect it via USB - BSOD. Any way to get this to reset to factory again totally before trying to install? 

Share this post


Link to post
Share on other sites

Finally got it! on a windows 7 laptop. Let it BSOD, but left the USB plugged in. Fired up line 6 updater as quickly as I could when it restarted and it did it. Hope an El Cap fix comes out soon. 

Share this post


Link to post
Share on other sites

I was able to install from my Win10 laptop and do the upgrade.  Backed up my setlist with presets and was able to import back onto the unit.

 

HOWEVER. 

 

1. None of my saved presets show up in stomp footswitch mode.  I noticed that right out of the box and was hoping the update would fix that.  I thought maybe b/c it's a new setlist so I resaved 1 of my presets onto an open preset in the Factory 2 setlist and they don't show there either.  (yes I am pushing FS6 and it does work on all the factory presets - just not new ones).

 

2. The expression pedal only works as a volume pedal.  I assign it to wah's and can get it to visually move the parameters but there is no audible differance (nothing happens).

 

TECH STAFF: any help?

Share this post


Link to post
Share on other sites

I was able to install from my Win10 laptop and do the upgrade.  Backed up my setlist with presets and was able to import back onto the unit.

 

HOWEVER. 

 

1. None of my saved presets show up in stomp footswitch mode.  I noticed that right out of the box and was hoping the update would fix that.  I thought maybe b/c it's a new setlist so I resaved 1 of my presets onto an open preset in the Factory 2 setlist and they don't show there either.  (yes I am pushing FS6 and it does work on all the factory presets - just not new ones).

 

2. The expression pedal only works as a volume pedal.  I assign it to wah's and can get it to visually move the parameters but there is no audible differance (nothing happens).

 

TECH STAFF: any help?

 

OK spoke too soon - found footswitch assign in the manual and figured out item 1.  My bad...

 

Still need assistance with item 2 - poured over the manual on controller assign which does work, except for actually hearing it audibly.

Share this post


Link to post
Share on other sites

 

Helix Firmware v1.01.2 Release Notes

Helix v1.01.2 is a free firmware update that includes fixes and optimizations. It is highly recommended that all Helix users perform this update.

 

It is also recommended that you back up your current presets by using the Helix application to create a preset bundle, allowing you to install new presets as part of the update process.

 

The easiest way to perform the update process is by installing the latest version of Line 6 Updater. Once you've connected Helix to your computer via USB port (hubs are not supported), Line 6 Updater will recognize the unit and take you through the update process. The Line 6 Updater application may be downloaded here: http://line6.com/software/

 

Bug Fixes

  • In certain situations, while in Pedal Edit mode only, effects parameters may fail to appear on the scribble strips if an Amp+Cab block was previously selected. This only happens when navigating to an effects block’s parameters after viewing the third page of Amp+Cab parameters. â€”FIXED
  • Other minor bug fixes and optimizations

Other Improvements

  • Minor improvements made to the factory preset bundle

Loading the Newest Factory Presets (Optional)

IMPORTANT! Loading the factory presets will completely overwrite all existing presets and setlists! Back up your presets before proceeding!

  1. Turn off Helix.
  2. While holding footswitches 7 and 8 (two left-most switches on the bottom row), turn on Helix. Wait for the message “Will restore stock Presets and Setlists...†to appear and let go.

Known Issues

  • While a loop is playing, changing from a preset with the Looper block on Path 1 to one with the Looper block on Path 2 may cause a small portion of the recorded loop to play
  • If the Helix application is open, FS6 (EXIT LOOPER) may fail to work after changing presets while in Looper footswitch mode
  • Minor pops and clicks may be present when Helix is streaming audio from a Mac® running OS X 10.11 (El Capitan)
  • Minor pops and clicks may be present when Helix is streaming audio from an iOS® device with Apple® Camera Kit
  • On rare occasions while booting, noisy graphics artifacts may appear on the main display
  • The underscore character (“_â€) should not be used in Preset names or IR names. Redwirez IR names commonly contain underscore characters; in the meantime, rename these IRs until a fix is available
  • Streaming audio over USB while the Helix application is open may cause it to disconnect
  • In rare cases, pressing the Variax/Mags knob on a Variax (connected via VDI) while the Helix application is open may cause Helix to freeze
  • When using the stereo version of the Looper (almost all factory presets use a mono looper), pressing Undo may remove only the left channel
  • While in Pedal Edit mode, the expression pedal may only select values 0 and above for Pitch parameters; in the meantime, pressing FS10 can manually select negative values
  • The firmware version number will incorrectly appear as 1.01.02 in the Line 6 Updater and Helix applications

 

 

I have two suggestions that worked for me but may or may not apply to others if you are using Windows 8 or 10 to run the Line6 Updater (formerly "Monkey").

  1. I could not seem to get the Updater to see the Helix until I installed the Helix "application" which also has the Helix drivers. Once I installed the Helix application the updater recognized the Helix. Not sure if I just did not wait long enough the first few times I tried to run the updater or if it was the installation of the Helix application that solved that issue.
  2. Several of us have experienced lockups on edited or user created presets after installing the 1.01.2 update. The solution was to run the "Loading The Newest Factory Presets (Optional)" procedure. Not enough time has passed yet to say whether or not this resolved the lockup issue but here's hoping.

Share this post


Link to post
Share on other sites

 

  1. I could not seem to get the Updater to see the Helix until I installed the Helix "application" which also has the Helix drivers. Once I installed the Helix application the updater recognized the Helix. Not sure if I just did not wait long enough the first few times I tried to run the updater or if it was the installation of the Helix application that solved that issue.
  2. Several of us have experienced lockups on edited or user created presets after installing the 1.01.2 update. The solution was to run the "Loading The Newest Factory Presets (Optional)" procedure. Not enough time has passed yet to say whether or not this resolved the lockup issue but here's hoping

 

1. Yep. On Windows, your PC can't see Helix at all without a driver. This is expected.

2. We're feverishly tracking every little thing down. Hopefully all will be gravy soon. There are a lot of different computers out there with a lot of video cards. Windows 10 is funky (for not just Line 6). Plus, on the Mac side, El Capitan is causing a lot of headaches (for pretty much everyone in the entire industry).

Share this post


Link to post
Share on other sites

I tried a Windows 7 laptop. Installed L6 drivers and updater. It's crashing the laptop when I connect it via USB - BSOD. Any way to get this to reset to factory again totally before trying to install? 

Just happened to me. Did you get a resolution? So bummed, I was really loving this thing

Share this post


Link to post
Share on other sites

Hi D

I got an Asus G751 so it's going to have a gaming vid card, if you have one of these pc's around give it a try. ( windows 10)

Till y'all get this worked out I'm staying on the firmware my helix came with 1.0 .

Share this post


Link to post
Share on other sites

I've tried updating the line 6 updater several times. Every time I check afterwards, it still says I have the same version as before. On top of that, the updater won't recognize my helix to get the latest firmware (1.06). Not sure what I am doing wrong. Any help would be appreciated!

Share this post


Link to post
Share on other sites

I've tried updating the line 6 updater several times. Every time I check afterwards, it still says I have the same version as before. On top of that, the updater won't recognize my helix to get the latest firmware (1.06). Not sure what I am doing wrong. Any help would be appreciated!

 

From what I understand, you can update Helix to the current firmware using the old version of the updater 1.04. Don't quote me on this, but something to the effect that the folder structure changed in the new installer version 1.07, and it mucks up the links when you try to update rather than clean install.

 

Try this- uninstall the existing L6 Intaller software from your computer entirely. Then, reinstall the L6installer software, and try from there.

 

If that doesn't work, uninstall the l6 installer again, then install the older version (1.04), and try to update your Helix using that.. I you go to the L6 software page, and get to the L6installer, then scroll down and access the downloads for previous versions; 1.04 was posted on

7/23/15.

 

This link should get you the 1.04 updater:

http://line6.com/getrelease?rid=6454&uid=1188905

Share this post


Link to post
Share on other sites

Still no luck on getting the updater to recognize the Helix.

 

I tried uninstalling the updater & reinstalled it. when I open it, it alerts me that there is a newer version of the installer. From there I've tried ignoring  this and installing the newer version but the result is the same. I am left with the same version of the installer no matter what I do and the Helix continues to be unrecognized by the installer afterwards.

 

When I've tried to download and open the bundle, i get a message saying that the file can't be opened because microsoft isn't supported by mac but I've made sure that I specify that I am using a mac with the correct version (OS X Yosemite) every time but the message always remains.

Share this post


Link to post
Share on other sites

Still no luck on getting the updater to recognize the Helix.

 

I tried uninstalling the updater & reinstalled it. when I open it, it alerts me that there is a newer version of the installer. From there I've tried ignoring  this and installing the newer version but the result is the same. I am left with the same version of the installer no matter what I do and the Helix continues to be unrecognized by the installer afterwards.

 

When I've tried to download and open the bundle, i get a message saying that the file can't be opened because microsoft isn't supported by mac but I've made sure that I specify that I am using a mac with the correct version (OS X Yosemite) every time but the message always remains.

 

In regards to the Helix not being recognized.  Make sure you have downloaded and installed the Helix App version 1.03 first. The Helix App has the driver that allows the Updater to see the Helix (or at least that is the way it worked in the past). Also try to avoid using a USB hub and if you are using a PC, use the USB connections on the back rather than the front panel if you have the option.

Share this post


Link to post
Share on other sites

I had to download driver version 1.76.0.1 before the updater would recognize my Helix.  It's not listed as firmware but as a driver in there download site

Share this post


Link to post
Share on other sites

I had to download driver version 1.76.0.1 before the updater would recognize my Helix.  It's not listed as firmware but as a driver in there download site

 

Glad you got it sorted out. I thought the Helix App included the necessary driver but maybe not?  I have been through several firmware upgrades and I can't remember exactly what I had to install in Windows 10 before the updater would recognize the Helix.  I do remember having to install either the windows driver or the Helix App. Whether it is the Windows driver or the Helix app it would probably be a good idea for Line6 to pin a post on the prerequisites for Windows (and Mac if there are any) for the Line 6 Updater and a Helix update. Your perseverance and this piece of information will probably help out some other users.

Share this post


Link to post
Share on other sites

I had to download driver version 1.76.0.1 before the updater would recognize my Helix.  It's not listed as firmware but as a driver in there download site

I don't see this driver version when I search for it. 

 

I've downloaded the latest updater but every time I do, I still get prompted to install the latest version upon signing in. 

Share this post


Link to post
Share on other sites

I don't see this driver version when I search for it. 

 

I've downloaded the latest updater but every time I do, I still get prompted to install the latest version upon signing in. 

I found this driver but I'm trying to update on a mac. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×