Jump to content

Helix Bug Reports


HonestOpinion
 Share

Recommended Posts

I would disagree with statement that "forwarding MIDI sys ex message from MIDI in to MIDI out has never been a feature claimed by Line 6". Go to user manual page 41 (Global settings > MIDI/Tempo) and you find the magic sentence : "MIDI thru : if you activate this parameter, MIDI out is acting as a MIDI thru and forwards ALL MIDI IN messages received on MIDI in" (translation from french version of user manual). It is exactly how the MIDI thru (from MIDI in to MIDI out) should behave: forwarding ALL messages from in to out. Fact is Hx effects filters some MIDI messages. Here it is sysex, but it could also be midi clock or whatever. When supporting this forward feature you have to forward everything, and not filter anything.

 

On other points I mentionned, I already opened a ticket for solving this, but unfortunately after making many tests requested by Line 6 support (firmware update, re-creating the issue on an empty device without reloading any backup...) and making image snapshots, line6 support was not able to help me... and ignored the issue closing the ticket.

 

Meatime I found a way to solve the issue, just in case some other people have the same problem :

1) in Hx editor, export just the preset (.hlx)

2) open it in a text editor, it's a JSON file

3) while all my Instant commands where really appearing in the Hx effects, it was not defined in the JSON file (how it was stored ?!? mystery...). So definitions generated by Hx Effects device were quite empty :

At file header, I had :

  "tone" : {

   "commandInst1" : {

    "@command" : 19

   },

   "commandInst2" : {

    "@command" : 18

   }, 

without any other definition, while there was some additionnal definition for the "working presets".

Then at snapshots definition section, I had (showing just one snapshot example) :

 "snapshot1" : {

    "@ledcolor" : 6,

    "@name" : "Lyrics",

    "@pedalstate" : 0,

    "@tempo" : 120.0,

    "@valid" : true,

    "blocks" : {

     "dsp0" : {

      "block0" : true,

      "block1" : true,

      "block2" : false,

      "block3" : false,

      "block4" : true,

      "block5" : false

     }

    },

    "commands" : {

     "commandInst2" : {

      "@fs_enabled" : false

     },

     "commandInst3" : {

      "@fs_enabled" : false

     }

    }

   },

As you can see, no parameters defined for each snapshot, rather an empty definition (and CommandInst1 was appearing in the Hx effects, while not defined at all in the JSON file).

 

It appears that most of the time preset export does not export the MIDI Instant commands parameters. So let's reconstruct it...

 

4) to update the file, add at the beginning of the file, just after the "tone" :

  "tone" : {
   "commandInst1" : {
    "@bank0" : 0,
    "@bank32" : 0,
    "@channel" : 0,
    "@command" : 4,
    "@current" : 0,
    "@program" : 0
   },  
   "commandInst2" : {
    "@cc" : 00,
    "@channel" : 0,
    "@command" : 1,
    "@value" : 0
   },

One section for each Command Instant you want.  Here you define the type of the command which will be used for each snapshot. Here is one example for a PC and another for a CC. The @command value defines the command type. It is PC=19 and CC=18 in some of my presets, and some other have saved PC=4 and CC=1. Seems that PC=4 and CC=1 works better in my case. Not sure why there is this difference, I suspect that there has been a firmware change and such values change... that would also explain the issue I face. In this section, I guess all values sets the default values for all snapshots if they are not re-defined in each snapshot.  If defined in one snapshot, each value overrides the default value (It's my guess, but I did not test it, so I prefer to make the default and each snapshot definition)

 

5) at the bottom of the file, in each snapshot section, modify the parameters you want to send for each command for this snapshot. eg :

   "snapshot0" : {
    "@ledcolor" : 8,
    "@name" : "Couplet",
    "@pedalstate" : 0,
    "@tempo" : 120.0,
    "@valid" : true,
    "blocks" : {
     "dsp0" : {
      "block0" : true,
      "block1" : true,
      "block2" : false,
      "block3" : false,
      "block4" : false,
      "block5" : false
     }
    },
    "commands" : {
     "commandInst1" : {
      "@bank0" : 0,
      "@bank32" : 0,
      "@channel" : 0,
      "@current" : 0,
      "@fs_enabled" : false,
      "@program" : 0
     },
     "commandInst2" : {
      "@cc" : 101,
      "@channel" : 3,
      "@fs_enabled" : false,
      "@value" : 0
     }
    }
   },

In this example, when selecting snapshot 0, Hx effects will send a fake PC command (not used)(in fact it will not sent the PC command when value is set to 0, see below) and a valid CC number 101 on midi channel  3 (0x02 sent). More generally when you want to disable an Instant command in a particular snapshot, set all values to 0 (or send it to a non-active midi channel...).

Note that while CC will send the right CC number indicated in JSON file (counting from 0 to 127), the PC will send a -1 value (counting from 1 to 128). So for example :

    "commands" : {
     "commandInst1" : {
      "@bank0" : 0,
      "@bank32" : 0,
      "@channel" : 3,
      "@current" : 0,
      "@fs_enabled" : false,
      "@program" : 14
     },

will send a MIDI message : 0xC2 (=PC on channel 2), 0x0D (PC=13).

For the PC, if you set the @program value to 0, the PC will be disabled for this snapshot and not sent to MIDI out.

 

5) save the file and reload it in Hx editor as a single preset, in the desired preset location.

 

Also note that when defining one Instant Command in a preset/snapshot, the IC type (CC=18 or PC=19) is mentionned in file header, but parameters are strangely not defined at all when exporting the JSON file. Anyway, adding it into the JSON file and re-importing it forces the Hx effects to take it into account... and store it correctly if there has been some saving corruption.

 

Again, I would have expected the Line6 support to ask me to send some hlx files to verify such preset saving bugs. They didn't... not very technical answer.

 

Anyway, hope this helps...

Link to comment
Share on other sites

  

On 7/30/2022 at 8:54 AM, VEVEF32 said:

I would disagree with statement that "forwarding MIDI sys ex message from MIDI in to MIDI out has never been a feature claimed by Line 6". Go to user manual page 41 (Global settings > MIDI/Tempo) and you find the magic sentence : "MIDI thru : if you activate this parameter, MIDI out is acting as a MIDI thru and forwards ALL MIDI IN messages received on MIDI in" (translation from french version of user manual). It is exactly how the MIDI thru (from MIDI in to MIDI out) should behave: forwarding ALL messages from in to out. Fact is Hx effects filters some MIDI messages. Here it is sysex, but it could also be midi clock or whatever. 

 

Most guitarists don't even know what a SYSEX message is. Most MIDI users don't use them. Most who've used them have done so to transfer a configuration file from an editor to their FCB1010 (or the like) without any real idea of what exactly was going on behind the scenes and have learned the hard way that you need a proper dedicated MIDI Interface to do it as many of the cheap cable interfaces most commonly used to connect MIDI instruments don't pass the longer SYSEX messages. My iConnectivity MIO (more expensive) passes SYSEX no problem, I have two of the cheapies which, while appearing to be identical (treble clef branding), one passes SOME sysex and the other passes none. Go figure!

 

IOW - using SYSEX is a special case mostly used by SYNTH people who generally have a much better understanding of MIDI than most, ESPECIALLY guitarists. Helix is a GENERAL PURPOSE device specialized for use by GUITARISTS. Just as it is NOT the best Audio Interface, it is NOT the best MIDI Interface.

 

So, to be clear, Line6 really SHOULD change their manuals and marketing materials to state clearly that SYSEX (and "whatever") is NOT supported and that the Audio Interface has more latency than many dedicated Audio Interfaces would. There are FAR MORE Helix users concerned with the latency thing than will EVER care about SYSEX. But I agree, the documentation SHOULD be accurate.

 

Personally, I'd be interested in seeing you document the last part of the quoted statement:

"Fact is Hx effects filters some MIDI messages. Here it is sysex, but it could also be midi clock or whatever. "

I just tested MIDI Clock, and Helix (don't have HXFX) passes MIDI Clock from Reaper just fine. I don't have a touch sensitive KB to test that stuff with, so you MIGHT be right about that. Maybe you can test that? I've not encountered any filtering of the basic MIDI messages that most of us are concerned with - PC, CC and NOTE.

 

As for the rest of your post, it's great that there's someone out there interested enough in this stuff to take the time and make the effort to do the no doubt significant amount of work it took to come up with this stuff. There's probably someone out there who'll actually use it and be very appreciative. However, it will NOT be used by the average Helix user who bought the device to replace their tube amp and analog pedal board. To most of us that stuff is nerdy g0bb1edyg00k. :-)

 

EDIT: I just re-read your previous post. While I've not had the random value re-assignment issue you mentioned (I save each change) maybe I'm not really understanding how you're configuring things or what the actual problem is. Regarding disabling an IC message just assign the message to an unused MIDI Channel. This will of course reset the message so that it'll be re-sent in the other Snapshots. If that's a problem I don't know the solution. Maybe this is another request for Ideascale? I'll vote for it!

  • Upvote 1
Link to comment
Share on other sites

Yes I agree sys ex messages are probably not the most used messages. But just take one exemple : all expensive strymon pedals, which are references among effects pedals, only use midi in and sys ex messages to configure the pedals (such as the Big Sky). No USB. So if you use a hx effects as a 'command center' to control downstream strymon pedals in midi Daisy chain, then you are not able to update the strymon presets with a pc connected to the hx midi in, unless you use an additional midi merger or play with cables (which is not very nice on a pedalboard).

Link to comment
Share on other sites

On 7/30/2022 at 2:33 PM, VEVEF32 said:

Yes I agree sys ex messages are probably not the most used messages. But just take one exemple : all expensive strymon pedals, which are references among effects pedals, only use midi in and sys ex messages to configure the pedals (such as the Big Sky). No USB. So if you use a hx effects as a 'command center' to control downstream strymon pedals in midi Daisy chain, then you are not able to update the strymon presets with a pc connected to the hx midi in, unless you use an additional midi merger or play with cables (which is not very nice on a pedalboard).

 

I'm not sure what you're saying The HXFX has 5 pin MIDI connectors, USB is not required to CONTROL the Strymon pedals. However, CONFIGURATION and CONTROL are two different things. CONTROL, switching presets and whatnot, making simple parameter changes on-the-fly, the things that most users are concerned with doing using the HXFX does not require SYSEX, just simple MIDI messages. I don't use Strymon pedals, so I'm not sure what "CONFIGURATION" entails. I'm guessing that "CONFIGURATION" means making wholesale and/or permanent changes to the Strymon Presets which are then CONTROLLED using simple MIDI. I had a look at the MIDI Spec for the BIG SKY and it looks like you could do this with simple MIDI, routing something like a korg NanoKontrol to the HXFX and THRU to the Strymon, but I can see where this might be a PITA vs using SYSEX. I THINK that MIDIOX can send simple MIDI using a batch file, but that's not something I ever looked into.

Link to comment
Share on other sites

On 7/30/2022 at 9:33 PM, VEVEF32 said:

Yes I agree sys ex messages are probably not the most used messages. But just take one exemple : all expensive strymon pedals, which are references among effects pedals, only use midi in and sys ex messages to configure the pedals (such as the Big Sky). No USB. So if you use a hx effects as a 'command center' to control downstream strymon pedals in midi Daisy chain, then you are not able to update the strymon presets with a pc connected to the hx midi in, unless you use an additional midi merger or play with cables (which is not very nice on a pedalboard).


You may want to read this - it’s quite old, but useful.

 

https://www.dropbox.com/s/68uptvxviegpkgo/The Unofficial Helix MIDI Guide.pdf?dl=0

 

Hope this helps/makes sense.

Link to comment
Share on other sites

Thanks @datacommando. Inside there is a lot of information I also found in various forums, which is concatenated here and not being in the Hx user manual. Interesting info source :-)

 

@rd2rk, what I meant is that lot of MIDI devices are not connecting to PC with USB to configure device : presets content (audio algos chain), global settings, etc..., but rather use PC > MIDI in link to do this, like strymon pedals. For doing this, they use only MIDI sysex messages because those messages are the only one in MIDI standard which are proprietary and manufacturer dependent. So, if you want to configure a preset on a strymon pedal (not select but really define what is the preset), you can do it 1) directly on the machine or 2) do it on the PC using a dedicated software (like the Hx edit program). But in this case, preset configuration update don't go thru USB link but only thru MIDI link and using sys ex messages. That's why I said that every time you want to define a new preset on a strymon pedal using your PC you have to connect to the strymon pedal using a MIDI cable. And if your strymon pedal is after the HX effects in the MIDI serial daisy chain, then Hx effects filters all sysex messages and you cannot do it. You have to unplug the MIDI in of the first pedal after the Hx and connect your PC directly after the Hx effects. You can also use a midi merge to perform this. But really, sysex messages should not be filtered by the Hx effects because it can be used by many other downstream devices for their configuration.

  • Like 1
Link to comment
Share on other sites

I understand. When I want to send sysex to my FCB1010 I use one of the MIDI to USB cables I mentioned.

What I'm saying is that while It's inconvenient to have to mess with cables to send sysex to the device, it's not a regular day-to-day routine procedure (maybe for uber tweakers) and it's not something that L6 is likely going to be able to fix on the current generation of devices even if they wanted to. AFAIK it's a HW thing. It's not a bug though it may appear so due to the misleading documentation, and much as you believe that L6 should have designed it with this use in mind, it is what it is. The best you can do at this point is go to Ideascale and vote for the existing "feature improvement requests" (sysex has already been requested at least once) and maybe post a "future product feature" request.

  • Upvote 1
Link to comment
Share on other sites

On 6/23/2022 at 5:04 PM, natewan said:

HX Stomp on v3.15
Snapshots are changing parameters that I have assigned to Midi CC commands and not as Snapshot parameters.

 

How I found the issue:
It happens with any parameter assigned to a midi CC# but I found it while trying to toggle a note sync on a delay between 1/4 and 1/8 Dotted. When I change to a different snapshot the note sync goes back to what that snapshot was saved as. This parameter was not assigned as a snapshot edit.

This happens with snapshot edit set to discard as well as recall. 

This issue has been declared normal function.

 

It kind of makes sense but also does not make sense. When selecting how a parameter is to be controlled, a snapshot should not effect other types of controlled parameters (ie. a snapshot should not change a parameter set to be controlled by a Midi CC#). Other parameters that are not controlled do not change but then again they are not changed between snapshots. 

 

I added a request for Snapshot bypass for Parameters here:

https://line6.ideascale.com/c/idea/1049072

 

Kind of like Snapshot bypass on blocks but for individual parameters.

Link to comment
Share on other sites

  • 1 month later...

Possible bug in Vibe Rotary.

1. Speaker blend still bleeds the drum in even if horn is panned in 100%.

2. Speed is off. When I set the same parameters on Vibe Rotary, 122 and 145, the Vibe Rotary is significantly faster.

 

Edit: that is in Helix Effects, type chosen was Stereo. I did not tried mono

 

 

Link to comment
Share on other sites

Maybe a bug with the send and return blocks.

Or maybe it's already reported.

While building a preset to work with guitar, mic and IEM, I added send blocks for the gtr and mic outputs to connect to FOH.

And I also build a separate path for IEM using the input return 1/2.

As per viewing an excellent video by Richie Castellano where he goes over a similar preset, I also decided using the sends instead of the 1/4" or the XLR to go to FOH for a few reasons.

 

The bug itself happened when adding a Return 1/2 block after a Send 1 (or 2) block. Doing this I can spare the separate path for the IEM and get the same result.

All was good after adding the blocks. Everything worked and had sound from all inputs. After saving, changing presets and going back to the preset it was empty and sounded like just DI.

Turned off the Helix (Floor by the way, with the lastest firmware and no other bugs) and when I turned it on there it was. The preset was loaded like it was saved.

Changing again presets and going back, empty again.

 

I was able to change the preset and get the same result I wanted by adding the return 1/2 block in path 1 after another send block. All worked and cycling presets did not emptied the preset. More or less the same thing that I did in path 2 but no bug this way.

I wasn't able to reproduce consistently the bug. Happened in two existing presets consistently. Happened often when building a preset from scratch. And I was trying now with my other unit, a LT, and happened again.

 

Is this a known bug? Can any of the experts around take a look?

Should I open a ticket?

I'm attaching a couple of pics of the screen with a simple test I did yesterday on the Floor unit and the preset I was working now on my LT that exibit the same bug when adding the return and send blocks (in this case the mic input was replaced by Variax but the result is the same).

IMG_20220908_225057.jpg

IMG_20220908_225015.jpg

KIM@MIC_bug.hlx

Link to comment
Share on other sites

  • 1 month later...

Bug in 3.5 FlexoVibe.

Rate parameter does not have option to change to note subdivision in HX edit, but can press knob on Helix floor to change Rate to note subdivision. This then breaks link between HX edit and Helix floor, with changes made to Rate on HX edit not affecting Rate on Helix floor, and changes made to Rate parameter not changing knob position in HX edit.

Pressing Rate knob on Helxi floor returns Rate to numbered speed and allows HX edit to control Rate parameter again.

Same behaviour occurs for mono and stereo versions.

  • Upvote 1
Link to comment
Share on other sites

On 11/4/2022 at 5:34 AM, 52dmk said:

Bug in 3.5 FlexoVibe.

Rate parameter does not have option to change to note subdivision in HX edit, but can press knob on Helix floor to change Rate to note subdivision. This then breaks link between HX edit and Helix floor, with changes made to Rate on HX edit not affecting Rate on Helix floor, and changes made to Rate parameter not changing knob position in HX edit.

Pressing Rate knob on Helxi floor returns Rate to numbered speed and allows HX edit to control Rate parameter again.

Same behaviour occurs for mono and stereo versions.

 

Good find. I have logged a bug for this and the 4-Voice Chorus. Thanks for reporting it!

Link to comment
Share on other sites

Not sure if it's a bug, but it's definitely an inconvenience. Since updating to 3.50 I can no longer drag my presets to rearrange them in HX Edit. I have to save them into a new spot, which would over write what is there. 

Maybe a little OCD but I keep my presets alphabetized because it's easier to find them that way. 

Edited by jshearer94
adding more information.
Link to comment
Share on other sites

On 11/4/2022 at 11:58 AM, acousticglue said:

a preset that was modified from a Line6 one saved to User 5 area 1B kept resetting to New Preset name, parameters were there and was only called Jmp45

 

Did you do the factory reset and backup restore after updating HX Edit AND the firmware?

Link to comment
Share on other sites

On 11/4/2022 at 8:19 AM, jdomine said:

 

Good find. I have logged a bug for this and the 4-Voice Chorus. Thanks for reporting it!

Helix Native 3.5 does not provide the rate “Note Sync” option for these two effects either.

  • Upvote 1
Link to comment
Share on other sites

On 11/4/2022 at 10:08 AM, jshearer94 said:

Not sure if it's a bug, but it's definitely an inconvenience. Since updating to 3.50 I can no longer drag my presets to rearrange them in HX Edit. I have to save them into a new spot, which would over write what is there. 

Maybe a little OCD but I keep my presets alphabetized because it's easier to find them that way. 

 

Works for me, but somebody else reported that over on TGP. Unless that was you... ?

Link to comment
Share on other sites

Hey, I don't know if I found some possible bugs:

 

Helix Floor FW3.5

 

- In the new Dual Cabs: When I dragged the DELAY parameter WITH THE MOUSEWHEEL in HX Edit (Win11) on the second cab HX Edit instantly crashed and closed down. I could just reopen it right away and it was working again. If I dragged the DELAY parameter with just a click on the specific time I wanted or typed in my wanted time there were no problems.

 

- Yesterday I was using the Helix without my PC and tried to put some FAVORTIES into a new patch. Everytime I tried to navigate to FAVORITES and clicked with the Joystick it automatically redircted me to MODULATION: MONO - STEREO. Tried it like 10 times after turning the Helix on and off, switching preses, switching setlists and so on. Then I did a short factory reset (9 and 10 whilst booting) and made 1 new favorite of a TS. It worked just fine again. I don't know if this has brought up the problem, but while it was hooked up to the PC yesterday I imported the "FAVORITE EFFECTS FREE PACK" by Worship Tutorials. These were the only favorites I had in my fav list.

Link to comment
Share on other sites

On 11/5/2022 at 12:17 AM, ShelbyMustangGt said:

- In the new Dual Cabs: When I dragged the DELAY parameter WITH THE MOUSEWHEEL in HX Edit (Win11) on the second cab HX Edit instantly crashed and closed down. I could just reopen it right away and it was working again. If I dragged the DELAY parameter with just a click on the specific time I wanted or typed in my wanted time there were no problems.

 

Reported and verified. They're working on it.

  • Thanks 1
Link to comment
Share on other sites

I built a preset last night using two amps and a dual cab. Snapshot 1 has one amp on, snapshot 2 turns that amp off the second amp on and changes the cab parameters, specifically mic type, distance, positions and angle. When switching between snapshots there is a delay and a gap in sound. It's very obvious when going from gain to clean sound but still noticeable switching between two different clean amps.

Keeping the parameters exactly the same on the cab block is a seamless transition so the problem appears to be a delay or gab when switching the cab block parameters.

I'm working on making a video showing this also going to test this with one amp using different drive settings per snapshot and different cab parameters.

Link to comment
Share on other sites

Not sure if this is the right place to report this, but...since updating to 3.50 yesterday, my Helix LT sometimes fails to change Variax models as it should when changing from one snapshot to another. It seems random and only on some presets.

Link to comment
Share on other sites

On 11/5/2022 at 6:17 AM, ShelbyMustangGt said:

Hey, I don't know if I found some possible bugs:

 

Helix Floor FW3.5

 

- In the new Dual Cabs: When I dragged the DELAY parameter WITH THE MOUSEWHEEL in HX Edit (Win11) on the second cab HX Edit instantly crashed and closed down. I could just reopen it right away and it was working again. If I dragged the DELAY parameter with just a click on the specific time I wanted or typed in my wanted time there were no problems.

 

- Yesterday I was using the Helix without my PC and tried to put some FAVORTIES into a new patch. Everytime I tried to navigate to FAVORITES and clicked with the Joystick it automatically redircted me to MODULATION: MONO - STEREO. Tried it like 10 times after turning the Helix on and off, switching preses, switching setlists and so on. Then I did a short factory reset (9 and 10 whilst booting) and made 1 new favorite of a TS. It worked just fine again. I don't know if this has brought up the problem, but while it was hooked up to the PC yesterday I imported the "FAVORITE EFFECTS FREE PACK" by Worship Tutorials. These were the only favorites I had in my fav list.

Also happens in Helix Native. DAW crashes after changing delay in new dual cab. Not sure if happened with mousewheel or draggin the slider.

Doesn't crash when clicking or entering manually a delay time.

Link to comment
Share on other sites

Might have a bug here on the 3.50 update on the HX Stomp. Update seemed to work just fine until I tried to select the Stomp as the audio device in my DAW (Cakewalk) which locked up. Gave it a few tries to be sure but it's doing it every time.

Link to comment
Share on other sites

On 11/6/2022 at 2:54 PM, Siessi said:

Might have a bug here on the 3.50 update on the HX Stomp. Update seemed to work just fine until I tried to select the Stomp as the audio device in my DAW (Cakewalk) which locked up. Gave it a few tries to be sure but it's doing it every time.

 

Hi,

 

You may want to check out this thread -

Hope this helps/makes sense.

Link to comment
Share on other sites

On 11/4/2022 at 4:08 PM, jshearer94 said:

Not sure if it's a bug, but it's definitely an inconvenience. Since updating to 3.50 I can no longer drag my presets to rearrange them in HX Edit. I have to save them into a new spot, which would over write what is there. 

Maybe a little OCD but I keep my presets alphabetized because it's easier to find them that way. 

I put a suggestion in the ideascale section (or whatever is called) a long time ago about the need for a search bar in the Editor, that and to display all the MIDI information for CC, BANK, and Program change that is displayed on the helix but not in the editor, as I have mobility problem and I can't easily bend down to push the button in order to display the info.  This information is needed every time I create a new preset, which then I need for adding it to an external software that triggers the MIDI command and jumps to the correct set list, preset and snapshot.  Come on LINE 6...  Please?

 

 

Link to comment
Share on other sites

On 11/4/2022 at 5:41 PM, cwlugtd said:

Installing 3,50 gave me a Boot Failure. Entering the Update Mode did not solve the situaties. HX does not recognize my Helix. 

 

Make sure you download HX Edit 3.50 and after has been installed, reboot your computer, as the software includes the audio driver.  After this the Helix should be detected.

Link to comment
Share on other sites

On 11/4/2022 at 5:41 PM, cwlugtd said:

Installing 3,50 gave me a Boot Failure. Entering the Update Mode did not solve the situaties. HX does not recognize my Helix. 

 


In a “failed state” HX Edit will not connect to your device.

Go here and follow the instructions.

 

Hope this helps/makes sense.

Link to comment
Share on other sites

On 6/23/2022 at 5:04 PM, natewan said:

HX Stomp on v3.15
Snapshots are changing parameters that I have assigned to Midi CC commands and not as Snapshot parameters.

 

How I found the issue:
It happens with any parameter assigned to a midi CC# but I found it while trying to toggle a note sync on a delay between 1/4 and 1/8 Dotted. When I change to a different snapshot the note sync goes back to what that snapshot was saved as. This parameter was not assigned as a snapshot edit.

This happens with snapshot edit set to discard as well as recall. 

 

I don't if anyone else had this issue but they fixed it with the new update! I feel so heard! Thank you Line6!

 

In short I asked for each parameter control to had the option of bypassing Snapshot control kind of like Snapshot bypass for each effect block. And they added it!

 

image.png.d534f347d6058ebd7f7e19239e7752ac.png

Link to comment
Share on other sites

On 11/10/2022 at 1:42 PM, ahallida said:
I use the HX Stomp as an audio interface with my DAW (Cubase 12 Pro / Windows 10 Pro) with no issues until the most recent HX Stomp update (3.50).
 
The DAW no longer compensates for delay / latency on playback. I am by no means a Cubase expert - however I have used the software for about a decade and I am familiar with interface setup / ASIO / delay compensation.
 
I have tried using another audio interface (Steinberg UR22 mkII) with the same DAW. This solved the problem. This test combined with the problem appearing only after the Helix update makes me think the issue is with the HX Stomp. I have updated Windows, drivers, and Cubase to no avail.
 
Any insight you folks can provide would be greatly appreciated.

 

I wonder if your issue has anything in common with the issue some users were having with Cakewalk after the 3.50 update. If so, those users got around it by uninstalling the Line6 version 1.97 driver and (if it was no longer installed) reinstalling the 1.96 driver which you can find on the downloads page. I guess those users are now hoping for a 1.98 update to the driver but until then...

 

Btw, you stated you already tried updating drivers but I'm not sure which ones, so apologies if this is redundant. If you have not already, I might try reinstalling my ASIO driver or download and reinstall the 1.97 version driver from the HX Edit 3.50 update.

 

Line 6

 

 

Link to comment
Share on other sites

On 11/4/2022 at 12:08 PM, jshearer94 said:

Not sure if it's a bug, but it's definitely an inconvenience. Since updating to 3.50 I can no longer drag my presets to rearrange them in HX Edit. I have to save them into a new spot, which would over write what is there. 

Maybe a little OCD but I keep my presets alphabetized because it's easier to find them that way. 

I opened a ticket and they wanted to confirm I was up to date in HX Edit as well as the unit itself. (I was). Since clicking the question mark in the bottom left and checking the status I can now click and drag like usual. So if someone runs into that problem, maybe checking for an update (that wasn't there) fixes it? Not sure, but mine is working now. 

Link to comment
Share on other sites

I have an enhancement request - please increase the timeout of the Tempo configuration page or make it persistent until next UI action is performed outside the page - there’s not enough time to adjust the tempo and listen to the results when setting global tempo with the knob by ear, the page closes too soon. Thank you. This is Helix Floor 3.5.

Link to comment
Share on other sites

On 11/10/2022 at 3:37 PM, pomor said:

I have an enhancement request - please increase the timeout of the Tempo configuration page or make it persistent until next UI action is performed outside the page - there’s not enough time to adjust the tempo and listen to the results when setting global tempo with the knob by ear, the page closes too soon. Thank you. This is Helix Floor 3.5.

 

Wrong forum, nobody from L6 hangs out here. Post your request here:

 

https://line6.ideascale.com/a/login

 

Search first to make sure it hasn't already been requested.

  • Upvote 1
Link to comment
Share on other sites

On 11/10/2022 at 4:21 PM, rd2rk said:

 

Wrong forum, nobody from L6 hangs out here. Post your request here:

 

https://line6.ideascale.com/a/login

 

Search first to make sure it hasn't already been requested.

Thank you for your reply. So, this forum is called “Helix bug reports” and L6 don’t read it? What is the point in submitting bug reports here then, since no-one except L6 can fix bugs? Also, few posts prior you responded to someone’s bug report: “Reported and verified. They're working on it.” Was that bug reported to L6 via ideascale or some other, actual L6 bug tracking system? Appreciate if you clarify.

Link to comment
Share on other sites

On 11/10/2022 at 6:21 PM, pomor said:

Thank you for your reply. So, this forum is called “Helix bug reports” and L6 don’t read it? What is the point in submitting bug reports here then, since no-one except L6 can fix bugs? Also, few posts prior you responded to someone’s bug report: “Reported and verified. They're working on it.” Was that bug reported to L6 via ideascale or some other, actual L6 bug tracking system? Appreciate if you clarify.

 

EDIT: IMO

 

This forum exists so that L6 users can solve other L6 users' problems and save L6 support a whole lotta time and money.

 

Ideascale exists for L6 users to present their ideas and feature requests, not for reporting bugs.

 

L6 SUPPORT is the only dependable way to get bugs to the attention of the developers.

Once someone at L6 has certified that it is, in fact a bug and not just operator error as most of the problems reported here as BUGS usually turn out to be, the support staff kicks it up to the developers who add it to the backlog of stuff they have on their plates.

Link to comment
Share on other sites

On 11/10/2022 at 5:37 PM, rd2rk said:

 

This forum exists so that L6 users can solve other L6 users' problems and save L6 support a whole lotta time and money.

 

Ideascale exists for L6 users to present their ideas and feature requests, not for reporting bugs.

 

L6 SUPPORT is the only dependable way to get bugs to the attention of the developers.

Once someone at L6 has certified that it is, in fact a bug and not just operator error as most of the problems reported here as BUGS usually turn out to be, the support staff kicks it up to the developers who add it to the backlog of stuff they have on their plates.

Thanks, this makes sense. If I may suggest, it would be great if you guys put this exact information into the top post in this forum that currently reads “This topic is not intended for bad-mouthing the Helix but for providing Line6 with maximum feedback to assist them in fixing issues as early as possible.”, which creates an impression that this forum is indeed targeted directly at L6, and maybe change the title to something like “Helix Bug Discussion” (unless existing contributors would get too confused by such a change) - somehow I think I’m not the first (and probably will not be the last) person who got slightly confused here… 25 years in the software industry makes you interpret the phrase “bug reports” in a very specific way. Cheers!

Link to comment
Share on other sites

On 11/10/2022 at 7:09 PM, pomor said:

Thanks, this makes sense. If I may suggest, it would be great if you guys put this exact information into the top post in this forum that currently reads “This topic is not intended for bad-mouthing the Helix but for providing Line6 with maximum feedback to assist them in fixing issues as early as possible.”, which creates an impression that this forum is indeed targeted directly at L6

 

I should have prefaced my post with "IMO". My opinion is based on how rarely anyone from L6 replies, but for all I know somebody DOES read it. If so and what they do as follow up is a mystery to me.

 

Anyhow, fixed it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...