Jump to content
Sign in to follow this  
ruanneves

Audio Latency when playing via USB connection (Win 8.1)

Recommended Posts

Hi,

I've started playing my Firehawk buy connecting it to my notebook using a USB connection, the audio quality is awesome (better than playing through my amp), but I experience quite a lot of latency while playing, I'd like to known if anyone has a fix for this, because it's quite frustrating when playing to a backing track or metronome.

Share this post


Link to post
Share on other sites

Make sure your DAW (recording program) is configured to use the Firehawk and its ASIO driver as the audio device. Turn off the software monitoring in your DAW and use the Firehawk audio outputs to monitor (headphones or studio speakers).

Share this post


Link to post
Share on other sites

FWIW - on my FireHawk FX  - I never could get the Firehawk FX Windows USB ASIO Driver to work until after i updated to FW 1.20

 

To verify the Firhawk ASIO driver is working,  Be sure you see these options in your Windows Sound Devices Control panel 

1443604458_1297094441_firehawk_win7_audi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...