Please ensure Javascript is enabled for purposes of website accessibility Jump to content

POD Studio UX2 and how I solved my Windows 10 driver issue

Recommended Posts



I just bought my first audio interface today (the UX2) and initially I ran into problems with the installation.


1. I downloaded the Pod Farm 2.5

2. didn't plug the device

3. picked the UX2 driver in the installation instructions

4. I plugged it in after it instructed me to do so.

5. No driver installation window appeared. I checked Device Manager and I saw the UX2 in the Unknown Devices with an exclamation mark icon; the problem: drivers were not installed.

6. Uninstalled the software completely and searched these forums for about 30 mins. Someone mentioned in a post on a thread to install Line 6 Monkey first (I really can't find the link anymore :( ).

7. Did that. He couldn't find the device even though it was plugged. It reported that UX2 driver was not installed and other things: USB Firmware outdated and the pod farm software and others.

8. I clicked to update the UX2 driver. It installed and after a few seconds it miraculously worked (and it seemed it updated the USB firmware as well.


And that's it, then basically you can install whatever you want.


This might work for other Pod Studio devices as well. 

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...