Jump to content
Digital_Igloo

HELIX FW 1.02.2 Now Available

Recommended Posts

Helix Firmware v1.02.2 Release Notes


Helix v1.02.2 is a free firmware update that includes fixes and optimizations. It is highly recommended that all Helix users perform this update!

It is also recommended that you back up your current presets by using the Helix application to create a preset bundle, allowing you to install new presets as part of the update process.

The easiest way to perform the update process is by installing the latest version of Line 6 Updater. Once you've connected Helix to your computer via USB port (hubs are not supported), Line 6 Updater will recognize the unit and take you through the update process. Line 6 Updater application may be downloaded here: http://line6.com/software/


Bug Fixes

  • When set to Per Preset, Variax model and tuning settings would not recall reliably after rebooting  â€”FIXED
  • In rare cases, pressing the Variax/Mags knob on a Variax (connected via VDI) while the Helix application is open may cause Helix to freeze  â€”FIXED
  • In certain situations, punching out of the looper would not take effect after pressing UNDO, causing invalid data in the loop â€”FIXED
  • Undoing an overdub in the stereo looper would only affect the left channel. â€”FIXED
  • If the Helix application is open, FS6 (EXIT LOOPER) may fail to work after changing presets while in Looper footswitch mode  â€”FIXED
  • From the Controller Assign screen, changing pages in Pedal Edit mode would sometimes result in empty scribble strips  â€”FIXED
  • On rare occasions while booting, “broken TV†artifacts could appear on the main display  â€”FIXED
  • The underscore character (“_â€) could not reliably be used in IR names â€”FIXED
  • Some pitch parameters’ negative values were not accessible from the expression pedal in Pedal Edit mode  â€”FIXED
  • Volume/Pan > Volume Pedal blocks would load bypassed when an external expression pedal was connected to EXP 2  â€”FIXED
  • In some cases, the inspector line would disappear when jumping to the Home screen from the model list by touching a cap sense footswitch â€”FIXED
  • Bypassed IR block footswitch appeared as dim white; now properly appears as dim pink â€”FIXED
  • Variax magnetics could emit the Variax model signal when booting with Variax connected via VDI â€”FIXED
  • Other minor bug fixes and optimizations

Other Improvements

  • Added underscore (“_â€) to available preset name and customized scribble strip characters
  • Minor improvements made to the factory preset bundle

Resetting Helix Globals / Loading the Newest Factory Presets (Optional)
IMPORTANT! This procedure will completely overwrite all existing presets and setlists, as well as clear all user IRs and reset all global settings! Back up your presets and IRs before proceeding!

  1. Turn off Helix.
  2. While holding footswitches 9 and 10 (middle two switches on the bottom row), turn on Helix. Wait for the message “Will reset Globals and restore stock Presets, Setlists and IRs…†to appear and let go.

Known Issues

  • While a loop is playing, changing from a preset with the Looper block on Path 1 to one with the Looper block on Path 2 may cause a small portion of the recorded loop to play
  • Minor pops and clicks may be present when Helix is streaming audio from a Mac® running OS X 10.11 (El Capitan)
  • Minor pops and clicks may be present when Helix is streaming audio from an iOS ®device with Apple® Camera Kit
  • Importing a Helix bundle while streaming audio over USB may cause the Helix application to disconnect
  • In rare cases, Amp+Cab or Cab > Dual parameter graphics may overlap the action panel buttons while in Pedal Edit mode
  • A certain rare combination of looper footswitch presses may cause several scribble strip graphics to disappear
  • Upvote 1

Share this post


Link to post
Share on other sites

Version 1.00 of the Updater software is all that shows is available. When that is opened, only 1.01.2 of the firmware is available. How do we get to the new links or downloads?

 

Thanks

Share this post


Link to post
Share on other sites

I have the Line 6 Updater installed on my Mac along with the Helix App. The Helix app recognizes my Helix, and I was able to back up my presets. But the Updater just has a blank black page that says "Select Device to Update" and nothing else. It does not seem to recognize my Helix. 

 

Any ideas?

Share this post


Link to post
Share on other sites

Update is still not showing in the Line 6 Updater or on the downloads page for Helix on Line6.com

Share this post


Link to post
Share on other sites

Then she shouldn't say she's ready and make me wait in the car for another day, lol!

Share this post


Link to post
Share on other sites

Then she shouldn't say she's ready and make me wait in the car for another day, lol!

 

You just described every lady I've ever known....

Share this post


Link to post
Share on other sites

BUG: I found while holding the "MODE" hold to edit button the helix froze and wouldn't respond. I haven't had a chance to update yet so hopefully its been fixed in this patch.

But I thought id share it here anyway. Im new to these forums so im not sure where is best to post bugs :P

 

Share this post


Link to post
Share on other sites

BUG: I found while holding the "MODE" hold to edit button the helix froze and wouldn't respond. I haven't had a chance to update yet so hopefully its been fixed in this patch.

 

But I thought id share it here anyway. Im new to these forums so im not sure where is best to post bugs :P

 

 

Best place would be to post it here:

 

http://line6.com/support/topic/16083-helix-bug-reports/

Share this post


Link to post
Share on other sites

Just as a heads up DI.

 

You might want to include how to reset global presets with the rack version too.  

 

Helix Rack won't be out for a couple months; we'll roll in whatever FW is current at that time.

Share this post


Link to post
Share on other sites

I can see the Release notes for the new 1.02.2 version on the downloads page, but when I click on it, I get the wrong filename "HELIX_v1.01.2sha9c86959bundle.zip". Note that both the version number and the SHA matches the old firmware file. I also tried clicking on the link for the old 1.01.2 file and it gives me a different filename "HELIX_1.01.2_bundle.hxf".

 

Using Line 6 Updater did find the correct firmware and I upgraded just fine, but the link on the downloads page seems to either show the incorrect filename or point to the incorrect file. I did try to refresh several times, just to make sure I was not getting a stale file, but every time I got the same results.

 

DI, I just thought you'd might want to take a look.

Share this post


Link to post
Share on other sites

Helix Rack won't be out for a couple months; we'll roll in whatever FW is current at that time.

:lol: lol, wow I just had a dumb moment. Never mind me.

Share this post


Link to post
Share on other sites

Does this firmware update include any line 6 link/DT amp optimizations?

 

I can confirm that it's still not working.

It looks like they took a shot at it though. But couldn't get it done in time. I say that because it's no longer hitting the preamp section of the DT amp anymore. BUT...it only seems to kind of work when you set the topology to III BEFORE you plug in the L6 link from the Helix.

Once you plug it in...the topology indicators on the DT amp go out.

And unless you chose III before you connected the Helix to the DT via L6....you have no sound at all.

 

So that leads me to conclude that they started trying to figure it out, but decided to hold off on it until they could get the other bugs fixed in the update.

 

Got to say though...Line 6 is really bad about communicating with their customers. Doesn't seem like it would have been a big deal to just add in the original post: "We are still working on DT integration, please have patience"

That's the kind of little thing that goes a long way.

Share this post


Link to post
Share on other sites

Update is still not showing in the Line 6 Updater or on the downloads page for Helix on Line6.com

Updater is now updated... but still no update for Windows 10 and the Helix Application.

Share this post


Link to post
Share on other sites

All you need is here
http://line6.com/software/index.html

Step 1 - All Helix owners with Windows computers MUST install the Helix USB Driver for Windows OS first!

1444885481_1421412545_HLX_driver.PNG



Step 2 - Download and install the Line 6 Updater Application
http://line6.com/software/index.html
1444884819_1033649499_L6_UpdaterPNG.PNG


Step #3 Download the latest Helix Firmware. - (this should be 2.5MB file with *.hfx file extension! )
http://line6.com/software/index.html

1444884814_868717593_HLX_FW_1.02.2.PNG



I observe the latest Helix firmware 1.02.2 update file has wrong ZIP file extension -( its not a ZIp file), and reports an error
1444931292_946416128_Helix_FW_Damaged.PN
HELIX_v1.01.2sha9c86959bundle.zip


Just Rename it with the proper file *.hfx extension:

HELIX_v1.01.2sha9c86959bundle.hfx

Then the Line-6 Updater Application can open this Helix firmware update file and update your Helix

  • Upvote 3

Share this post


Link to post
Share on other sites

I can confirm that it's still not working.

It looks like they took a shot at it though. But couldn't get it done in time. I say that because it's no longer hitting the preamp section of the DT amp anymore. BUT...it only seems to kind of work when you set the topology to III BEFORE you plug in the L6 link from the Helix.

Once you plug it in...the topology indicators on the DT amp go out.

And unless you chose III before you connected the Helix to the DT via L6....you have no sound at all.

 

So that leads me to conclude that they started trying to figure it out, but decided to hold off on it until they could get the other bugs fixed in the update.

 

Got to say though...Line 6 is really bad about communicating with their customers. Doesn't seem like it would have been a big deal to just add in the original post: "We are still working on DT integration, please have patience"

That's the kind of little thing that goes a long way.

 

Thanks for the update Robbie. I look to you to blaze the trail for DT integration with the Helix. I am also not impressed with Line 6 support on this. My ideascale request has 114 votes, and I am sure they are working on a solution, but I don't see it as a top priority for them.

 

DI did mention that the next "Major" firmware update would have the DT integration, but I have no idea when that would be released. I suspect it's several months out. Until then I will continue to enjoy my dream rig which sounds awesome.

Share this post


Link to post
Share on other sites

Got to say though...Line 6 is really bad about communicating with their customers.

 

...

 

There's nothing I could possibly say that won't appear as passive-aggressive, so I'll just apologize in advance and add some smileys:

 

Sorry, robbieb61.  :)

 

Ahem.

 

Line 6 cannot legally talk about upcoming features or updates. In the more than 1,000 posts I've written over the past 3-1/2 months where I'm personally communicating with Line 6's customers far beyond office hours and even while on vacation, I'd say approximately 40-50 of those posts were reiterating the fact that we're not allowed to talk about upcoming features or updates. And at the risk of losing my job, 4-5 of those posts explicitly stated that improved L6 LINK compatibility is toward the top of our to do list.

  • Upvote 5

Share this post


Link to post
Share on other sites

Line 6 has been incredible about communicating on this product across multiple forums online.  So much so that there's a LOT of information within those forums to digest and it would probably take too long to go through and realize they have already addressed and are working on this. Of course they want their products to work well together. I think rather than assume the worst, it makes the most sense to post a question because - they have been really good about responding.  A lot of the faith I have in this platform and my decision to invest has been based on the incredible support and obvious thought/testing that has gone into it. I continue to be encouraged by the two firmware updates that have already been released. It's already an amazing machine and it's only going to get better.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have to say I agree with digital igloo on this.

 

In a world where corporate doctrine is to simply say nothing, his support of the end user in a public forum is a major step for Line 6 and above and beyond in my book. It shows direct involvement and a direct line to the development team. They hear your requests, and like any corportation have rules regarding what they discuss to protect their intellectual property.

 

Really, some of the whining on this and other forums regarding update timing and free stuff and wanting it NOW displays a sad sense of entitlement on the part of some people.

 

Not going to hijack the thread here, but these companies do have a vested financial interest in keeping consumers happy and having one of their employees actively engaged with the users is a step in the right direction that should be recognized.

Share this post


Link to post
Share on other sites

I agree with cacibi.  Line 6 and especially DI have done, in my opinion, a commendable job at disseminating a lot of info and going above and beyond with helping those of us who were lucky to get our Helices in the first delivery.  I know we all want what we want now, and believe that what we think is the most important thing to fix is what L6 should be focusing on, but having the expectation that my wants should trump others and direct L6's thinking does nothing but set me up to be frustrated and have my serenity completely trashed.  I'm positive that L6 is listening to us, but troubleshooting, rewriting code, implementing, and testing don't happen overnight.  Let's all take a deep breath and accept the fact that the fixes, new amps, cabs, effects, IR's and editing software will get here when it gets here.  The thing has barely been out 2 weeks and we expecting years worth of new development to happen yesterday.  

I'm not jumping down any particular user's throat, but we need to keep our expectations right sized.  (myself included)  I'm extremely happy with my Helix and what it offers and what it brings to us as musicians and creators.  

 

Ok...I'm off my lunch hour soapbox.  Back to your regularly scheduled program..... :)

Share this post


Link to post
Share on other sites

Looks like the beta testing by customers continues. I'll check back in 6 months or so to see if it's settled down any.

Share this post


Link to post
Share on other sites

Line 6 has started from the start that DT amps were not directly supported. And if you preorder a brand new item you have to expect growing pains. People were yelling for the release and then if they have bugs they say it was a premature release. I just hope the people at Line 6 realize some of us are very happy and are more than willing to work through the growing pains. I also thank the team for all tve hard work and the fact we already have multiple firmware updates. I guess that was why I used to be an Hewlett Packard tester. I enjoy it.

Share this post


Link to post
Share on other sites

Looks like the beta testing by customers continues. I'll check back in 6 months or so to see if it's settled down any.

 

Fair enough, stumblinman. A huge product release corresponding with major Mac and Windows OS releases ain't fun, I'll tell ya' that.

  • Upvote 1

Share this post


Link to post
Share on other sites
Thanks DI...by the way, I wasn't proposing that you disobey your boss's directives. I was suggesting that instead of releasing the new firmware with no mention of the DT amp at all, that perhaps you could have just simply said: For all you DT amp guys, this update does not fix the L6 integration.
 
That's what I mean by not giving us any idea of what's going on. Instead of all of us with DT amps feverishly trying out the new firmware with high hopes, we could have just known what's going on.
 
As I said in my original post, since we are kept in the dark about the very products we have purchased...I can tell that SOMETHING was being worked on because of the different behavior I'm seeing in what the L6 link is doing with the DT amp after the firmware upgrade. So I let those people who are looking for the solution know what I saw.
It would have been better coming from Line 6 instead of someone like me who has no affiliation with the company. And that was my meaning when I said that Line 6 isn't doing a good job in keeping us informed.
 
Anyway, I didn't mean anything towards you personally.  My apologies if I came across as insulting you in any way     :)​

Share this post


Link to post
Share on other sites

Looks like the beta testing by customers continues. I'll check back in 6 months or so to see if it's settled down any.

 

Huge multi billion dollar passenger and military aircraft have crashed because of software errors, and it wasn't because the software wasn't tested extensively. They obviously didn't test that unfortunate combination of input sequences, but these things are complex and it's impossible to test all combinations. Have a bit of patience.  :)

 

Peace

Share this post


Link to post
Share on other sites

 

Thanks DI...by the way, I wasn't proposing that you disobey your boss's directives. I was suggesting that instead of releasing the new firmware with no mention of the DT amp at all, that perhaps you could have just simply said: For all you DT amp guys, this update does not fix the L6 integration.

 

Cool—thanks, robbieb61. The reason we don't list DT stuff in the updates is that its omission isn't a bug, it's a lack of features. If we were allowed to and decided to list all of the missing features in Helix, "Known Issues" would be like reading War and Peace. Our feature backlog is GIGANTIC. This is why IdeaScale is so important—it tells us what to prioritize.

Cheers!

Share this post


Link to post
Share on other sites

Having an issue updating. Helix is not coming up now in the line 6 updater and when i click the download it just keeps duplicating itself. Im on mac

Share this post


Link to post
Share on other sites

Having an issue updating. Helix is not coming up now in the line 6 updater and when i click the download it just keeps duplicating itself. Im on mac

Are you on El Capitan as this has been listed as a known bug for many audio apps.

Share this post


Link to post
Share on other sites

Are you on El Capitan as this has been listed as a known bug for many audio apps.

 

No I'm on Mavericks. I got it to show up but the update failed and now I'm stuck in update mode.

Share this post


Link to post
Share on other sites

 

 

saying version 1.02.2 

 

FW 1.02.2  IS  the latest version

 

1444884814_868717593_HLX_FW_1.02.2.PNG

Share this post


Link to post
Share on other sites

BUG: I found while holding the "MODE" hold to edit button the helix froze and wouldn't respond. I haven't had a chance to update yet so hopefully its been fixed in this patch.

 

But I thought id share it here anyway. Im new to these forums so im not sure where is best to post bugs :P

 

 

I have not seen this on 1.02.2.

 

I tried several different patches that had a number of different effects to see if it was effect-related. DId you notice this on just one patch or on several? if so, Is there anything that is unique to those patches (i.e. they all have an effect in common, or other shared feature)? If you manage to isolate it to a certain patch or group of patches, Have you tried re-creating said patches (just to make sure they are not corrupted somehow)?

Share this post


Link to post
Share on other sites

Just completed the 2nd update with holding FS9 & FS10 during reboot, and then importing my exported user preset bundle - and found it moved some preset names in my user bundle again.  What-da?  I have some made-from-scratch presets stored in 01A through 02A.  They import back in OK. 

 

Then there's some blanks "New Preset" (02B - 02D).

 

I had some copied factory presets that I liked in bank 3: 03A - 03D.  The presets are still there - but the preset names shifted down 1 preset after the first update.  Now after the 2nd update they shifted another preset down.  So these factory copies are now mismatched.  02D has a name now - but no blocks.  The blocks for that name are now 2 presets up where I originally copied it.

 

I guest it could be in the export/import process something gets skiped if you have groups of blank user presets in between stored presets?

 

I know this sounds like the "who's on first" rutine but anyone else experience this - preset names moving after update/reset?  Linie 6 experts, any explanation?

 

Thanks 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...