Jump to content
Sign in to follow this  
lawrence_Arps

the very small percent of problems

Recommended Posts

OK its a bit of an assumption.

 

Im curious as to the number of units currently in use and the number that actually generate genuine problems...ie. not user errors.

 

My Helix has never glitched in any way. I haven't bothered with the last update but will probably do the next one.

 

If there have been 5000 units shipped and 50 have hat problems that's 1%.....but I have no idea of the actual numbers involved.

Share this post


Link to post
Share on other sites

I only had one issue where it froze while holding the MODE button in a patch. Havent had any problems since, but I also haven't updated my firmware at all yet.

Share this post


Link to post
Share on other sites

My has been flawless except for the other day it froze when I tried to add a second amp to Path 2 (4th amp at once). USB was plugged in.

 

I turned it off and on again and unplugged the USB. Nothing has gone wrong since.

 

So far it has a better strike rate than the 4 of my Xbox 360s did  :P

  • Upvote 1

Share this post


Link to post
Share on other sites

I've been turning it on & off 3-4 times a day for the past 3 weeks and it seems to boot to the HBSOD about 1-2 times per week. I always back it up to my PC after making extensive tweaks, so it's not that big a hassle. I haven't figured out what causes it to do this.

I only had it freeze up once. While saving a pre set from one set list to another (on Helix not the app)

No freeze ups or issues while playing.

No regrets getting it early. I sold my Hd500x this week.

But I'll bring my laptop to my show later this month just in case I have reset & reinstall presets.

I'm running firmware 1.02.2 - 4e4971d

Share this post


Link to post
Share on other sites

My screen got lines on start up and helix would come close to freezing up. But after last reset it has been ok. Guess I finally did the reset right.

 

Other thing is if I go exploring through presets the helix would start to make static sounds and distortion. Today I felt lucky and tried out 5 amps with no problems. ( wonder if it's possible to run out of memory?) I don't understand this one because once I click on a new preset the old one should have closed out on its own. But a simple power off and back on fixes this.

 

Something can be wierd with looper if I'm looping cords and playing over and pick a different amp to solo over it will kick looper off and try to glitch.

 

I'm still on 1.00.0 firmware and some of this might be fixed by update, I'm just waiting for next update to come out.

 

Helix is still new and line 6 is working on the bugs for us so it should be ok.

Even with bugs/glitches the helix is pretty good

 

Helix with bugs fixed will be amazing.

Share this post


Link to post
Share on other sites

But yea....some of us are getting errors unless you count turning the helix on as a user error.

Share this post


Link to post
Share on other sites

And here's exactly what I'm watching - the reviews of the sound quality and ease of getting those basic sounds have me primed to buy - but I play out a LOT, charging our clients a lot of money.  This thing has to be rock solid and road ready,  failure on these gigs is not an option.  So I'm checking this thread daily,  keeping an eye on what's being reported.  Best guess,  sometime after the turn of the year - after several more "point" updates - I may see enough stabilty to plunk down my cash.  I like what I hear - but currently less so what I'm reading.

 

I'm patient.  And thanks to all the beta testers - someone's got to be the first one in…

  • Upvote 1

Share this post


Link to post
Share on other sites

I had a freeze up on day 2 while being connected via USB (which seems a known issue) and been running hassle free since 2 weeks. Seems stable. But being able to bsckup all Presets on USB Stick would be handy if you need to factory reset while being out and about.

Share this post


Link to post
Share on other sites

Hi all,

 

I've received my Helix last week and after having tried all preset I decided to update the firmware ....... oh nooooooooo ! I'v got an "Update Failed" and at the restart, the Helix was blocking on startup screen with ":0" error code. I've tried to reset it several times using different combination of holding footswitch at switch on but no success. I've also try to install again the update from 2 other different computer and using an USB port at the back of the computer and not from a HUB.

I called the line6 support in California and they ask me to send back the unit cause of a chipset problem :-(, They explain me that they've got few unit with this kind of problem.

Now I'm waiting for my seller He received a new one ...

  • Upvote 1

Share this post


Link to post
Share on other sites

.....but I have no idea of the actual numbers involved.

Neither does anybody else. "Units shipped" and "units shipped to an end user" are two different things. The first number is easy for L6 to calculate. The second, almost impossible to get a real number. And even if they do have a rough estimate for rates of failure, they're never gonna part with that info anyway...

Share this post


Link to post
Share on other sites

The percentage of "problem" units is 100% since they all have the same bugs and needed fixes. The percentage of user experience with these issues will vary based on the time and depth of feature use.

 

I've had a number of small bug experiences. But, overall it's a great device.

Share this post


Link to post
Share on other sites

Yeah, the question that the OP has asked is what I have been trying to gauge as well.  There have been enough awesome reviews about this device's ease of use and sound quality that it made me feel like it was a no brainer to upgrade from my 500x.  I suppose it is impossible to get any kind of real feel for that number because, unless you're a long time member here, you're probably not going to come here unless you have an issue or just like forums.  Kind of the whole, no one leaves reviews unless they are to complain, issue (if any of you have worked retail you know what I mean).

Share this post


Link to post
Share on other sites

We do have a firmware update today, I'm definitely going to update later when I get home

Share this post


Link to post
Share on other sites

Looks like a good chunk of the freezing issues have been addressed in this one.  That makes me feel a lot better.  Now I really can't wait for Sweetwater to get their next shipment in.

Share this post


Link to post
Share on other sites

And here's exactly what I'm watching - the reviews of the sound quality and ease of getting those basic sounds have me primed to buy - but I play out a LOT, charging our clients a lot of money.  This thing has to be rock solid and road ready,  failure on these gigs is not an option.  So I'm checking this thread daily,  keeping an eye on what's being reported.  Best guess,  sometime after the turn of the year - after several more "point" updates - I may see enough stabilty to plunk down my cash.  I like what I hear - but currently less so what I'm reading.

 

I'm patient.  And thanks to all the beta testers - someone's got to be the first one in…

 

If I were you I would be patient a little longer.

 

I just updated both the PC program and the firmware and did a complete factory reset, but I still can't backup (Export) any patch, setlist or bundle. Windows simply shuts down the program saying that a problem has caused the program to stop working properly. It displays the patches correctly and I can rename a patch on the PC and it shows up correctly on the Helix, so the communication between the Helix and the PC program seems to be ok. It simply won't save anything without crashing, and it crashes before anything gets saved to the disk.

 

I do hope the BSOD problem is a thing of the past with firmware 1.03.0, but I'm definitely not gigging this board until it's been stable at home for quite some time, and then I would still like to be able to back up my presets and bring a PC to the venue ... just in case.

Share this post


Link to post
Share on other sites

If I were you I would be patient a little longer.

 

I just updated both the PC program and the firmware and did a complete factory reset, but I still can't backup (Export) any patch, setlist or bundle. Windows simply shuts down the program saying that a problem has caused the program to stop working properly. It displays the patches correctly and I can rename a patch on the PC and it shows up correctly on the Helix, so the communication between the Helix and the PC program seems to be ok. It simply won't save anything without crashing, and it crashes before anything gets saved to the disk.

 

I do hope the BSOD problem is a thing of the past with firmware 1.03.0, but I'm definitely not gigging this board until it's been stable at home for quite some time, and then I would still like to be able to back up my presets and bring a PC to the venue ... just in case.

 

Strange, I use Windows 10 (installed Windows 7 helix software since there was no Win 10 software available) and I have had no problems backing up any of my bundles, setlists, or presets. I back up almost daily since I am still tweaking presets.

Share this post


Link to post
Share on other sites

If I were you I would be patient a little longer.

 

I just updated both the PC program and the firmware and did a complete factory reset, but I still can't backup (Export) any patch, setlist or bundle. Windows simply shuts down the program saying that a problem has caused the program to stop working properly. It displays the patches correctly and I can rename a patch on the PC and it shows up correctly on the Helix, so the communication between the Helix and the PC program seems to be ok. It simply won't save anything without crashing, and it crashes before anything gets saved to the disk.

 

I do hope the BSOD problem is a thing of the past with firmware 1.03.0, but I'm definitely not gigging this board until it's been stable at home for quite some time, and then I would still like to be able to back up my presets and bring a PC to the venue ... just in case.

 

Did you uninstall the program before installing the new version?  Also, something else you can try is after uninstalling, find the file folder in your program files for it and delete it.  This way you know you are getting all fresh new files and nothing can get mixed between versions.  I don't know if any of this will work but these are common things to try when updating programs

Share this post


Link to post
Share on other sites

Using the Windows 7 laptop And on my Windows 10 machine I have zero backup/restore issues. I know some have but I thought today's update should fix most of them. I never had an issue though so I was lucky from that standpoint.

 

I did get one black screen after the first firmware update but after a reset I never had one again. The issue I he more often was freeze ups with a few complex patches while editing. I was able to recreate them so I will have to see if I can cause it after the update. If so I will ring up Line 6 and report it.

Share this post


Link to post
Share on other sites

Looks like most my problems have been fixed. I just checked out at least 20 presets with no problems ( I have be unable to do this till now)

 

Helix is looking up.

Share this post


Link to post
Share on other sites

Did you uninstall the program before installing the new version?  Also, something else you can try is after uninstalling, find the file folder in your program files for it and delete it.  This way you know you are getting all fresh new files and nothing can get mixed between versions.  I don't know if any of this will work but these are common things to try when updating programs

I did uninstall both the Helix program and the updater, but I did not delete any folders manually.

I will try that.

Share this post


Link to post
Share on other sites

Has There been any isues/failures or frozent Helix'es not related to USB connect or with IR's loaded?

Share this post


Link to post
Share on other sites

My Helix hasn't had any issues of note... All the updates have worked on Windows 10 Pro... keep reading that some are having issues and praying mine doesn't do the same, so far so good though... 

Share this post


Link to post
Share on other sites

And here's exactly what I'm watching - the reviews of the sound quality and ease of getting those basic sounds have me primed to buy - but I play out a LOT, charging our clients a lot of money.  This thing has to be rock solid and road ready,  failure on these gigs is not an option.  So I'm checking this thread daily,  keeping an eye on what's being reported.  Best guess,  sometime after the turn of the year - after several more "point" updates - I may see enough stabilty to plunk down my cash.  I like what I hear - but currently less so what I'm reading.

 

I'm patient.  And thanks to all the beta testers - someone's got to be the first one in…

Just out of curiosity what are you using now?

Share this post


Link to post
Share on other sites

Just out of curiosity what are you using now?

Well for the moment I've settled in on my GT-10 - I have an HD500x which I rage-quit on after about a year, too damn finicky to get good sounds out of - although Hurghanico's recent "achilles heel" post over on that board has me ready to give it another go.  Also in the collection is a GNX3 (my good-to for many years), a Tonelab SE, Pod 1, Pod 2, a GP-10 (which has a few surprisingly good amp/cab models.  Not all, but a few...), and numerous amps.  But in the current gig I really want/need to go direct, with all the flexibility that a modeler can provide.

 

I have hopes (approaching certainty) that they'll get the bugs worked out - like I said, I'll see how things are doing 'round the beginning of the year.  The Helix SEEMS to be what I've be looking for for years - but as I said above, my band doesn't go out the door for less than $2500 a nite, typically high profile corporate/city type gigs, and for that kinda money I don't take anything on stage that isn't up to it.  Nota Bene - ANY piece of gear can fail, we had a problem with the FOH just last night that had us scrambling up to the first count-off.  But it has to be the exception, 99% reliability - and it's fairly obvious the Helix is still suffering birth pangs.

 

Even if Hurghanico's recent findings encourage me to bring the HD out again, the Helix still looks promising to me.  But I ain't hurting for stuff - I can wait.

  • Upvote 1

Share this post


Link to post
Share on other sites

Well for the moment I've settled in on my GT-10 - I have an HD500x which I rage-quit on after about a year, too damn finicky to get good sounds out of - although Hurghanico's recent "achilles heel" post over on that board has me ready to give it another go.  Also in the collection is a GNX3 (my good-to for many years), a Tonelab SE, Pod 1, Pod 2, a GP-10 (which has a few surprisingly good amp/cab models.  Not all, but a few...), and numerous amps.  But in the current gig I really want/need to go direct, with all the flexibility that a modeler can provide.

 

I have hopes (approaching certainty) that they'll get the bugs worked out - like I said, I'll see how things are doing 'round the beginning of the year.  The Helix SEEMS to be what I've be looking for for years - but as I said above, my band doesn't go out the door for less than $2500 a nite, typically high profile corporate/city type gigs, and for that kinda money I don't take anything on stage that isn't up to it.  Nota Bene - ANY piece of gear can fail, we had a problem with the FOH just last night that had us scrambling up to the first count-off.  But it has to be the exception, 99% reliability - and it's fairly obvious the Helix is still suffering birth pangs.

 

Even if Hurghanico's recent findings encourage me to bring the HD out again, the Helix still looks promising to me.  But I ain't hurting for stuff - I can wait.

Cool man, thanks for the answer. I traded my GT-10 recently haha (For a Vetta II HD no less), great old machine the GT-10. I miss certain aspects of it. It was bulletproof, had the 38 second looper, was very versatile, had a great patch for my 12 string acoustic-electric and so on. Really digging the Vetta so far so all is seemingly well haha.

 

Yeah I really like the Helix also, everything about it seems top notch and so versatile and easy to carry around. The price is an ouch now though because our dollar took a huge dive in the last year. $1500 okay, $2000 just seems out of the stratosphere at the mo for a floor modeller when I already have a Mesa, SV mkii and other tube amps and processor gizmos. It is shmexy as hell though :P

Share this post


Link to post
Share on other sites
It is shmexy as hell though :P

 

Oh dude - it's "little French maid outfit with fishnet stockings" shmexy!  With all my pragmatism about sound quality and flexibility, the  "wow factor" counts for something.

 

Yeah it's pricey, and I wouldn't even be considering it if I weren't gigging regularly - but I AM gigging, DO declare the income (unavoidable with corporate/city gigs), and WILL write it off the top if I end up buying.  So it's not the money per se, strictly the reliability factor as of now.

 

ps - add a garter to the above outfit........ :rolleyes:

  • Upvote 2

Share this post


Link to post
Share on other sites

USB problems?  Don't take your Helix back to the dealer.  Boot your computer to Safe Mode.  That works on a Mac, and I think I recall there being a way to do that on Windows.

 

I had an issue with my Helix the first day, when I tried to update the firmware.  I'm using Mac OS X El Capitan.  When I got it back from the shop, the Updater wiped my Helix out again.  Still no fix since early December, still waiting for a fix from either Apple or Line 6.  Now I see Windows users are having the same issues, so maybe it's not El Cap.

 

Temporary solution:  Boot your Mac into Safe mode by rebooting holding the Shift Key down.  It won't work every time, you will eventually update firmware and use the Helix app. after some repeated tries.  

 

Important - Drag and Drop presets into a Folder in the Finder - then try to Export a Bundle.  Be prepared to Force Quit the Helix app if it disconnects and try again.  The Quit option isn't available.

 

A couple of weeks ago, I reset my PMU on the Mac after reading some threads about USB issues.  It didn't fix the problem.  The Updater locked the Helix up again tonight when updating to Firmware 1.06,0.  I had to boot to Safe Mode, roll it back to to 1.04.3 to unlock it because it wouldn't take 1.06.0.  Luckily, all the presets I worked on were intact when it rebooted.  I was able to Drag-and-Drop my presets onto Finder, but the Helix app. kept disconnecting consistently when I tried to Export a Bundle.

 

I was then able to get the Helix to Update to 1.06.0, and export Bundles and Setlists successfully after unplugging/plugging and rebooting the Helix app. because the Helix kept disconnecting, or wouldn't be recognized by the app.

 

We really need a fix for the USB problems.

Share this post


Link to post
Share on other sites

I bought a JTV 59 and the Helix mid January and both have issues. The JTV started to change models randomly on two seperate occasions in the first week (seems to be behaving itself for now.... fingers crossed) and the Helix has no working mic in, which I opened a ticket on and reported to my dealer on the second day of use and I am still waiting for a solution. Not a happy bunny! But even though there are teething problems, once resolved you would have to prize both products out of my cold dead hands to get them off me. Playing more than ever!!!

Share this post


Link to post
Share on other sites

One month on and still no solution/no Helix ..... pissed off is an understatement. Come on Line 6 sort it out!!!!

Share this post


Link to post
Share on other sites

Chase up your ticket

I have managed to get mine returned to have the mic looked at

But you need to keep on top of it on the ticketing system

Share this post


Link to post
Share on other sites

One month on and still no solution/no Helix ..... pissed off is an understatement. Come on Line 6 sort it out!!!!

I just checked up on your ticket and it appears we gave you a list of service centers to take your Helix to, did you receive that list? 

Share this post


Link to post
Share on other sites

Not a single issue as a soundcard or updating with Windows 8 or 10 (two different laptops), all my screens are good, It's already been kicked around at a few shows and held up nicely....

 

I think the issues are no more than anything like this that goes into mass production.

Share this post


Link to post
Share on other sites

Hi line6hunter, Yes indeed, I got the list through. I am just waiting for line6 (Spain) to send me a new one. Paid for back in November, promised for Christmas delivery, which never happened, came mid January, fault reported on second day of use and still no news.... well at least I have my JTV59 with the intermittent toggle switch problem to play with. I actually love the products, just not the hassles with the dealer and their lack of interest now they have my hard earned cash. If you have any suggestions on rectifying the toggle switch problem I would be more than grateful as I am totally reluctant to let it go back to line6 Spain (my guitars don't like to leave home alone, if you can understand that) Please don't take what I say as attacking line6 or the products as when they are working perfectly well I am 100% sure I will be over the moon. It's just turning into a bit of an epic saga. Thanks for the interest.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...