Jump to content
bellara

POD X3 Live HISSING

Recommended Posts

Hi.

 

POD X3 Live (and I would not be surprised if ALL MULTI EFFECTS) - terrible Hissing pb.

Just found the root cause but don't know how to solve it.

 

My device is connected via USB to the PC.

The device is also connected to external sound card in stereo using 2x 1/4 cables.

In fact there is a loop POD==>USB==>PC==>sound card==>POD.

HISS occurs in that very construct even if POD is not plugged to the transformer power supply !!!

 

The hiss is EMI induced (electro magnetic interference) from electrical source which ever it is (probably computer)

 

If I break the loop in any way, EMI induced hiss stops.

for instance,

  1. keep  POD==>1/4 cables==>sound card plugged and disconnect USB ========> no more HISS.
  2. Keep PC==>USB==>POD plugged and disconnect 1 of the 2 1/4 cable = 2fold less hiss ; the 2 cables ====>no more HISS.

 

What I am not sure is whether loop can be broken using solid and shielded 1/4 cables.

 

Any help appreciated.
DIMEBAG.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...