Jump to content
ccornel

Need Expression Pedal Help

Recommended Posts

Good morning.  I can't figure out what i'm doing wrong.  When I add additional expression pedals the sweep goes from 100% at one end of travel to 0% in the middle to 100% at the other end.  I have two of the Mission EP-1s that i used with AXE-Fx.  I've tried to learn the controllers, make adjustments on the Helix to the percentages, regular and TRS cables.  Nothing working.  The built in pedal works fine until i add the outboard pedals then it acts up too.  I'm hoping it's something stupid i am missing since i don't see anyone else having this problem.

 

Thanks,

 

Carl Corneliusonn

Share this post


Link to post
Share on other sites

There might be a control within the Pedal Assign area that controls the sweep of the effects pedal, like Linear and Logarithm or something like that. Seems like I ran into something similar to what you're experiencing. IIRC, Linear was the one that had the more regular sweep.

Share this post


Link to post
Share on other sites

Hello Carl

You will need to get a Line 6 specific expression pedal as they are wired differently from Roland type expression pedals....

The difference is the use of a 1/4" mono cable as opposed to a stereo cable.... Also, Line 6 uses a 10k ohm pot, but you can use most other values with the Helix without difficulty.

You can probably re-wire yours... I Included a modification drawing for your Mission EP-1... (the third diagram includes the addition of a switch so that you can switch between the stock MIssion EP-1 and Line 6 Functionality.)

I hope this helps

Seeya

Joe

 

PS.. Mission sells an EP1-L6 specifically for Line 6 devices...

 

Here is some info from the Mission website..

 

*Note that the EP1-L6 is the only Mission expression pedal that can be directly connected to the expression pedal input on Line 6 devices. Other Mission expression pedals are not compatible with the Line 6 pedal interface.

post-461076-0-59645200-1448751196_thumb.jpg

post-461076-0-16844800-1448811470_thumb.jpg

Share this post


Link to post
Share on other sites

Ugh -- so this means my Roland EV-5 pedal won't work with the Helix?

 

Actually, it probably will.

 

Also, on Helix, a LOT of other pedals work. One of my EXPs is an ordinary Ernie Ball VP Jr. with one cable connected from EXP to the output jack on the VP.

Share this post


Link to post
Share on other sites

Hello Carl

 

You will need to get a Line 6 specific expression pedal as they are wired differently from Roland type expression pedals....

 

The difference is the use of a 1/4" mono cable as opposed to a stereo cable.... Also, Line 6 uses a 10k ohm pot, but you can use most other values with the Helix without difficulty.

 

You can probably re-wire yours... I Included a modification drawing for your Mission EP-1... (the third diagram includes the addition of a switch so that you can switch between the stock MIssion EP-1 and Line 6 Functionality.)

 

I hope this helps

 

Seeya

 

Joe

 

PS.. Mission sells an EP1-L6 specifically for Line 6 devices...

 

Here is some info from the Mission website..

 

*Note that the EP1-L6 is the only Mission expression pedal that can be directly connected to the expression pedal input on Line 6 devices. Other Mission expression pedals are not compatible with the Line 6 pedal interface.

 

 

So I opened up my 2010 model EP-1 pedal to do the mod- and it looks nothing like the prints. Mine has a single 20K ohm pot with I believe 3 wires attached. Why is it so much different than the schemes ? And yea it works well on KPA and Fractal stuff... Now what?

Share this post


Link to post
Share on other sites

Hey thanks for that!

 

I assume that I just need a regular 1/4" guitar signal cable to run it then?

Share this post


Link to post
Share on other sites

Hey Spikey,  

 

Just a standard TS cable will work and the Helix will auto-calibrate the pedal automatically.

 

Good-Luck

 

seeya

 

Joe

Share this post


Link to post
Share on other sites

My EV-5's appear to not be compatible, bummer cuz I have 3 of them and they're my favorite expression pedal.

Has anyone had success with EV-5's?

Share this post


Link to post
Share on other sites

Unfortunately, You'll have to rewire the EV-5 to work...

 

So, it isn't possible to rewire it through the min vol pot?

Share this post


Link to post
Share on other sites

I connected an ev5 and had problem but after adjusting min volume it was ok. Maybe I should try it again and see if it held good.

Share this post


Link to post
Share on other sites

hi guys i got a roland fv-500L and i have the issue that the wah is at 100 percent when heel is down and at 0 percent when toe is down. 

 

how do i get it the other way around? 

Share this post


Link to post
Share on other sites

hi guys i got a roland fv-500L and i have the issue that the wah is at 100 percent when heel is down and at 0 percent when toe is down. 

 

how do i get it the other way around? 

 

Well, for now, you can simply set the minimum and maximum opposite of what they currently are. Set it so the minimum is 100% and the maximum is 0%. There isn't a polarity setting for external pedals right now. You could also make or buy an adapter to switch the polarity of the pedal.

Share this post


Link to post
Share on other sites

That's hilarious, exact same issue with fv-500, was wrecking my head as to why it would do it but the switch to reverse min\max values resolved the problem. Expression pedals can just be the weirdest things, some I have work fine with a certain set of devices and either not at all or with weird results with others. Really wish manufacturers had just standardized. 

Share this post


Link to post
Share on other sites

Is posible only change cable conections instead of modifing  the pedal, i have a mission ep-1-r and a behringer fvc-100.

 

But i think using a phone cable instead of a trs solve the problem in ep-1-r because slave an hot are join for the simple use of this kind of cable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...