Jump to content
Sign in to follow this  
Damien19

POD HD500 4 cable method FX return clipping problem

Recommended Posts

Good day guys,

 

POD HD500 have been a great unit UNTIL....I'm using full 4 cable method.

 

Problem: I'm getting DIGITAL DISTORTION when I crank my Laney Ironheart pass 6 o'clock.

 

Elaboration:

I'm using STOMP mode since LINE produce insane hiss.  My guitar ---> IRT--->Vox 1x12 celestion G12M is super quiet even @ hard rock Alice In Chain kind of gain setting, running without any noise gate. 

 

Request:

Please help me guys, I've been using POD HD500 for 4 years and this problem put me away from POD HD for post pre-amp stage efx processing.

 

Any tricks to solve this problem? If so, please share. Treat me like a newbie , I'm seriously need a solid solution or else I just sell this POD and go for analog setup.

 

Best regards,

Damien

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...