Please ensure Javascript is enabled for purposes of website accessibility Jump to content

KB37 and El Capitan

Recommended Posts

I have a MacBook Pro 17 with an Intel Core2 Duo processor and 4 GB of RAM.


I've downloaded the latest Line6 drivers and Monkey and installed both. When I run Monkey, under Device Firmware I see "USB Firmware" version is "Unknown". "Flash Memory" is also unknown. In the info box, I get this message: "This item is installed, but its version could not be determined."


If I then attempt to "Update selection" in Monkey, I get this message: "Could not establish a connection to the TonePort KB37.  Please check your USB connections.  If the device is plugged in, try disconnecting then reconnecting the USB cable."


I have done that, to no avail.


I tried using a different USB cable, and got this message in the Monkey info  window: "This item can only be upgraded using a USB connection. If you are currently connected using MIDI cables, please connect the USB cable and click the 'Change Device...' button, or restart Line 6 Monkey."


I did that, and got the message: "There was an error communicating with your device. If it is a USB device, try disconnecting then reconnecting the USB cable.  Error: (Code 80007103) Failed read from firmware."


I  disconnected, then reconnected again with the previous USB cable, and got the same message but with "Error: (Code 80007004) Hardware is not present."


Before, when I connected the KB37, both VU meters would light up, with the needles pinned at MAX. This time, all I get is dimmed VU meters, with alternating clip lights.


Any help would be appreciated.






Link to comment
Share on other sites

I second pretty much everything that you said, Jack. I'm using a 2008 Mac Pro, and El Capitan 10.11.1, I've done everything that I can think of, but can't get anything working. I was concerned about a hardware issue or using older firmware/flash memory, but after using Line 6 Monkey in Windows 10 on my KB37, everything works and checks out. I literally have no idea whatsoever on my Mac (main recording) environment right now. 

Link to comment
Share on other sites

el cap and latest monkey screwed up my system. when i rebooted it couldn't even find my ethernet or wireless network!!! did some disk utilities to repair and restart. Got the internet back, but comp was slow as, dragged line6 to the trash, thought maybe i'd update in another month or two. Forgot to uninstall the drivers, so tried re-installing so i could use the uninstall utility. Now i can't even get the program to launch. How do i get rid of the drivers in OS X without being able to launch the uninstall utility from line6????

Link to comment
Share on other sites

I've been working with this issue a little bit more, here's what I know. I've uninstalled and reinstalled the new driver multiple times. On restart, the computer is inoperable with my KB37 VU meters lighting up. I tried opening both the "Line6 Audio-Midi Devices" and "Sound" tabs under system preferences. While connected, the Line6 Audio-Midi Devices takes about 2 full minutes to open, only to report that there isn't anything connected. The computer completely freaks out when I hit Sound, and it reports that it can't open that preference pane. At this point I can't even shut my Mac Pro down without doing a hard shutdown and disconnecting my KB37. I've attempted everything at this point to no avail, so still no luck for us KB37 users as far as I can tell. 

Link to comment
Share on other sites

  • 4 weeks later...


So, I just upgraded to El Capitan and I'm having loads of trouble with my KB37 - which I might add was working perfectly under the previous OS. I suspect something has messed with the flash memory in the hardware. Same description of events as you monadayne. I had to go back to my GuitarPort, which is working just fine. Problem is, I need keys and my condenser mic to get my music rolling again. I'm pretty much at a stand still till they decide to work on this problem. 


Has anyone figured out a work around? Maybe some way to update the flash memory without Monkey and License Manager freezing up? Mac recognizes the KB37 since the upgrade, but I haven't used it with my DAW yet. 

Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...

I'm going to sell mine and not buy anymore Line 6 hardware. They decided to ignore customer needs with this one, it's not high enough priority. My replacement was a Presonus iTwo and my old Roland GI10 plugged into its midi. I no longer can use keys, but I'm sure I'll find a cheap controller some day. It's a shame too, I've been a Line 6 guy since the mid 90s when they hit the scene.

Link to comment
Share on other sites

  • 6 months later...

Same thing here! I thought maybe by upgrading to sierra since the driver specifically say sierra that that would do it. Nope. I can run my guitar through it and it works going straight into POD farm, but that's it. The mic and keys will do nothing in Logic Pro. Monkey sees it, says everything is up to date. But it does not work. I love this controller because of guitar,mic and keys all in one package. But I guess I have to buy something else.

Link to comment
Share on other sites

I have my KB37 working on

OS X El Capitan OSX 10.11.6 

Mac Pro (Early 2008) 2x2.8 Quad-Core / 32GB

Logic X 10.2.4

Line6 Monkey 1.73.0

with POD Farm 2 2.59


by just following the POD StudioTM & TonePortTM MIDI Setup Guide.


As a Midi Keyboard controller

as a transport control

also as an I/O

Link to comment
Share on other sites

I downgraded to Yosemite 10.10.5

Using drivers 7.3.8

Monkey 1.73

POD farm 2.59


It still wouldn't work with the 7.6.4 drivers


My iMac does not give choice to go to El Capitan only straight to sierra. So I'm staying with what I have because it's working.

Link to comment
Share on other sites

  • 4 months later...

My KB37 will not transmit a midi signal when using El Capitan. The mic and instrument inputs work fine but the keyboard would not transmit a mid signal into garage band. I tried everything, re-installing software, drivers etc. 


I finally found a fix (though not too elegant) by installing Yosemite 10.5 on a new partition on the hard drive (I think this is easier than down grading from El Capitan to Yosemite). The problem with using a different partition is you have to restart to switch between operating systems to use the KB37. Downloaded Pod Farm 2.5.9 from Line 6, installed it in Yosemite, and it works again! What a pain. I don't know if Sierra OS works, my mac is too old to install it. I doubt if El Capitan will ever be fixed.


Note: If you ever downloaded Yosemite from the App store, you can download it again within your purchases tab, otherwise I could not find it anywhere.


Good Luck!


Link to comment
Share on other sites

  • 4 months later...

Hello, I'm sharing this information because after upgrading to mac sierra and logic x 10.3 I struggled to get my kb37’s midi notes to work. Thanks to the line 6 help support and running a series of tests i hope this information can be of assistance to anyone facing this problem. 


Step 1. 

Download 7.6.4 and 7.6.5 from here -

uninstall line6 first and keep kb37 disconnected from computer. Uninstall is available at applications folder -> line6 -> drivers -> line 6 driver uninstaller



Step 2.


install 7.6.4 and when u get the page where it says customise (bottom left hand corner), make sure the following preferences are checked for the installation


(a) audio driver

(b) midi driver

(d) line6 twx framework


Step 3.


restart and make sure usb of kb37 is disconnected from computer


Step 4.


install 7.6.5 with following preferences checked

© audio-midi


Step 5.


restart and make sure usb of kb37 is disconnected from computer


Step 6.


connect usb of kb37 to computer and it started working for me


Important note: 


Now every time i start up the computer, i need to make sure kb37 is disconnected before i start it up for it to work. Some of my midi keys started working strangely with logic as well (some notes are playing cycle mode). 


This is the best workaround i’ve discovered if you are having the problem where Kb37 is not working with logic pro X 10.3 on mac sierra 10.12. I understand this is the el capitan thread but maybe a similar process might work.  

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...