Please ensure Javascript is enabled for purposes of website accessibility Jump to content

HD 500 stuck on driver


Recommended Posts

I have tried and re-tried but can't seem to get this done.  My laptop runs win7.  I've got Monkey at 1.71, updated the USB firmware to 1.04, re-booted both POD and laptop ad nauseum, even turned off my Norton... but whenever Monkey tries to update the FW, it thinks it's successful yet shows the driver at  My goal is to get my hd500 from 2.32 to 2.62, but I don't want to even attempt this if I can't even get the drivers to update.


Anybody got any ideas?  


Also, when updating the POD Flash Memory, am I supposed to hold down a nav button and power it on somewhere in the process?


THANKS (in advance)!

Link to comment
Share on other sites

You may have to do a uninstall and reinstall everything if the old system driver is hiding on the system. I'm not running Win7 but you night want to make sure you are in the admin account too. Try downloading the driver directly and installing that way.


When updating the Flash the nav key stuff is for safe mode reflashing (depending on the key held) but I wouldn't bother with that at this stage.


I do like to actually download the files and choose the Monkey option of Flash from File, less retries if I get a time out.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...