Jump to content
mtreehugger

HD 500 stuck on driver 4.2.5.1

Recommended Posts

I have tried and re-tried but can't seem to get this done.  My laptop runs win7.  I've got Monkey at 1.71, updated the USB firmware to 1.04, re-booted both POD and laptop ad nauseum, even turned off my Norton... but whenever Monkey tries to update the FW, it thinks it's successful yet shows the driver at 4.2.5.1.  My goal is to get my hd500 from 2.32 to 2.62, but I don't want to even attempt this if I can't even get the drivers to update.

 

Anybody got any ideas?  

 

Also, when updating the POD Flash Memory, am I supposed to hold down a nav button and power it on somewhere in the process?

 

THANKS (in advance)!

Share this post


Link to post
Share on other sites

You may have to do a uninstall and reinstall everything if the old system driver is hiding on the system. I'm not running Win7 but you night want to make sure you are in the admin account too. Try downloading the driver directly and installing that way.

 

When updating the Flash the nav key stuff is for safe mode reflashing (depending on the key held) but I wouldn't bother with that at this stage.

 

I do like to actually download the files and choose the Monkey option of Flash from File, less retries if I get a time out.

 

-B

Share this post


Link to post
Share on other sites

Any other PC with Win7 to try it on? Just to make sure there's no issue with the POD... I'd say go ahead and update the firmware on your POD anyways, the driver issue might get fixed as a result. Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×