Jump to content
dugbug

brand new amplifi 75 won't turn on

Recommended Posts

It worked for an hour.  I updated it, sat it on the floor and played for about an hour in a benign home environment on clean power.  I had brand new firehawk fx hooked up to it.  at some point it just turned itself off.  

 

Now turning it on has a momentary awakening (a millisecond or so) and its off.  Nothing.  What is going on?  This thing CANNOT possibly be so delicate.  

 

Any ideas?  its clearly returnable.  Ill call line 6 when they open up today.

Share this post


Link to post
Share on other sites

Hey dugbug,

 

I have the exact same problem with my amplifi 150.  Good luck getting anyone on the phone, but line 6 emailed me instructions to try and reset the system to default settings.  Unfortunately, mine would not stay on long enough for me to do anything. They then told me to take it to an authorized service center since it is still under warranty. I have yet to do so considering the nearest one is 2.5 hours away, but I do plan to take it sometime this week or the next. 

 

Let me know if you find anything further, and I'll do the same.

 

Sincerely,

BennyFish

Share this post


Link to post
Share on other sites

I spoke to tech support and the girl claimed to have not heard of this issue before and recommended just return to store or for repair.  

Like you my amp would not stay on long enough to do anything with resets.

 

Im just going to exchange it if they have another or return it.  A bit nervous about exchanging it though, as perhaps a bad part entered their production line.

 

Im in 60% humidity, maybe there is an issue there I dunno.  I have had electronics fail over time due to humidity... but not within an hour of opening the box lol.

Share this post


Link to post
Share on other sites

Hey Bug,

 

Did you decide to take the amp back?

 

Quick update, my amp is currently still in the repair shop.  They had to order a new circuit board which takes a couple weeks arrive.  I'm hoping that is the only problem and I will be able to get it back in a couple of weeks.

 

BennyFish

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...