Jump to content
schontone

Helix Screen Display Problems

Recommended Posts

I am having trouble with my screen display. Started out as strange colors during start up. Progressed to lines on the screen followed by strange colors, and now it has morphed into a totally blank screen for about 2 minutes followed by intermittent lines and then strange color patterns. All this clears up after about 10 minutes and it works fine after that until the next shut down. The tone is never affected.post-2269447-0-04625600-1451007675_thumb.jpg I called Sweetwater today and they sent me a return authorization number to send it in for repair but before I do that I just wanted to know if anyone has had this problem and may have found a simple fix for it?

Thanks

 

**Click on the picture to enlarge.

Share this post


Link to post
Share on other sites

Man I'm sorry to see that, I've never seen anyone with that problem yet. Pretty major.  Sweetwater is ligit though. I got mine from them. Pre-ordered in August. Either they fix or replace it your covered. Not to worry.

Share this post


Link to post
Share on other sites

Man I'm sorry to see that, I've never seen anyone with that problem yet. Pretty major.  Sweetwater is ligit though. I got mine from them. Pre-ordered in August. Either they fix or replace it your covered. Not to worry.

Hi Glenn,

Thanks for the reply! I am trying a reset right now after reading a bunch of posts. Hope it works.

 

By the way, I bought your custom patches online a while back and they are great! I think my favorite one is the Mik Marz patch!

Share this post


Link to post
Share on other sites

Hi Glenn,

Thanks for the reply! I am trying a reset right now after reading a bunch of posts. Hope it works.

By the way, I bought your custom patches online a while back and they are great! I think my favorite one is the Mik Marz patch!

Awesome man. Thank you so much for your continued support and Merry Christmas to you and your family. I hope you get this resolved. But like I say, dont worry. Sweetaeter/Line6 will make it right for sure!!

Share this post


Link to post
Share on other sites

This looks to me like a hardware issue... especially the part where after 10 minutes the screen cleans up (heating, maybe? - or related to the video driver chip or the cable that feeds the display?). I would suggest calling Line 6 customer support and they will walk you through the troubleshooting steps to know for sure whether you need to replace it.

Share this post


Link to post
Share on other sites

Definitely a hardware issue -- get it fixed or get a replacement from Sweetwater. That child ain't right...

 

If it were heat-related, I'd expect it to be alright initially, then go bad, not the other way around. Could be a bad cold solder joint that doesn't make proper contact until it warms up... Either way -- not good. Might be a simple fix or not. It will need to be put on a test bench by a qualified service tech. OR just replaced by Sweetwater. They advertise a 2 year warranty -- time to ante up...

 

So far (knock wood) I've not needed Sweetwater's warrantee service. When my JTV-59 had its 3-way switch glitch in 2011, I dealt directly with Line 6, and they had it back to me in a week. Even though I bought it from Sweetwater, L6 stepped up to the plate and dealt with it. It's been fine ever since.

 

I hope for your sake you have a back-up plan while you wait for resolution if you need to gig in the meantime. I keep my prior equipment. I have a POD HD 500X on hand for backup purposes. I always take my last pedal and keep it in the car, just in case... I got burned when my POD XTLive died at a gig in 2009, made a flying trip home to grab my small Fender combo, but was severely limited that night. Luckily the gig was only ~5 miles away from home, but we were about 30 - 40 minutes late in starting the gig.  

 

When I had my X3Live, I had no backup, then when I got my HD500, my X3L was the backup, then when I got the 500X, my 500 was the backup. Now the 500X is the backup for the Helix.

 

I'm an engineer, and think in terms of contingencies. Firm believer in Murphy's Laws, as well....

 

Dave

Share this post


Link to post
Share on other sites

I have used Sweetwaters warranty with other products. They are good to their word. They will get it repaired or replaced for you.

Share this post


Link to post
Share on other sites

Thanks for the input from everyone. Sweetwater agreed that it was a hardware issue. Sent it back today fully insured via UPS for $71.40. Not happy about that after only having it since October this year.  But the unit is pretty much non usable without a screen so I didn't have a choice at this point.

Share this post


Link to post
Share on other sites

Thanks for the input from everyone. Sweetwater agreed that it was a hardware issue. Sent it back today fully insured via UPS for $71.40. Not happy about that after only having it since October this year.  But the unit is pretty much non usable without a screen so I didn't have a choice at this point.

 

Surely they are going to reimburse you for the shipping costs!?

Share this post


Link to post
Share on other sites

Surely they are going to reimburse you for the shipping costs!?

I sent an email to my Sweetwater rep to ask him if he could do anything about that but I haven't heard back yet. The tech guy there said that the policy was to pay only for the return shipping. So that is all I know at this point. 

Share this post


Link to post
Share on other sites

I sent an email to my Sweetwater rep to ask him if he could do anything about that but I haven't heard back yet. The tech guy there said that the policy was to pay only for the return shipping. So that is all I know at this point. 

 

Have a look here, under 'A few details to be aware of:': http://www.sweetwater.com/about/warranty/

 

This states that you are responsible for shipping both ways! I should have read that before I purchased a Helix from them. $71.40 is no small amount to just throw away like that, for one way. Even a slightly less shipping cost is still too much. This makes their 2-year warranty a bit useless. Hopefully you can convince someone to reimburse you. They also state on their site that if something is defective before 30-days, they will pay all shipping. A couple of more months longer than 30-days isn't too much to ask for them to pay all shipping costs for a defective device of this price.

 

Good luck to you. Keep us posted how it turns out for you, if you have the time.

Share this post


Link to post
Share on other sites

Hello sorry to hear of the issues you are having but I'm also finding screen faults. Mine arent as serious as you have experienced however I'm hoping they don't escalate.

Scribble strips have drop-outs on footswitchs 7&11 with vertical black lines when eluminated. Can't help thinking that there may be problems in the manufacturing of PCBs display edge connections.

Many other members have contacted me with similar screen faults.

Share this post


Link to post
Share on other sites

Seems to be a LOT of teething problems with Helix. Quite concerning.

 

I don't think you can actually ascertain anything as to what the total number of units with problems are. I suspect that compared to the total number out there, it's low. Of course, if you happen to have an issue, that doesn't matter to you, really. What matters is how Line 6 responds. I've seen nothing to suggest that they aren't taking every issue seriously. If you're asking for a company to produce a line where there are no problems, well, that's a unicorn. It doesn't happen. Any electronic item produced is going to have some number of failures.

 

I was at a well-known theatrical lighting manufacturer's factory, and the owner of the factory put a sign up with a quote from the company who did the roof of their building. It said, "I guarantee your roof will fail, but when it does, I'll fix it." That is how this particular manufacturer views their product and reputation. They can't guarantee their product won't fail, but they'll do anything within their power to make it right.

  • Upvote 1

Share this post


Link to post
Share on other sites

I too have seen that line 6 are stepping up to the plate where problems have been found. My point is that whenever Boss release new fx I don't hear of many of these types of issues reported. There seems to be quite a few with line 6 products historically. That said, the helix looks amazing and I do have one on preorder which is the reason for my concern. It looks so good that I want it to be able to be my all in one solution for many years to come.

 

Your point about the roof manufacturer is a brilliant example of how to instil great confidence in a product. Giving an expensive supposed tour grade premium flagship model a one year warranty isn't!! (Boss is 5 years by the way)

 

If line 6 made a similar statement declaring any faulty footswitches/screens would be replaced whenever they fail in the future I'd proceed without any concern whatsoever. However if footswitches fail or the main screen busts after 13 months I have no guarentee that I won't be left completely out of pocket having sold my entire pedalboard to find the helix and unable to gig.

 

I'm hopeful these are just teething issues because I genuinely am so excited for helix. If we're just talking design, layout, value for money, and sound, it looks like the best thing to come out for about a decade. My concern is only because I want it to last.

Share this post


Link to post
Share on other sites

Here is the update on this issue:

Unit was seen and reportedly repaired at Sweetwater within just a couple of days. :)  They told me that it was a factory defect having to do with the cable that goes to the screen. I asked if there was a way to get reimbursed for the $71.40 for my shipping costs due to the extremely short time before the unit display failed and I was told that I would have to take that up with Line 6. So if anyone from Line 6 is reading this, would you please tell me what the proper procedure is for making that kind of a request? 

Thanks 

Share this post


Link to post
Share on other sites

I don't think you can actually ascertain anything as to what the total number of units with problems are. I suspect that compared to the total number out there, it's low. Of course, if you happen to have an issue, that doesn't matter to you, really. What matters is how Line 6 responds. I've seen nothing to suggest that they aren't taking every issue seriously. If you're asking for a company to produce a line where there are no problems, well, that's a unicorn. It doesn't happen. Any electronic item produced is going to have some number of failures.

 

I was at a well-known theatrical lighting manufacturer's factory, and the owner of the factory put a sign up with a quote from the company who did the roof of their building. It said, "I guarantee your roof will fail, but when it does, I'll fix it." That is how this particular manufacturer views their product and reputation. They can't guarantee their product won't fail, but they'll do anything within their power to make it right.

Hi phil_m,

I thought as one of the experts here maybe you could help me figure out what to do next. I copied the above post for you to look at but I haven't heard anything from Line 6 on it yet. I would like to get it to the correct person but just not sure how to do that. Thanks

Here is the update on this issue:

Unit was seen and reportedly repaired at Sweetwater within just a couple of days.  :)  They told me that it was a factory defect having to do with the cable that goes to the screen. I asked if there was a way to get reimbursed for the $71.40 for my shipping costs due to the extremely short time before the unit display failed and I was told that I would have to take that up with Line 6. So if anyone from Line 6 is reading this, would you please tell me what the proper procedure is for making that kind of a request? 

Thanks 

Share this post


Link to post
Share on other sites

Hi phil_m,

I thought as one of the experts here maybe you could help me figure out what to do next. I copied the above post for you to look at but I haven't heard anything from Line 6 on it yet. I would like to get it to the correct person but just not sure how to do that. Thanks

Here is the update on this issue:

Unit was seen and reportedly repaired at Sweetwater within just a couple of days.  :)  They told me that it was a factory defect having to do with the cable that goes to the screen. I asked if there was a way to get reimbursed for the $71.40 for my shipping costs due to the extremely short time before the unit display failed and I was told that I would have to take that up with Line 6. So if anyone from Line 6 is reading this, would you please tell me what the proper procedure is for making that kind of a request? 

Thanks 

 

First off, I'm not official Line 6 support, so I'm afraid I can't tell you anything other than to go through the official support channels. Either open a ticket here: http://line6.com/support/tickets/add.html or give them a call at 818-575-3600.

Share this post


Link to post
Share on other sites

One of the only reasons I still put up with Guitar Center is because I can buy something online, ship it to my house, and if it busts, or sucks, I can return it to the store in town no problem. 

Share this post


Link to post
Share on other sites

First off, I'm not official Line 6 support, so I'm afraid I can't tell you anything other than to go through the official support channels. Either open a ticket here: http://line6.com/support/tickets/add.html or give them a call at 818-575-3600.

 

Thanks for the quick reply! I just didn't know how to proceed correctly. I will open up a support ticket and get started. 

BTW, I agree with your previous post in that no product is free from a certain % failure and what matters most is what they do to make it right.

I'm sure they will do their best.

Thanks again.

Share this post


Link to post
Share on other sites

UPDATE:

Support ticket is in and Line 6 sent me an email telling me they would respond within 3 day. I'll keep everyone posted after I get a response.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...