Jump to content
farrellk

Problem running Line 6 Updater 1.07 on Win10 64-bit?

Recommended Posts

Wondering if anyone else is having problems running Line 6 Updater 1.07 on Windows 10 64-bit?  I tried downloading tonight in an effort to update my Helix FW to the latest release.  Updater will not run after installation, yet DOES reside in memory - which I have to kill using Task Manager if I want to run Helix 1.03.

 

When downloading the installer for Updater 1.07, I get a msg stating "The signature of Line6Updaterv1.07Installer.exe is corrupt or invalid."  Going forward with the installation seems to work fine (i.e., no crashes).

 

The previous version of Line 6 Updater 1.04 runs fine.  Helix 1.03 runs fine.  Any thoughts?

 

Share this post


Link to post
Share on other sites

Uninstall the version that's currently installed (via Programs And Features).

Reinstall the latest version... and it'll then open/work properly.

 

In short, an "overwrite" install doesn't operate properly under Win10.

A clean install does...

  • Upvote 1

Share this post


Link to post
Share on other sites

Uninstall the version that's currently installed (via Programs And Features).

Reinstall the latest version... and it'll then open/work properly.

 

In short, an "overwrite" install doesn't operate properly under Win10.

A clean install does...

jroseberry - you nailed it on the head.  That's exactly what the problem was.  I did as you suggested, and it worked like a champ.  Thank-you!

Share this post


Link to post
Share on other sites

1.07?!

What's new in it? Is it just a maintenance release or are there new toys to play with?

Do tell. Do tell!

Share this post


Link to post
Share on other sites

1.07?!

What's new in it? Is it just a maintenance release or are there new toys to play with?

Do tell. Do tell!

Version 1.07 applies to "Line 6 Updater version 1.07," which is necessary if you want to use the latest Helix Firmware (which is 1.06.0).  I think you're looking for the list of features in that new Firmware.  Those features are Pinned at the top of the Helix forum.

Share this post


Link to post
Share on other sites

Version 1.07 applies to "Line 6 Updater version 1.07," which is necessary if you want to use the latest Helix Firmware (which is 1.06.0).  I think you're looking for the list of features in that new Firmware.  Those features are Pinned at the top of the Helix forum.

 

Umm... Don't think so.... I loaded Helix FW 1.06.0 with the prior Line6 Updater version 1.04, and it worked fine.

 

Helix FW 1.06.0 was released 01/26/16, and the Updater Version 1.07 was released 02/02/16 -- I believe I updated the Helix prior to 02/02. It might be necessary for future FW updates, though. I am running Win8.1 64-Bit, so don't know if that's a factor... I did update to the Helix App Version 1.03 before backing up my Set lists for the firmware update -- that one was released the same day as the new Firmware and was necessary for the process.

 

The Helix Rack FW 1.06.2 was released the same day as the Updater version 1.07 -- the Updater update was to support the newer hardware (Helix Rack, Firehawk 1500, and the new wireless), I believe.

 

The process went smooth for me, though, I did have the Helix App trigger my antivirus -- was not digitally signed properly by Line 6, and I installed it anyway (didn't like to, but I did). I downloaded the Updater version 1.07 a day or so ago, and IT also triggered my antivirus - saying it is not digitally signed by Line 6! C'mon guys -- get'er done right!! Digitally sign the new stuff so it doesn't give us heartburn, alright?

 

I have not yet installed the new Installer, probably this weekend. Will probably uninstall 1.04 first -- makes sense, and won't hurt to do that. Just not looking forward to the nerve-wracking prospect of having warnings going off when I install version 1.07....

 

Dave

 

Share this post


Link to post
Share on other sites

Umm... Don't think so.... I loaded Helix FW 1.06.0 with the prior Line6 Updater version 1.04, and it worked fine.

 

Same here.

Share this post


Link to post
Share on other sites

My bad.  I SHOULD have stated this: When using Line 6 Updater 1.04 to update my Helix FW to 1.06.0, the Updater wanted to update itself to 1.07 before it would give me the option to update my Helix FW to 1.06.0.  That is why I made the assumption that the Updater needed to be updated first.

Share this post


Link to post
Share on other sites

My bad.  I SHOULD have stated this: When using Line 6 Updater 1.04 to update my Helix FW to 1.06.0, the Updater wanted to update itself to 1.07 before it would give me the option to update my Helix FW to 1.06.0.  That is why I made the assumption that the Updater needed to be updated first.

 

I never got that updater message. But if I remember correctly, the v1.07 Update app was released about a week later after firmware v1.06.0, and may have had something to do with firmware v1.06.2 for Helix Rack.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...