Please ensure Javascript is enabled for purposes of website accessibility Jump to content

USB Windows error when Helix boot!


Recommended Posts


I have a USB error on Windows(7, 8, 8.1 and 10) when I boot my helix and it is cold. If I boot and it's hot I do not have this problem.

I tried everything and nothing works:


1. uninstall the driver

2. Helix factory reset


do you have an idea?



Link to comment
Share on other sites

I tried! usb cable, other windows systems, other laptops!

each time you start the Helix I get the message "USB not recognized" just when cold!


Unless you live in the Arctic or Greenland in wintertime, due to the fact that this only happens when the Helix is cold, it sounds unfortunately like it might be a hardware issue. I suppose you could always try reinstalling the latest firmware in case this issue is actually a firmware issue related to the amount of time the Helix has been up rather than how warm it is. If that does not fix the issue, you may want to open a ticket with L6 support for this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...