Jump to content
acelab

Guitar > Helix > RC-300 >L2m

Recommended Posts

Hi there,

 

I've ordered a pair of StageSource L2m speakers. My initial intension was to connect them via L6 link to the Helix. However I still want to include my Boss RC-300 in the setup.

 

So I think I have to ditch L6-link and go from the Helix with 2x 1/4" out into the RC-300 L/R instrument ins and from the 1/4" outs into the L2m 1/4" (or XLR) in, right?

 

Or am I missing some cabling option here? Maybe connecting the RC-300 in a send/return loop of the Helix instead?

 

Is anybody using a similar setup with Helix, RC-300 and StageSource FRFRs?

 

Best regards,

Ace

Share this post


Link to post
Share on other sites

Hi there,

 

I've ordered a pair of StageSource L2m speakers. My initial intension was to connect them via L6 link to the Helix. However I still want to include my Boss RC-300 in the setup.

 

...

Maybe connecting the RC-300 in a send/return loop of the Helix instead?

....

 

I don't have the RC-300 but I think you have the answer there, just use the outputs or the sends,  and the returns on the Helix for the RC-300 and you can still the L6 Link to your L2ms. It probably just depends on what works and sounds best for you best in terms of routing, whether you come out of the RC-300 or the Helix to your L2ms. At some point when the signal goes to the RC-300 you will have a D/A conversion. Not that this should cause an issue. I would probably opt for looping the RC-300 in the Helix and using the L6 Link to the L2m speakers. Please let us know what works best for you.

Share this post


Link to post
Share on other sites

I have both the RC300 and a Roland GR-55.  I plan to connect to Helix via the return/send loops on the Helix.  There's a YouTube video where someone briefly describes connecting his GR-55.  But there's not problem that I'm aware of.  You're gonna love those stagesource speakers.

Share this post


Link to post
Share on other sites

I don't have the L2ms yet but I've tested the setup with my small studio monitors today.

 

It does work like a charm, here is what I did:

- Global settings in Helix changed for Send 1, 2 and Return 1, 2 to be line level (default is instrument level)

- Guitar goes into Helix

- Send 1+2 from the Helix go to Instrument In 1+2 on the RC-300.

- Main Output L+R from the RC-300 go into Return 1+2 on the Helix.

- 1/4" Output L+R from Helix go into the studio monitors (later to be changed by using the L6-link when the L2ms have arrived)

 

BUT to use this setup it looks like I would have to change 2 things in each and every preset on the Helix:

- Adding a block "Send 1+2" in the main path just before the output so the processed guitar signal is routed into the RC-300 for recording/looping

- Adding a second signal path with "Return 1+2" as the input so the three audio tracks from the RC-300 get out to the speakers (or alternatively add another block "Return 1+2" to the main signal path between the send-block and the output).

 

Too bad this can't be done globally or am I overlooking something here?

Share this post


Link to post
Share on other sites

You can create a template preset for this and then copy that template as a starting point for all new presets.

  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for pointing out the templates, very handy!

Everybody interested in creating own patches should give a closer look to templates, saves a lot of time.

For the factory settings to include the send/return loop however still every single one needs to be edited. Ah what the heck, I make the best out of it and consider it training on the device ;-)

Share this post


Link to post
Share on other sites

Acelab, I have the exact same issue.  I have a helix floor, boss rc 300, and 2 Stagesource speakers.  

 

The Stagesource speakers are connected via the L6 links, which I love b/c its so simple.  

 

Looks like you figured out how to set everything up, and I'm stoked about the template to ensure the RC-300 is factored in all future patches, but did you ever figure out a way to update all the factory patches?  Would hate to have to go in and add a new block to everyone.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×