Jump to content
shawncooke1

Helix sending midi command when switching patches?

Recommended Posts

I have created some good 4cm patches that work well with my JVM210.  I have it sending midi commands to control my amp channels.  For things to work on my amp, my fx loop has to always be on.  On the patches I created, there isn't a problem, but when i switch to a patch someone else made it sends a midi note and either/or changes the channel on the amp or turns off the fx loop.  WTH?  Im lost!  I can't figure it out, or how to fix this.  Does anyone have this problem, or a fix for it? Thanks for all the help I have already received, and hope to get more.

Share this post


Link to post
Share on other sites

There has got to be a midi or cc setup page with settings. Pure guess but Look under setup .

Share this post


Link to post
Share on other sites

Yes, you have to turn off sending PC messages in the global settings of the Helix. I'm not in my studio, so can't tell you exactly the name of the parameter, but it's under MIDI in global settings ;-)

Share this post


Link to post
Share on other sites

Thanks for the info. I did turn off sending PC messages.  Its really weird.  I have to set it to command/program, but I can't crack the code.  I can get the JVM to to stay or switch to a channel when I turn the preset selector knob clockwise or select the next preset button on the foot switch to the right.  But then if i turn the knob back to the left, it seems to send a different midi note and changes to a different configuration on the JVM. example..

 

Im on preset 1 on helix, JVM is on clean green, fx loop on

turn knob clockwise to preset 2, JVM goes to crunch orange, fx loop on

turn knob to preset 3, JVM goes to clean green no fx loop on

turn knob counterclockwise to preset 2, JVM goes to clean green, no fx loop on.

 

The way I got it to some what work on switching clockwise was to set an instant command in command center.  But I can't for the life of me get to crack the code.  I want to be able to use my power amp for some patches and just the preamp for others. But no matter what i chose there, I have to be able to have the fx loop on at all times. Thats where Im running into the biggest problem. I can't get the fx loop to come on with every Helix preset.

Share this post


Link to post
Share on other sites

I have a JVM410H and got into a bit of trouble with the PC send before I realise there was a setup in the global settings section. Once the PC send was turned of all was behaving normally.

 

Just to make sure we covered all the basics. Once the PC send is turned off the HELIX will stop sendind the usual 1-128 PC message according to the patches number 1A - 0, 1B- 1, 1C-2, etc up to 32-D - 127. It will rely entirely on what you put in the control center (instant and footswitch related PC). What I have done is created memory sttings in the JVM corresponding to the channel/mode I like and associated those to PC number. To do this you have to send a PC message after you press twice on the program button on the JVM. So once you configured the JVM the way you want say preset 2 crunch-orange FX loop on, press twice the program buuton on JVM and then send you MIDI PC message by selecting the HELIX preset 2. I assume you pick the PC number 2. JVM will flash to confirm it received the message. You can then copy the HELIX patch anywhere you want it will always send the MIDI PC 2 message every time you pick that patch.

 

When you say you tried patches from others it suggests it has some intant PC message in the patch or that the PC send has not being disabled in the Global Settings. If there's no instant PC there's no reason why it would change by itself. Hope this help. I tougth my setup was fried as well besause I had two different type of PC message sent. Had my HELIX for a month now. Spent countless hours and am very happy with the purchase. Hope that helps. You'll get there.

Share this post


Link to post
Share on other sites

Its really weird.  Today when I turned everything on, it worked like it was supposed to. I guess the JVM or the Helix just needed a break or a restart. Thank you guys for the help. I was sure banging my head off the walls last night.  This thing is getting so close to being the complete deal for me.  Im thinking that the people that has already sold theirs, or taken it back, just didn't spend a bunch of hours with the board to make it what they want.  It takes a huge amount of time to perfect it because it is so customizable.  Im glad I have stuck with it.  Im sure in the end Im gonna love it.  Ive yet to run it through the PA.  Just headphones and JVM.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...