Jump to content
Sign in to follow this  
troy

Helix crashing my computer Windows 10

Recommended Posts

I'm using Windows 10 (64 bit) and I can get the updater and Helix app to work IF I restart my computer with the Helix ON, if the Helix is not ON when the computer restarts then turning the Helix on will crash my computer everytime

 

I was able to update and I'm able to use the software but I'm curious if anyone else is having this problem

 

Yes I downloaded the Windows driver

 

Many thanks

Share this post


Link to post
Share on other sites

Does it do the same thing if you connect the USB while the Helix and computer are both already on? I'm using Windows 10 64-bit as well but haven't run into the issue (yet).

  • Upvote 1

Share this post


Link to post
Share on other sites

I'm using Windows 10 (64 bit) and I can get the updater and Helix app to work IF I restart my computer with the Helix ON, if the Helix is not ON when the computer restarts then turning the Helix on will crash my computer everytime

 

I was able to update and I'm able to use the software but I'm curious if anyone else is having this problem

 

Yes I downloaded the Windows driver

 

Many thanks

I am also using Windows 10 (64bit) and I have not experienced this. It sounds almost like two conflicting drivers, a piece of hardware (Helix or other) conflicting with the driver, or a driver that did not install properly. If this continues it might be worth backing up your presets and downloading and reinstalling the latest beta Helix App (1.11.1) and letting it reinstall all the software again in case the first download got corrupted somehow or a driver did not install properly. You can then retry the Updater and see if you are still crashing.

  • Upvote 1

Share this post


Link to post
Share on other sites

Honest Opinion is probably right about it being a driver conflict.  Without the Helix connected and "On," your PC will revert to the internal soundcard/on board sound of the motherboard..  This is the main reason you would get a bluescreen, or crash if your External Soundcard lost connection to your PC with your DAW open.

 

If you only use your Helix for a sound card, (and never will use the onboard sound again) you can simply uninstall the onboard sound drivers. Make sure your Helix drivers are up to date, and is powered on and connected to your PC each time you power up the PC.

 

If you still plan on using your onboard sound at some point for anything the above method is not for you.  What I would do at this point is make sure you install the latest Win 10 drivers for your on board audio, and for the Helix itself.

 

Even if you have up to date drivers, I would re-install both. (starting with the on board drivers first)

 

If you have trouble uninstalling the drivers, there are third party tools you can download, (most are free) that can help you with that.

I think Driver Cleaner is one of them.

  • Upvote 2

Share this post


Link to post
Share on other sites

I decided to use a different computer after un-installing and re-installing multiple times

 

Had no problems with installing Helix App for my Macbook Pro

 

thanks for the info

Share this post


Link to post
Share on other sites

I decided to use a different computer after un-installing and re-installing multiple times

 

Had no problems with installing Helix App for my Macbook Pro

 

thanks for the info

 

Great to hear, cheers! More than one way to skin a cat, my apologies to cat lovers everywhere.

Share this post


Link to post
Share on other sites

Why anybody would ever use anything other than Win7 for an audio computer is beyond me.

Share this post


Link to post
Share on other sites

Windows 10 kills with audio. Just gotta go through and turn off all the stupid Windows background crap just like you would with ANY version of Windows. 

Share this post


Link to post
Share on other sites

I have the same issue with Windows 7(x64). Turning on Helix crashes Windows. After the automatic restart & post, Windows loading screen just hangs. Using another computer is not a fix, but I suppose I can fire up VMware and have a 2nd PC/Profile with stripped down drivers and utilities as a workaround until a more stable set of drivers become available.

 

I did update my firmware when I first connected the USB to my PC, so I guess another workaround is to unplug the USB cable, turn on Helix and re-plug it in. PITA

Share this post


Link to post
Share on other sites

The solution is most likely to exit Logitech G Hub. This is what fixed it for me.

Is there a chance for Line6 or Logitech to fix this?

 

Share this post


Link to post
Share on other sites
Had the same trouble... Just built a new PC for music production, but the helix crashes the pc every time, even without the mouse and keyboard (Rapoo, not logitech).
Tried to reinstall all the drivers but didnt work.. Any suggestions?

Share this post


Link to post
Share on other sites
23 minutes ago, gumaca2 said:
Had the same trouble... Just built a new PC for music production, but the helix crashes the pc every time, even without the mouse and keyboard (Rapoo, not logitech).
Tried to reinstall all the drivers but didnt work.. Any suggestions?

 

This is an old thread so any solutions here (version numbers and such) are irrelevant. 

Here are a few things to try...

  1. When the Helix starts, look at the screen to see the firmware number... then download and install THAT version of HX Edit and/or corresponding drivers. The two need to match. 
  2. Do not connect through a hub... connect directly to the computer through a "back USB port" (fronts are usually internal hubs). 
  3. If it still doesn't work, try a different USB port and/or different USB cable.

Once you get it to start... if you don't have the latest firmware update you should perform that operation. Of course, you can't do that until you can get it to connect consistently. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Coda media. Tried to install the old drivers, and helix software but didnt work.

What solved the problem was to connect the helix into my old pc that was working and then update the firmware to 2.82

Thanks for your help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...