Jump to content
Sign in to follow this  
fastnloud

Line6 any fix for the helix channel switching issues yet??

Recommended Posts

It seems lots of people are having issues with this and I have heard nothing from line6 on this in other post. Are you guys working on a correct fix and are you willing to do this repair by having customers send the helix in for service free of charge. I have tried everything just for simple boost switching on both amps , and no bueno. I have seen a list of amps not responding and its growing. thanks

Share this post


Link to post
Share on other sites

I think somewhere in that Unbearable Patch Switching Delay (immortal) post that it was mentioned (by DI?) that Line 6 continually works on performance optimizations.

 

I think there was also a bit of discussion on the fact that Helix dynamically allocates DSP and has flexible signal routing and control, which is more to process between patch changes

 

There hasn't been an update that specifically addresses it yet though.

Share this post


Link to post
Share on other sites

^ I think fast and loud means the problems with the EXT amp sockets and many amps, not the preset switching lag.

Share this post


Link to post
Share on other sites

channel switching an amp should be a simple process for something like helix, right?.my amps are simple boost on/off switching not even really channel switching. It works with a 10 dollar foot switch but not my 1500 helix..lol

Share this post


Link to post
Share on other sites

It seems lots of people are having issues with this and I have heard nothing from line6 on this in other post. Are you guys working on a correct fix and are you willing to do this repair by having customers send the helix in for service free of charge. I have tried everything just for simple boost switching on both amps , and no bueno. I have seen a list of amps not responding and its growing. thanks

Sorry I don't have an answer on this for you, but I do want to encourage you to open a support ticket on this issue if you haven't done so already. That's the best way to get some action, or at least a direct response of some sort. Line 6 may not respond directly here but they will respond to a support ticket and then you'll have the chance to press for an answer.

Share this post


Link to post
Share on other sites

Sorry I don't have an answer on this for you, but I do want to encourage you to open a support ticket on this issue if you haven't done so already. That's the best way to get some action, or at least a direct response of some sort. Line 6 may not respond directly here but they will respond to a support ticket and then you'll have the chance to press for an answer.

 

+1 Silverhead!!  I know from experience that Line 6 will respond with three days or less (my normal response time has been 2 days.  Then, as you reply, they reply until the ticket is closed.

 

Dennis

Share this post


Link to post
Share on other sites

I opened a support ticket today but to tell you the truth ,i have had less than stellar results from them over various subjects that they should have given me direct answers to but never did that for me.Im betting they have no real solution to this fix.


 


My gigrig G2 has no issues doing this simple task and either does my cheap little 10 dollar switch box. maybe they need to contact gigrig and find out how to make this work?


 


I will be updating what line6 tells me ,from this post.


Share this post


Link to post
Share on other sites

maybe you post some details on your issue here including what amps and gear you are using and someone else can assist.  This is a users forum after all.  Try the FB Users group too.

Share this post


Link to post
Share on other sites

 

I opened a support ticket today but to tell you the truth ,i have had less than stellar results from them over various subjects that they should have given me direct answers to but never did that for me.Im betting they have no real solution to this fix.

 

My gigrig G2 has no issues doing this simple task and either does my cheap little 10 dollar switch box. maybe they need to contact gigrig and find out how to make this work?

 

I will be updating what line6 tells me ,from this post.

 

Copy and paste (into the next thread) will not speed up things either...

Share this post


Link to post
Share on other sites

Some info if you haven't seen it yet.

 

http://line6.com/support/topic/16178-helix-4cm-amp-switch-mesa-v25-and-mesa-mini-rect-not-working/?p=132241

 

---may be a simple external solution.

 

http://line6.com/support/topic/16444-4cm-with-ext-amp-control-issues-with-exp-pedal-position/?p=131997

 

--- internal done by line 6. I think.

 

 

I hope these help.

Share this post


Link to post
Share on other sites

sup guys, ive been having this same issue with my mesa rectifier. i tinkered with it a bit and this may help you guys out.

you have to go into controls and assign a foot switch to ext amp. then set it to 1 (tip) or 1and2. 2(ring) i couldnt get to do anything.

but when you do this it only works on the stomp presets. for example, when you pick weather or not you want snap/preset or snap stomp be sure to have stomp on there somewhere. then like i said assign it to a switch. now this next part is important, when you assign it to a switch hit the save button. at the bottom of the screen you will be givin an option on where to save it. for example 1a,1b,1c ect. be sure to save it to a switch that is in stomp mode. these usually have no label on the little tab screens. once done the tab should say ext amp. now press it and bingo. your channels switch.however i still have not figured out how to set it up to where you can have one switch to dirty and one switch to clean. the problem im having is once you switch on channel 1 and then click the other assigned switch to channel 2 it leaves on both channels instead of switching the other one off. so atleast the channels are switching atleast lol.

Share this post


Link to post
Share on other sites

i gave in and got a voodoo labs amp switcher,i just couldnt get the helix to change amp channels based on what snapshot i was on!!!

 

now it works fine,just select the right midi cc number for either channel and save for that snapshot,also have the option of running another 3 jacks to change other channels etc.

 

line 6 have failed with this option big time!!!!

Share this post


Link to post
Share on other sites

i gave in and got a voodoo labs amp switcher,i just couldnt get the helix to change amp channels based on what snapshot i was on!!!

 

now it works fine,just select the right midi cc number for either channel and save for that snapshot,also have the option of running another 3 jacks to change other channels etc.

 

line 6 have failed with this option big time!!!!

 

Did you get the EXT AMP jack to work with a footswitch? If you can do that, you should be able to get it to work with snapshot changes.

Share this post


Link to post
Share on other sites

Working fine for me.
Only way for it to work is to assign it to an actual footswitch on the Helix and then enable or disable the footswitch and save it to a snapshot.

Share this post


Link to post
Share on other sites

channel switching an amp should be a simple process for something like helix, right?.my amps are simple boost on/off switching not even really channel switching. It works with a 10 dollar foot switch but not my 1500 helix..lol

It would be impossible to make channel switching work on EVERY amp out there. So many amps do it differently. Helix has switching that works on a lot of amps, but not all. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...