Jump to content
Smashcraaft

HD Edit 2.26 collection of known issues

Recommended Posts

Hello. I am sure I have read about some real bugs of HD Edit in the past, so we should take the time and ask Line6 to fix them.

This thread should be used as a collection to provide all needed changes in one list. So, at the end we should have a list of errors to be fixt and (additional) also some realistic (!) wishes (probably never will be fulfilled).
First error I remember was something with mixer volume, which would not be saved in some instances (maybe only if the POD is connected via USB?). Maybe someone can specify this error more detailed?
My personal biggest (realistic) wish for an update of HD Edit would be a tab-functionality to jump to the next knob or parameter and a much more straight visualisation of the chosen (or mouse-over) effect.


So here is the list (I would like to keep updated)

Bugs

  • take a look at the system defaults and set them to the most common and flawless values.
  • get rid of "(Code 8000000a) Operation timed out".
  • add the software-ability to fix the hardware knobs, as those seem to move by themself through vibrations.
  • expression-pedal related multi-platform bug crashes Edit, if you extensively use wah for more than a couple of minutes (Details 1, 2, 3).
  • DEP lack of displayed knob-values (missing value-display is a known bug. Feature introduced with Ver. 2.25).
  • Error when saving mixer volume (only HD is connected via USB) >>> ideascale
  • I can recall encountering a bug where one side of the mixer, the right channel, occasionally went silent for some reason, and the solution was to just move the volume slider, if using HD Edit.
  • strange general behaviors when HD is connected via USB (should be explainded more detailed).
  • f.e. changes in FX and Amps that are performed over footswitch or expression pedal are not instantly updated/visible (some times not at all) on the edit software. There is no way to know if changes (for example, volume) are actually taking place. Communication between the software and the unit must be improved.
  • I found after editing multiple patches and then quitting the POD HD 500 EDIT you have to restart your pedal to reread the newly edited/loaded patches or they won't play right.
  • the delay settings are not properly transferred from the editor to the device
  • afaik there might be some unfixed issues with some amps in the model packs.

Wishes

  • tab-functionality to jump to the next knob or parameter
  • add an overload Indicator in the HD500 signal chain
  • add a vertical scrollbar to allow native resolution of netbooks
  • much more straight visualisation of the chosen (or mouse-over) effect
  • I want to be able to see value of knobs before turning any. Its hard to tell EXACTLY what % your knob is on. The dot that represents true button placement does not get you close enough. I want to edit by the numbers not a grainy LCD screen. Often I need to edit just a couple numbers.
  • add some more mic angles for the SM57 and some valuable mics
  • add some kind of Global EQ patch-wise as an effect-block or DEP
  • Dual Output Modes
  • add API-functions or let the HD Edit go Open Source

Share this post


Link to post
Share on other sites
All issues above should serve as a basis for further discussion. 

Some points could not clearly been allocated as bug or wish. 

​It´s a matter of the viewpoint in some cases  :rolleyes:

Share this post


Link to post
Share on other sites

Fix the bug that crashes Edit if you play using wah for more than a couple of minutes. And I do mean crash. I usually have to restart *Windows* to sort the mess out.

  • Upvote 2

Share this post


Link to post
Share on other sites

Fix the bug that crashes Edit if you play using wah for more than a couple of minutes. And I do mean crash. I usually have to restart *Windows* to sort the mess out.

WTF?! Is this a known issue on all PODs?

Share this post


Link to post
Share on other sites

WTF?! Is this a known issue on all PODs?

 

Far as I know. I've read other posts on this forum complaining about it, so it's not just me.

 

Try for yourself - open a patch with a wah pedal in Edit and start playing. Sometime under 5 minutes, you should get the crash (unless this is purely a Windows / Edit issue and you are running on a Mac).

  • Upvote 1

Share this post


Link to post
Share on other sites

Fix the bug that crashes Edit if you play using wah for more than a couple of minutes. And I do mean crash. I usually have to restart *Windows* to sort the mess out.

 

I've never experienced this. When I used the HD on Windows 7, there were times when I would have HD Edit running while using the wah. Never had any crashes because of it.

 

There is one bug I wish they would have fixed a long time ago: you can't see DEP values, even when changing said values. It's been a while since I've used HD Edit, but I also remember this bug getting more complicated when using dual amps. I opened a support ticket for this, must have been about a year ago now. They said they were aware of it and working on a fix. Yea, right.

 

Sadly, one can kind of get the impression that they have abandoned any future updates, even bug fixes, for the HD series.

  • Upvote 1

Share this post


Link to post
Share on other sites

Far as I know. I've read other posts on this forum complaining about it, so it's not just me.

 

Try for yourself - open a patch with a wah pedal in Edit and start playing. Sometime under 5 minutes, you should get the crash (unless this is purely a Windows / Edit issue and you are running on a Mac).

I´m gonna give it a try on Win7 and latest Mac-OS.

Which one? "Obi Wah" or "Vetta Wah"?

Share this post


Link to post
Share on other sites

There is one bug I wish they would have fixed a long time ago: you can't see DEP values, even when changing said values. It's been a while since I've used HD Edit, but I also remember this bug getting more complicated when using dual amps. I opened a support ticket for this, must have been about a year ago now. They said they were aware of it and working on a fix. Yea, right.

 

Sadly, one can kind of get the impression that they have abandoned any future updates, even bug fixes, for the HD series.

Do I understand you right that you are talking about the lack of displayed knob-values?

Not sure if this is a bug or a missing feature  :mellow: But anyway

 

Time will show, if the Editor is abandoned, but we should give it a try and if we talk about real bugs Line6 should be interested in fixing them even because the HD still sells and will keep on selling if Line6 offers a minimum of support to it.

Share this post


Link to post
Share on other sites

Fix the bug that crashes Edit if you play using wah for more than a couple of minutes. And I do mean crash. I usually have to restart *Windows* to sort the mess out.

 

 

Far as I know. I've read other posts on this forum complaining about it, so it's not just me.

 

Try for yourself - open a patch with a wah pedal in Edit and start playing. Sometime under 5 minutes, you should get the crash (unless this is purely a Windows / Edit issue and you are running on a Mac).

 

 

Same crash on Mac OS X, no matter the version. This is something I mentioned often (both here in the forums and support tickets), and they just tried to blame my computers or simply denying reality.

 

A real shame.

  • Upvote 1

Share this post


Link to post
Share on other sites

I´m gonna give it a try on Win7 and latest Mac-OS.

Which one? "Obi Wah" or "Vetta Wah"?

 

It happens with any wah effect. I think the problem is caused by the heavy two-way USB traffic caused by operating the pedal while Edit is running, but I cannot prove it. All I can do is *replicate* the crash - but as you likely know, reliable replication is the indicator that a true bug does exist.

  • Upvote 2

Share this post


Link to post
Share on other sites

Same crash on Mac OS X, no matter the version. This is something I mentioned often (both here in the forums and support tickets), and they just tried to blame my computers or simply denying reality.

 

A real shame.

 

Ed thank you for confirming the fact that this is a real and general problem. Much appreciated.

  • Upvote 1

Share this post


Link to post
Share on other sites

Here are some other users reporting the same problem, starting with Ed_Saxman (see also above):

 

http://line6.com/supportarchivenew/thread/90494/

 

http://line6.com/support/topic/12509-fk-what-just-happened/

 

http://uk.line6.com/supportarchivenew/thread/84091/

 

To be clear, I think the problem is actually caused by using the expression pedal with Edit open - not just the wah effects.

  • Upvote 1

Share this post


Link to post
Share on other sites

Here are some other users reporting the same problem, starting with Ed_Saxman (see also above):

 

http://line6.com/supportarchivenew/thread/90494/

 

http://line6.com/support/topic/12509-fk-what-just-happened/

 

http://uk.line6.com/supportarchivenew/thread/84091/

 

To be clear, I think the problem is actually caused by using the expression pedal with Edit open - not just the wah effects.

Thank you both! I've added this in the bugs-section and linked the details.

  • Upvote 1

Share this post


Link to post
Share on other sites

Do I understand you right that you are talking about the lack of displayed knob-values?

Not sure if this is a bug or a missing feature  :mellow: But anyway

 

Time will show, if the Editor is abandoned, but we should give it a try and if we talk about real bugs Line6 should be interested in fixing them even because the HD still sells and will keep on selling if Line6 offers a minimum of support to it.

 

It's definitely a bug. It was introduced, if I remember right, with version 2.25 of the editor. The one that started supporting the amp packs. And I just looked at the download page, which says this is one of the bugs, or some variation of it, that they fixed. Lol. Delusional.

 

I'd say time has already shown that they aren't interested anymore, despite it being a current product. The last editor version was released a year ago. But you're right, there's something to be said from persistence. You never know; it could result in them acting.

  • Upvote 2

Share this post


Link to post
Share on other sites

It's definitely a bug. It was introduced, if I remember right, with version 2.25 of the editor. The one that started supporting the amp packs. And I just looked at the download page, which says this is one of the bugs, or some variation of it, that they fixed. Lol. Delusional.

 

I'd say time has already shown that they aren't interested anymore, despite it being a current product. The last editor version was released a year ago. But you're right, there's something to be said from persistence. You never know; it could result in them acting.

Thank you! I've added this in the bugs-section.

@ALL: You are highly invited to correct my grammar and misspellings! Please get in contact via my profil > personal message to keep this thread as clean as possible.

  • Upvote 1

Share this post


Link to post
Share on other sites

This is a good initiative, Smashcraaft, and it's handy to have this info consolidated in one place. Similar things have been done in the past with other products.

 

It's important to understand, though, that Line 6 may or may not pay any particular attention to this thread. For sure some Line 6 staff will read it, but doing anything about it requires them to step outside their normal procedures and responsibilities. That's why it's very important to also make sure that each of these bugs and feature suggestions is also recorded in Ideascale, the official Line 6 feedback mechanism.

 

If you really want this thread to have official impact I suggest that you (or any other interested user who wants to volunteer some time) go through your list one item at a time and determine whether or not the item is already present in Ideascale. If so, provide link(s) to the relevant Ideascale item(s). If not, create an Ideascale item for it and provide the link.

 

Then all readers here can use the links to add their own votes to their priority bugs as well as their favorite ideas and suggestions.

  • Upvote 1

Share this post


Link to post
Share on other sites

This is a good initiative, Smashcraaft, and it's handy to have this info consolidated in one place. Similar things have been done in the past with other products.

 

It's important to understand, though, that Line 6 may or may not pay any particular attention to this thread. For sure some Line 6 staff will read it, but doing anything about it requires them to step outside their normal procedures and responsibilities. That's why it's very important to also make sure that each of these bugs and feature suggestions is also recorded in Ideascale, the official Line 6 feedback mechanism.

 

If you really want this thread to have official impact I suggest that you (or any other interested user who wants to volunteer some time) go through your list one item at a time and determine whether or not the item is already present in Ideascale. If so, provide link(s) to the relevant Ideascale item(s). If not, create an Ideascale item for it and provide the link.

 

Then all readers here can use the links to add their own votes to their priority bugs as well as their favorite ideas and suggestions.

Hi Silverhead. I appreciate your words and will follow your advice (hopefully by the help of the community).
 
At the other hand I am afraid, that ideascale has not the best standing in the community to some kind of subjective lack of information, which relates to the ideas and their implementation.
 
Users seems to be disenchanted a little at this point, so I would not overrate the lack of voices screaming for this or that.
However I will do my best and hopefully it is not for nothing. A bug is a bug and should be fixed for a still selling product, without a doubt.

Share this post


Link to post
Share on other sites

I agree with your comments re: Ideascale and its perception in the community. Many users contribute their ideas with the expectation that it be incorporated quickly into the existing product. But Line 6 doesn't always use the ideas in current products. For instance, many many of the features in Helix were taken from ideas posted in the context of the POD HD products. Ideascale contributors of the original ideas will feel disappointed that their ideas are not yet, and won't ever be, implemented in the POD HD devices. Similarly you might find that some of your ideas here for improvement to POD HD Edit will find their way into future editors, and never be implemented in HD Edit.

 

But I can assure you that Line 6 does consider all Ideascale submissions. It is the primary source of user feedback that they use. And I agree that bugs should be fixed. Still, the best way to influence that is to use Ideascale. Like it or not, that's what Line 6 uses. Any minor bugs not reported and voted up in Ideascale are not likely to get the visibility required to become prime candidates for fixing.

 

Again, your efforts here are helpful and should be appreciated by the community.

Share this post


Link to post
Share on other sites

Users seems to be disenchanted a little at this point, so I would not overrate the lack of voices screaming for this or that.

 

 

They seem disenchanted because they are part of the "Bernie Sanders 'Everything is Free' cult". 

 

They want features that are only found in a $3000 unit put into a unit that cost them $300. AND they want it immediately. 

This idea that updates can be written, tested, and disseminated within hours of a request is ludicrous.

 

 

 

Even if it could be done, L6 does not give little updates. They rewrite and distribute the entire unit. This isn't a virus scanner that adds everyday a few names to an already existing list. Nor is it Microsoft, where each month you can pick and choose which updates to install. L6 gives out the entire firmware. It would be like needing to download and install Windows 10 every time you wanted an update. 

Nobody wants to do that! 

Share this post


Link to post
Share on other sites

They seem disenchanted because they are part of the "Bernie Sanders 'Everything is Free' cult". 

 

They want features that are only found in a $3000 unit put into a unit that cost them $300. AND they want it immediately. 

 

 

I wonder how many people have considered this: 

 

If the HD500 cost $500 (retail) when it first came out... 

And since people were so willing to buy it... 

 

What would they be willing to pay for the unit IF the current firmware was released into a new product instead of the current product. So, the HD500 would be running firmware 1.0 (or whatever it was initially shipped with). And then there would be like an HD600 or HD700 that is running 2.6.2. 

 

Because, really, if you look at what the initial release of the HD500 looked like -- the current firmware is easily a $1000-1500 unit when compared to the initial $500 firmware. And I am not talking about the bug fixes, I simply mean the features in it now that were not in it before.

 

BUT THAT'S NOT GOOD ENOUGH FOR PEOPLE, THEY STILL WANT MORE.  

Share this post


Link to post
Share on other sites

BUT THAT'S NOT GOOD ENOUGH FOR PEOPLE, THEY STILL WANT MORE.

 

Very true! And applies to all of us at various times.

 

Btw.... How's that request in your signature coming along? (Just kidding..... 😊)

Share this post


Link to post
Share on other sites

How's that request in your signature coming along? (Just kidding..... )

 

I didn't put it on ideascale. So I have no one to blame but myself -- which means I should make the font bigger and bolder and cry more often about how you hate us. 

 

 

 

But jokes aside:

I don't consider my EDIT request part of the unit in terms of updates even though there would need to be an update that would include drivers and such. 

I view EDIT as companion software that is separate from the paid unit. Everyone these days runs their software on the 3 platforms (Microsoft, Apple, Google), it's like adding "like us on Facebook, Follow us on Twitter" to every advertisement -- that is just how it needs done. 

Hell, my website runs something like 7 different versions to accommodate all of the various mobile options. Plus having two apps - although, we had issue with Apple so we are no longer available for them, lol. 

Share this post


Link to post
Share on other sites

....which means I should make the font bigger and bolder and cry more often about how you hate us. 

 

...

 Absolutely!! That'll do it!

 

I understand your request and it's certainly a valid one. I was just poking an elbow in your ribs a wee bit. Thanks for taking it well.

Share this post


Link to post
Share on other sites

Apart of the latest part of this discussion errors in HD Edit should IMO be fixed, because the editor is a figurehead of the device and Line6 advertises the editor on the product page as a benefit.

Share this post


Link to post
Share on other sites

I`m on a rant now.. I`m going to speak to Trading Standards tomorrow as the HD Units aren`t fit for purpose or Use. After repeatedly getting the error 8000000a code I reinstalled the edit software.. nothing same again so hooked up line 6 monkey to reinstall the firmware now got code that usb not connected please try again meanwhile my HD Pro X now wont moved off updating flash.. The Ghost in the machine has well and truly F*&ked up.. Thanks alot Line 6. These units were made before Helix as  a Pro Rig no matter of the price tag, they are supposed to work !!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

I`m on a rant now.. I`m going to speak to Trading Standards tomorrow as the HD Units aren`t fit for purpose or Use. After repeatedly getting the error 8000000a code I reinstalled the edit software.. nothing same again so hooked up line 6 monkey to reinstall the firmware now got code that usb not connected please try again meanwhile my HD Pro X now wont moved off updating flash.. The Ghost in the machine has well and truly F*&ked up.. Thanks alot Line 6. These units were made before Helix as a Pro Rig no matter of the price tag, they are supposed to work !!!!!!!!!!!!!!!!

You got a lemon. It sucks, but it happens to everyone sooner or later. Return it, get a new one, and you're off to the races. Or not, let it sour your opinion of he brand forever, and go Fractal. Either way, problem solved.

 

The overwhelming majority of them work as advertised, and have for years. It's hardly a new model.

Share this post


Link to post
Share on other sites

You got a lemon. It sucks, but it happens to everyone sooner or later. Return it, get a new one, and you're off to the races. Or not, let it sour your opinion of he brand forever, and go Fractal. Either way, problem solved.

 

The overwhelming majority of them work as advertised, and have for years. It's hardly a new model.

I`ve had it over due on the Guarantee tbh & i`m not the only 1 with these bugs.. As far as Units go I love it, yep would Love the Axe FX but I`d even go for the Helix But the funds wouldn`t go that far

Share this post


Link to post
Share on other sites

Hello Guys,

 

Same issue here (Code 8000000a) Operation timed out ^^

​

Any solution ?

Share this post


Link to post
Share on other sites

Hello Guys,

 

Same issue here (Code 8000000a) Operation timed out ^^

​

Any solution ?

I am a little bit unsure if we are talking about the same issue but I get a receive-patches timeout every time I start HD Edit.

Using the "Receive all" function works but I do not understand the reason why it has to be tickled this way.

Share this post


Link to post
Share on other sites

Yes, the same issue here ... but I found that this is clearly related to some patches.

After a factory reset, I loaded few presets from custom tone library (various dates from 2012 to 2017) and all is ok, no bug.

But when I try to load some patch from MeAmBobo package, the bug is back and I have to do the same trick as you explain (Receive all).

 

So it seems our issue is linked to some patches 'specificities' ... but how can we solve that ?

 

I sent a message to Line6Tony to get some support, hope it'll help.

Edited by Warfare
  • Upvote 1

Share this post


Link to post
Share on other sites

6. Error when saving mixer volume (only HD is connected via USB) >>> ideascale

To verify this issue (I had an unexpected loss in volume after editing some patches) I like to ask the ones who had noticed this too:

Do you maybe had entered mixer-values using a comma instead of a period dot which could have ended in a differing value which ends up in tonal-change much more recognizable than the value you changed?

 

I had made changes in a 0.5 range which lead to dramatically changes in volume but I sure accidently enter commas from time to time. So I guess (and hear) the displayed value is no longer the real value, used by the POD.

 

If this is true and a simple comma can freak out the POD HD Edit app, I strongly suggest a urgent bug fix.

Share this post


Link to post
Share on other sites

My request to the community:

please connect your POD to USB and sync it with HD Edit. Then take one of your patches and duplicate it.

Try some values in the mixer using a comma instead of a period. Send the duplicates to the POD and receive them back again.

 

If you are able to find any significant changes in volume not corresponding to the value changes or the numerical value displayed in the mixer, then please get back to me, providing the POD Version and OS you use.

 

My problem is, that i use a X and non-X POD on different desktops (Mac/Win) which complicates the testing. But I will give it a try too.

I am very afraid of loosing my perfectly balanced setlists and patches just by using HD Edit :/

Share this post


Link to post
Share on other sites

Bonjour,

aujourd'hui, je suis passé du PC portable au PC salon, j'ai installer Windows 10, ensuite Monkey, Driver (en manuel) et hd500 Edit (en manuel puisque Monkey, me l'a demandé.

 

tout ceci étant fait j'ai lancé hd500, et là, le PC me dis que le programme a cessé de fonctionné ... malgré plusieurs ré installation, toujours la même erreur. que dois je faire ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×