Jump to content
Sign in to follow this  
irfanrmd71

Line 6 xd-v75 receiver dead after update line 6 g30 transmitter and receiver

Recommended Posts

HELP URGENT!!!

 

I just perform an update to my line 6 g30 transmiter and receiver using xd-v75 receiver borowed from local music store.

It was a line 6 xd-v75 headset unit.

 

Update to my g30 went fine.

But after the update installed, i can't start xd-v75 receiver.

When i plug the power supply and switch the power button on, the screen doesn't show anything but black. The rf and battery meter in the left panel blinking red. Everything works normal before i perform update.

But when i use xd-v75 on loader enabled mode to computer, it works fine. 

Line 6 monkey can detect the xd-v75 receiver and show that their current firmware is 2.01.

 

Before performing update to my g30 receiver and transmitter, i check if my g30 receiver and transmitter detected in line 6 monkey. So i plug my receiver first, select g30 receiver from the list, and line 6 monkey detect it. After that i don't perform update right away, i press quit so i can check if my g30 transmitter detected in line 6 monkey. When i press quit, instead of quiting line 6 monkey right away, i saw line 6 monkey start reconfiguring xd-v75 for no reason. i saw performing mcu and other stuff. I'm not connected to the internet yet that time. I wonder is this is what causing problem with the xd-v75 receiver.

 

What happened to that xd-v75 receiver?

Will a firmware update solve it or can i solve it without firmware update (the stock firmware is 2.01)?

 

If i update the firmware only on the receiver (update to 2.04), will it still work without problem with the transmitter (tbp12) which have an older firmware (2.01)?

 

Honestly i feel bad with the music store. I just don't want to touch another stuff (the transmitter) because they already think that i broke the receiver, so if i touch the transmitter then they'll think that i'm gonna ruin the transmitter too.

 

Please help me.

Tomorrow i'll be back to the music store to fix this.

Sorry for bad english.

Share this post


Link to post
Share on other sites

Did you ever solve this? I seen to have a similar problem! My XD-V75 has just updated a G30 system and the G30 works fine using the later firmware but now my XD-V75 seems dead - if I connect back to the PC via USB, the screen on the XD-V75 lights up and it goes into Loader Enabled mode but if I try to operate the receiver as a stand alone - nothing, no backlight, no difference which ever way the power swich is set.

Share this post


Link to post
Share on other sites

Guys I got the same problem but I solved following these steps:

  1. When completed you should see a "XD-V75 Receiver update successful" message. Click "OK".
  2. To get the receiver out of Loader Mode, unplug the unit, remove the USB cable, plug in the power and turn the unit on

Best!

Andrea

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...