Jump to content
Sign in to follow this  
maxnew40

Joystick no longer scrolls.

Recommended Posts

I was editing a sound on my Helix floor unit and all of a sudden I noticed that the joystick no longer does anything when I turn the knob. Did I somehow configure my unit to not use the joystick for scrolling or is my joystick broken?

 

I wanted to check with users here before I submit a ticket in case I just disabled it myself.

 

I have version 1.10 firmware in my Helix.

 

-Max

Share this post


Link to post
Share on other sites

My suggestions:

- first backup any setlsits/presets you want to save

- power cycle Helix. This fixed the same symptom for me during beta testing.

- if problem persists, reinstall firmware.

 

Then open a ticket if still not working properly.

Share this post


Link to post
Share on other sites

I already tried several different reset combinations and also re-installed 1.10. I guess I will have to submit a ticket when I get home and have access to the serial number on the unit.

 

With the editor I don't need to use the joystick scroll function very often, but at the price I paid for this unit I expect it all to work. I will not be a happy camper if I have to send it back for repair. In fact I will probably just live with it if my only other option is to send it in for repair and be without it for an extended period of time.

 

-Max

Share this post


Link to post
Share on other sites

My suggestions:

- first backup any setlsits/presets you want to save

- power cycle Helix. This fixed the same symptom for me during beta testing.

- if problem persists, reinstall firmware.

 

Then open a ticket if still not working properly.

Hey Silverhead a fellow Canuk!

What do you mean by power cycle Helix!

Share this post


Link to post
Share on other sites

Hey Silverhead a fellow Canuk!

What do you mean by power cycle Helix!

It usually means switch the power off then on again.

 

-Max

Share this post


Link to post
Share on other sites

Damn it, the unit is broken and I have to send it in for repairs and be without it for potentially weeks on end. I am not a happy camper and am sort of regretting that I purchased it now (maybe should have waited a year for them to work the bugs out). My HD500 is gone and I don't really have a rig to play through now.

 

I had a similar experience with my first JTV-59 but since I bought it at a store versus online I was able to take it back to the store for an exchange. If it wasn't so expensive I would just live with it since I can still use it with the editor, but for that price failing after about two weeks is just a huge let down.

 

Was I just unlucky again or is there a high infant mortality rate for these joystick controllers?

 

-Max

Share this post


Link to post
Share on other sites

Damn it, the unit is broken and I have to send it in for repairs and be without it for potentially weeks on end. I am not a happy camper and am sort of regretting that I purchased it now (maybe should have waited a year for them to work the bugs out). My HD500 is gone and I don't really have a rig to play through now.

 

I had a similar experience with my first JTV-59 but since I bought it at a store versus online I was able to take it back to the store for an exchange. If it wasn't so expensive I would just live with it since I can still use it with the editor, but for that price failing after about two weeks is just a huge let down.

 

Was I just unlucky again or is there a high infant mortality rate for these joystick controllers?

 

-Max

 

I sent mine in for repair (different problem) and had it back in a week.   It took a while for the RMA box to get to me, but once I sent it out it was a very quick turnaround.   Hopefully you experience the same service!

Share this post


Link to post
Share on other sites

Also - I would definitely send it in for repair - sometimes one component failing could be indicative of a more severe problem.  

Share this post


Link to post
Share on other sites

I sent mine in for repair (different problem) and had it back in a week.   It took a while for the RMA box to get to me, but once I sent it out it was a very quick turnaround.   Hopefully you experience the same service!

That is very encouraging to hear. They are in California and I am in Washington, so  it should only take about 1-2 days shipping time. Waiting for an RMA after I uploaded a copy of my receipt.

 

-Max

Share this post


Link to post
Share on other sites

Also - I would definitely send it in for repair - sometimes one component failing could be indicative of a more severe problem.  

 

That is how I was thinking also. I can still use my unit fine with the edit application but I am now afraid I might have an overall poorly manufactured unit, sort of like the occasional "Lemon" that a car manufacturer will put out where one in every several thousand just isn't right.

 

I guess I am just really bummed out that I have to be without it for a while. At least I have several pretty decent amps to use. Should I pull out the Fender Supersonic or the  old Traynor YBA-1 head?

 

-Max

Share this post


Link to post
Share on other sites

That is very encouraging to hear. They are in California and I am in Washington, so  it should only take about 1-2 days shipping time. Waiting for an RMA after I uploaded a copy of my receipt.

 

-Max

 

I'm in New York - so yeah, I wouldn't worry too much.   Luckily I have an M13 too - I only use the amp/cab modelling features sparsely, I normally run through Mesa Mark V with a Two Notes Torpedo Reload back into my DAW.   I know some would be scratching their head of why I have a Helix - but, other than the reverbs, the effects are an upgrade over the M13 and it can serve as a last minute emergency backup into a house PA in case the Mesa ever died - so now I don't have to lug around another head.   Really wish Line6 would incorporate more Mesa modelling other than the Recto's in their lineup.   Oh well - all said I have a great sounding rig that's hard to put a price on.

Share this post


Link to post
Share on other sites

I have an old M-13 but it won't power up any more and I sold off all my pedals except for a tube screamer.  

 

I think I get through rehearsal with my Fender Supersonic and a tube screamer, it will be very basic but it is just rehearsal I guess.

 

-Max

Share this post


Link to post
Share on other sites

I was contacted by Frank at line 6 that even offered to send me a loaner unit while mine gets repaired. Amazing customer support from Line 6!

 

-Max

Share this post


Link to post
Share on other sites

UPS picked up my Helix, so it is on the way to Line6 for repair. I really miss it already.

 

-Max

Share this post


Link to post
Share on other sites

I just got notified by UPS that they have delivered my Helix to Line6 for repair. Lets see how long it takes for me to get my unit back. So far most people are reporting 1-2 weeks for repairs. I think I may be experiencing Helix withdraw.

 

-Max

Share this post


Link to post
Share on other sites

Hi you can add 1 more to the list, mine will do everything but scroll, confidently my issue only started after the last update, literally straight away, kinda hoped it was related but alas my helix has to go back. At least it is under warrenty

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...