Jump to content
Sign in to follow this  
FlatFingers

POD HD500X Can't get rid of an echo

Recommended Posts

I'm a newbie with the POD, and I have an FX setup with a number of effects that I switch in & out.  I'm running a Gibson SG through it & listening on headphones, running it into Cubase LE AI Elements 7 on my Win 7 computer.  There's a single slap-back echo that I can't get rid of when I want to play a clean sound.  It might be a product of recording & monitoring through the Cubase, but I've not tried generating a clean track & playing it back.

 

Anyone have any ideas?

 

Attached are pictures of my POD screens.

post-2339145-0-32576700-1463544465_thumb.jpg

post-2339145-0-71927300-1463544473_thumb.jpg

post-2339145-0-01289000-1463544480_thumb.jpg

post-2339145-0-49371800-1463544485_thumb.jpg

Share this post


Link to post
Share on other sites

My first impression is it's probably an artifact of latency in your Cubase where you're monitoring both source and recording at the same time.  If it's not there when you play it back, that's probably it.

Share this post


Link to post
Share on other sites

Plug some headphones directly into the POD. If you don't hear it that way, then the problem is further down the line...

Share this post


Link to post
Share on other sites

My first impression is it's probably an artifact of latency in your Cubase where you're monitoring both source and recording at the same time.  If it's not there when you play it back, that's probably it.

 

 

Plug some headphones directly into the POD. If you don't hear it that way, then the problem is further down the line...

 

+1. I am 98.876% sure it's that you are listening to both the HD500 and the Cubase DAW monitoring at the same time. After you've recorded it, when you listen back to the track, is the echo still there?

  • Upvote 1

Share this post


Link to post
Share on other sites

Think you guys have it - I don't hear the echo in playback.  I have my headphones plugged into the POD.  I'm pretty sure I have monitoring shut off in Cubase, but I'll have to check that out next time.  I'll post again if/when I figure this out.  Thanks!

  • Upvote 1

Share this post


Link to post
Share on other sites

I noticed the echo without being in Cubase...And, I've had to rediscover that I have to turn off Win 7 sound with the POD USB plugged into the computer OR unplug the USB after downloading settings. It's a small pain, 'cause I'd like to play along with songs from Windows through the USB through my phones connected to the POD.  So it goes...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...