Jump to content
jetdriver

Helix + H9

Recommended Posts

For those of you connecting an Eventide H9 in stereo, how are you setting your mix levels on the helix? And what happens if I only connect the mono (L) XLR to the FOH? Will it make it mono automatically? I seem to remember something about setting mix at 50% for some reason.

 

Playing live I run mono almost exclusively. So maybe it would be easier to run it/connect it that way?

  • Upvote 1

Share this post


Link to post
Share on other sites

I don't have an H9 (although I want one), but presumably you would keep it at 100% wet and control the wet/dry mix from Helix's FX Loop block's Mix parameter. 50% is a good starting point, but trust your ears.

 

If the XLR R is not connected, Helix automatically sums both sides to mono from the XLR L.

Share this post


Link to post
Share on other sites

Hey jetdriver, have you delved into having the Helix control the H9 via midi yet (just Activate\Deactive and Preset Cycling). I've been meaning to sit down and sort through it but if anyone has taken that steps and knows of any specifics regarding channel and particular program messages that have to be sent...well I'd appreciate it.

Share this post


Link to post
Share on other sites

One thing I noticed from the command center is the PC messages start at 0 on the Helix and the preset numbers start at 1 on the H9. Took a little bit to figure out why my patches were not lining up. Once I got that down it was easy peasy. The H9 actually listens to the Helix and follows its commands! (HAHA) This was my first attempt at adding a midi controlled device with my Helix, it is freakin' awesome!!

  • Upvote 1

Share this post


Link to post
Share on other sites

I have the H9 running in the FX loop as a serial effect and let the H9 control the wet/dry mix.  MIDI control is pretty good, use program change to set the effects and you can program pretty much everything else to respond to a CC message

 

Mike

Share this post


Link to post
Share on other sites

One thing I noticed from the command center is the PC messages start at 0 on the Helix and the preset numbers start at 1 on the H9. Took a little bit to figure out why my patches were not lining up. Once I got that down it was easy peasy. The H9 actually listens to the Helix and follows its commands! (HAHA) This was my first attempt at adding a midi controlled device with my Helix, it is freakin' awesome!!

 

I was reading this tread to see if the Helix could send simple PC messages, as the manual fails to mention this (I'm thinking of buying) 

But I own the H9 and one thing you can do is inside the App that controls the H9, you can set it so that it responds one number off so that the number you set on your sending device matches. I discovered this when using with my Kemper

  • Upvote 1

Share this post


Link to post
Share on other sites

I was reading this tread to see if the Helix could send simple PC messages, as the manual fails to mention this (I'm thinking of buying) 

But I own the H9 and one thing you can do is inside the App that controls the H9, you can set it so that it responds one number off so that the number you set on your sending device matches. I discovered this when using with my Kemper

 

It can send PC messages along with a bunch of other commands. It's all explained on pages 43 and 44 of the manual.

Share this post


Link to post
Share on other sites

Is anyone else having issues with clipping the H9's input with it in one of the Helix's FX Loops? I have to turn down the FX Loops send level to -2.5db in order make it stop clipping but it messes with the over all level controls of the H9 I am finding.

  • Upvote 1

Share this post


Link to post
Share on other sites

One thing I noticed from the command center is the PC messages start at 0 on the Helix and the preset numbers start at 1 on the H9. Took a little bit to figure out why my patches were not lining up. Once I got that down it was easy peasy. The H9 actually listens to the Helix and follows its commands! (HAHA) This was my first attempt at adding a midi controlled device with my Helix, it is freakin' awesome!!

 

I thought there is a setting somewhere in Helix to tell the PC messages to start at 1 or 0? I just did a brief search of the manual but am not finding that bit..

 

Also watch out for MIDI CC#128! According to the manual:(rev.D, page 58)

 

MIDI CC#: 128

Value: 0-63: Oh;

64-127: Nooo

"Helix achieves self-awareness and starts poking fun of that face you make during the solo"

Share this post


Link to post
Share on other sites

Is anyone else having issues with clipping the H9's input with it in one of the Helix's FX Loops? I have to turn down the FX Loops send level to -2.5db in order make it stop clipping but it messes with the over all level controls of the H9 I am finding.

 

Do you have the Helix's loop set to instrument level?

Share this post


Link to post
Share on other sites

Do you have the Helix's loop set to instrument level?

After I posted this I was wondering the same thing after looking at the parameters of the Global Settings. What are the default settings? I don't have my Helix in front of me at the moment but whatever the default setting are as I have not changed them.

Share this post


Link to post
Share on other sites

After I posted this I was wondering the same thing after looking at the parameters of the Global Settings. What are the default settings? I don't have my Helix in front of me at the moment but whatever the default setting are as I have not changed them.

 

I believe the default setting is line level.

Share this post


Link to post
Share on other sites

I believe the default setting is line level.

Well that's probably it then...   :wacko:  I will check and report back. Thanks!

Share this post


Link to post
Share on other sites

So it turns out the setting for the loops are set to instrument. Any ideas why it's still clipping? Someone must have run into this before. :unsure:

Share this post


Link to post
Share on other sites

So it turns out the setting for the loops are set to instrument. Any ideas why it's still clipping? Someone must have run into this before. :unsure:

 

Do you have the effects loop block after the amp block? The output from the amp block can actually be quite high, so I suppose it's possible that the output from the effect send might be hot in that case. The remedy for that would be reducing the channel volume parameter in the amp block.

Share this post


Link to post
Share on other sites

Do you have the effects loop block after the amp block? The output from the amp block can actually be quite high, so I suppose it's possible that the output from the effect send might be hot in that case. The remedy for that would be reducing the channel volume parameter in the amp block.

That's exactly what was causing it. Ch Vol was on 9.7. Turned it down and the clipping went away. Beginners mistake. Thanks so much!

Share this post


Link to post
Share on other sites

That's exactly what was causing it. Ch Vol was on 9.7. Turned it down and the clipping went away. Beginners mistake. Thanks so much!

Any chance you guys would be willing to share the patch you have that works with an H9? I have got a gig coming up where i would like to drive everything via the Helix with my 2 H9s, but every time i have tried to get them working together as a stereo setup it's not sounded great...any tips appreciated!! 

Share this post


Link to post
Share on other sites

That sounds like the same problem I was having with my Strymons, in your FX block set the Send level to -6dB and the Receive level to +6dB to get some extra headroom.

 

Craig

Share this post


Link to post
Share on other sites

I use the H9 in stereo loop 3/4.   With the exception of the Pitchfuzz (which is awesome, btw), I run the H9 after the amp, 100%.   I do have to adjust either the amp output, or the fx send/return, as well as the Input Gain on the H9.   I use the H9 fuzz with my strat (low output pickups), and a bunch of other algorithms with my humbucker guitars.  

 

I've run the H9 in a parallel path, but you have to remember to set "kill dry" on the h9 for those patches.   Pretty sure I ended up using it in serial stereo for everything, but it definitely takes some level tweaking.  At least H9 gives you a clue it's clipping (hint, hint, Eric....).  

 

My latest favorite is a patch I downloaded off of customtone called SnapsTrain.  I made a few mods, threw in the H9 and am digging it.  Right now I have no band, so I'm one of those dudes sitting at home between two L2s in stereo playing "For the Love of God" badly.    Stereo is awesome!  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...