Jump to content

Recommended Posts

I received my G10 today and it's been charging now for over 8 hours, and no charge held whatsoever.

Just flashing Red and the charging base pulsing Red.

When removed from the base its flashes red, It won't work at all or hold any charge at all :/ 

 

Very disappointing as looking at the FAQ I would of thought after 6 hours of charging I could at least test it a little but nothing.

As the FAQ advised of a small charge after just 2 hours.

 

I've seen a few others with the same problem and units were faulty. I will return it and stick to my G70 and multiple transmitters as I've now seen more people with the same problem :/

Share this post


Link to post
Share on other sites

Mine works perfectly, are you using pc-usb or original charger?

Share this post


Link to post
Share on other sites

If you're having charging issues, please make sure you seat the transmitter completely into the receiver, otherwise the transmitter will not charge. For more details, see this article: Relay G10 FAQ

Share this post


Link to post
Share on other sites

I'm having the same problem, the receiver charged initially, but after leaving it plugged into the transmitter overnight whilst not connected to the mains it appears to have completely drained it's battery and no amount of charging will fix it. Both the transmitter and receiver are permanently flashing red, I've checked that the receiver is docked properly and have attempted an update but it's too flat to complete it successfully, any ideas on where to go next?

Share this post


Link to post
Share on other sites

I'm having the same problem, the receiver charged initially, but after leaving it plugged into the transmitter overnight whilst not connected to the mains it appears to have completely drained it's battery and no amount of charging will fix it. Both the transmitter and receiver are permanently flashing red, I've checked that the receiver is docked properly and have attempted an update but it's too flat to complete it successfully, any ideas on where to go next?

 

open a support ticket with Line 6

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×