Jump to content
Sign in to follow this  
HoopUte

FBV Shortboard MkII Expression Pedal Quit Working

Recommended Posts

Anybody else run into this?  Just recently the expression function of my pedal on my 6 year old MkII shortboard quit working.  When it's in volume mode about half the time the light doesn't even come on, but there is no volume at all regardless of whether the light is on or not.  The wah on/off switch works, but there is no expression throughout the range of the pedal in that setting either.  I've tried running the pedal calibration procedure, but the board doesn't recognize any motion in the pedal.  When I press  the "D" button to move on to the second step, nothing happens and I just have to power back off and on, then play with the wah switch on. 

 

This cropped up right before a gig so I had to get creative in volume control throughout the night.  Nothing like a little added pressure, eh?

 

Is there a fix for this or will I have to buy a new board?

 

Thanks.

 

Hoop

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...