Jump to content
Sign in to follow this  
zappaman123

Flextone 2XL power cable and hum

Recommended Posts

        I have a Flextone 2xl and recently bought a power cord for it. now it's got a terrible hum, anyways, it is one I bought off an ebay store brand new. My question is: Is it the power cord or is it the amp in anyway? Any help would be greatly appreciated. Thank you

 

                                                                           Please send any thing it could be

Share this post


Link to post
Share on other sites

It could be the cord if there was no hum previously on the same outlet.  More likely its just a ground issue in the building wiring.  Try a different outlet in a different room, try to get on a different circuit.    Power cord is pretty simple, hard to get a bad one.

Share this post


Link to post
Share on other sites

I bought the cord new but not sure if the amp has its own kind of cord, I couldn't find a cord for the flextone 2xl is there a possibility it could be the wrong power cord. First time trying the amp in a while and brand new cord

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...