Jump to content
FullMotion

A Word of Warning About Helix 2.0 Update

Recommended Posts

About that "CURRENT EXISTING Helix editor app" -

1- I bought this unit used so I really don't know what I'm doing.

2- I couldn't get the app to back up anything (before anyone says it - I know, just another techno challenged user).

3- I thought since nothing would back up that the IR's were part of the factory presets (duh) and obviously I lost about 24 of them that came with the unit from the previous owner. Any chance I can recover them?

4- Why can't I find any detailed instructions about "backing up setlist/presets etc or using the new SNAPSHOTS? I haven't found anything in the users manual. Is there an updated users manual for 2.0?

5- Are the bundles you make going to continue working with 2.0 and future updates? - I am looking at purchasing some of them?

Thanks, TW

 

1. In addition to the manual and forums, there's a bunch of information in the knowledgebase here: http://line6.com/support/page/kb/_/effects-controllers/helix/

 

2. Kind of a moot point now.

 

3. Unless you have the original IR files, no, those IRs will be gone. Perhaps you can contact the original owner about getting them. If they were IRs that he purchased commercially, though, technically he shouldn't be sharing them anyway.

 

4.  It sounds like you're looking at an outdated version of the manual. The newest documentation is here: http://line6.com/support/manuals/helix

 

5. Yes, any pre-2.0 bundles should work with the 2.0 firmware.

Share this post


Link to post
Share on other sites

About that "CURRENT EXISTING Helix editor app" -

1- I bought this unit used so I really don't know what I'm doing.

2- I couldn't get the app to back up anything (before anyone says it - I know, just another techno challenged user).

3- I thought since nothing would back up that the IR's were part of the factory presets (duh) and obviously I lost about 24 of them that came with the unit from the previous owner. Any chance I can recover them?

4- Why can't I find any detailed instructions about "backing up setlist/presets etc or using the new SNAPSHOTS? I haven't found anything in the users manual. Is there an updated users manual for 2.0?

5- Are the bundles you make going to continue working with 2.0 and future updates? - I am looking at purchasing some of them?

Thanks, TW

Yes Tom my previous patches are all compatible with Version 2 after ding the necessary updates to the Helix.

Share this post


Link to post
Share on other sites

About that "CURRENT EXISTING Helix editor app" -

.......

4- Why can't I find any detailed instructions about "backing up setlist/presets etc or using the new SNAPSHOTS? I haven't found anything in the users manual. Is there an updated users manual for 2.0?

....

There is s separate manual for the editor program. You will find it in the Manuals section of this website.

Share this post


Link to post
Share on other sites

Wouldn’t it have been easier just to use Monkey for all this ?  things do seem to have gotten more complex and confusing with HELIX compared to olden times. 

 

Or at least make it so the one app - HELIX does the updating biz as well as editing. 

 

Having said that - fortunately my update went find.  I followed the instructions to the letter ( of course ) 

Share this post


Link to post
Share on other sites

Wouldn’t it have been easier just to use Monkey for all this ?  things do seem to have gotten more complex and confusing with HELIX compared to olden times. 

 

Or at least make it so the one app - HELIX does the updating biz as well as editing. 

 

Having said that - fortunately my update went find.  I followed the instructions to the letter ( of course ) 

 

Yes, same experience. Thanks to everyone for your help. I now have current manuals. Working on how I screwed up the backup process and lost my IR's. Helix board is up to ver 2.0. Took three tries to get "Helix Editor" up to ver 2.0. Correct me if I'm wrong but while in the Helix app shouldn't the EDIT window reflect the settings highlighted in the LIBRARIAN window? No matter which preset I choose in the LIBRARIAN window the "signal flow ad "low panel", effects etc never change in the EDIT window? All the settings stay the same as presented in the initial opening of the app. Only the title changes as I go through the presets. (using in Windows 7) 

Share this post


Link to post
Share on other sites

A little late in the thread, but this may help anyone who has bricked a Helix.  I had one of the first ones into Canada in Dec. 2015.  Some Mac/El Cap users had trouble with bricking before Helix 1.12. Mine bricked 2 or 3 times, and the first time, I returned it to the shop as well.

 

What I discovered is that you boot your Mac into safe mode by holding the Shift Key, and then use the updater.  It restored my Helix at least a couple of times.

 

Something to try before you send it away if you've got upcoming gigs.

Share this post


Link to post
Share on other sites

Not sure about all of them, but at least some of them were due to using the wrong Helix Editor version for the update

 

Not my case, I was using the right software. 

If something was wrong on my part, it might have been using a front usb port. 

That particular computer has three on the front, one is part of the card reader and two are directly connected to the mainboard. Those two should work ok, but they fail sometimes (losing connection to the hardware), unlike the ones in the back, so next time I know where to connect to.

Share this post


Link to post
Share on other sites
Another update: I got my Helix back from Line 6 yesterday with the 2.0 update installed. Turnaround was fast - it took about a week total. I've only had a little time to spend with it, but all of the new 2.0 stuff seems very cool! I don't yet know if they have found the source of the problem, but I'll post here if they pass on any info to me.

 

I've been very satisfied with the customer service from Line 6. It's great to have a company that handles support so well and makes sure the end user is taken care of.

Share this post


Link to post
Share on other sites
I've been very satisfied with the customer service from Line 6. It's great to have a company that handles support so well and makes sure the end user is taken care of.

 

 

I agree. I purchased my first Line 6 product about five years ago and they have stayed true to form. I had to reload my Helix floorboard, and its accompanying editing app, four times yesterday. Three of those times I called the techs and they were helpful and patient. Job done. In case anyone is interested - The editor app didn't download properly and in the process of reloading the app the floorboard locked up. Using the 6/12 button "SAFE MODE" re-boot I was able to get the Helix running again so I could reload Helix ver 2.0. There are sooooo many steps to loading the Helix, I couldn't tell you what the suspect action was. I think the L6 design team had to deal with many obstacles making the new technology so they just couldn't use the older download tools. I have read through all of the topics in the NEW users manual. I'm not a techno-musician but I can see how much thought went into not only making a very usable/versatile unit but about as, dare I say, "intuitive" as it can be. My imagination will be the only limiting factor here! (aside from the ever present software/firmware glitches) At this point I'd have to say my favorite feature of this unit is the ability to easily build any pedalboard/boards I want with the touch of a few buttons. Any stomp boxes in my future will have be impressive to get my attention.

Share this post


Link to post
Share on other sites

After downloading and updating, the presets will not rebuild. If I reboot, I get an initial screen that has :-28 in the upper left hand corner. Any ideas?

Share this post


Link to post
Share on other sites

I have had that same issue now twice.  I think it has something to do with the USB connection.   Try unplugging your USB cable and restarting the Helix.  If that doesn't work trying plugging it into the USB  of a different port or different computer all together.  Unfortunately trying to reboot 9+10 or anything else doesn't work.  Eventually it comes back.  Remember to backup your patches and setlists frequently.

Share this post


Link to post
Share on other sites

Hi Guys,

 

I am trying to update to 2.01 from 1.03, helix is visible on the updater and shows firmware of 2.01

 

When I first tried to update the update failed on the Helix's screen and when I went to restart it now the screen just alternates an image of a speaker, a cab, a amp head and the helix squiggle.

 

Trying to reinstall previous firmware just ends in the update failing.

 

Can't get it to do anything else.

 

Please Help

 

 

Cheers

Share this post


Link to post
Share on other sites

Hi Hamish, Try plugging your USB into the Rear of your computer and Not using a "Hub" or front USB connection, which is actually a Hub. Mine did the same thing once when upgrading to V2.0.

Share this post


Link to post
Share on other sites

Thanks Glen,

 

I have tried rear USB Ports, still tells me update 2.00 & 2.01 are complete but still getting the Helix screen alternating those images and doing nothing else

Share this post


Link to post
Share on other sites

Also, when I do get the firmware update going the screen on the Helix goes blank and does not do anything else, instructions on the computer says it will restart automatically and begin rebuilding presets, how long does this take?  and should there be something on the screen?

 

I left it for 30 minutes to rebuild the presets but there was no change to the unit.

 

Help

Share this post


Link to post
Share on other sites

The actual restarting should occur pretty much right away. If I remember right, when the update goes like it should, after the restart the update program on the computer remains blank until Helix has fully restarted. During the preset rebuilding, the screen on Helix should show the usual moving dna, basically a normal startup screen, with the addition of an indication of preset rebuilding and an increasing number. It should not take thirty minutes, maybe around five at the most.

Share this post


Link to post
Share on other sites

Also, when I do get the firmware update going the screen on the Helix goes blank and does not do anything else, instructions on the computer says it will restart automatically and begin rebuilding presets, how long does this take?  and should there be something on the screen?

 

I left it for 30 minutes to rebuild the presets but there was no change to the unit.

 

Help

This is what happened to mine as well. Unfortunately, the support team was not able to find a reason why it happened. Luckily, they were able to restore it and get it updated and sent back to me pretty quickly. Might be best to contact them.

Share this post


Link to post
Share on other sites

Mine did that too, failing to restart after updating, essentially bricked after that. What worked for me was using a different USB port. Sounds like like voodoo troubleshooting, but I'm not the only one that worked for, worth a try if you haven't already.

Share this post


Link to post
Share on other sites

I just tried the update of my 4 days old Helix to 2.01.0 : after an hour and seeing strange Japanese symbols on the screen I began to read some posts on this forum about update problems.  Seemed like almost everybody here faced minor or major issues and I started to freak out since it's not my first bad encounter with updating electronic hardware through the internet.

 

So I shut the Helix down and back on : I got the message "update failed (or sort of) and the feared orange "0" in the left upper corner.

 

After a few deep breaths I just shut down my laptop (mac running El Capitan), turning it back on and trying it again (still using the latest version of the editor (and updater) of course).... and to my surprise it worked (rebuilding presets by helix took another 3-4 minutes)!!

 

So keep the spirits up, stay calm and perform the update right after you've started your computer without doing anything else - pray - and it might just work.

 

I'm posting this because I know how frustrating it can be to have such expensive devices not doing what they are supposed to do right away.

 

and now I'm going to explore this monster machine !

Share this post


Link to post
Share on other sites

I had the same issue updating my helix to 2.11. I followed the instructions exactly and got the update failed error with messed up helix screen.

 

Ultimately, booting helux to update mode (switches 6 + 12), unplugging all other usb devices except my mouse and installing in local mode worked for me.

 

I suspect my USB wifi was hanging up the helix update somehow.

 

Hope this helps someone else.

Share this post


Link to post
Share on other sites

Hey everyone! I've had my Helix now for over a year. I download and got to 2.01 update, but I recent;y tried to download the newest update from 5/15/17. When I tried to update the system couldn't do it, and that it failed to update. After that my Helix wasn't the same. Now when I turn it on it shows the Line 6 Helix logo, and the loading spirals, but also flashes "Helix Rack". Is there a way to fix this? And, if I have to send it to Line 6 is it expense to fix? Thank you.

 

Share this post


Link to post
Share on other sites

Hey everyone! I've had my Helix now for over a year. I download and got to 2.01 update, but I recent;y tried to download the newest update from 5/15/17. When I tried to update the system couldn't do it, and that it failed to update. After that my Helix wasn't the same. Now when I turn it on it shows the Line 6 Helix logo, and the loading spirals, but also flashes "Helix Rack". Is there a way to fix this? And, if I have to send it to Line 6 is it expense to fix? Thank you.

I'm the original poster on this thread. I would suggest that you create a support ticket. If you have had the unit for less than 2 years, it is still covered by warranty if any repair is necessary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...