Jump to content

error 1114 dynamic link library (DLL) intialization routine failed

Recommended Posts

Hi all trouble-havers :angry: ,


In case you're having the error "error 1114 dynamic link library (DLL) intialization routine failed" when trying to open your recently installed Helix Editor application, refer to the following YouTube video and follow the instructions (

).  It appears to have something to do with laptops circa 2010-2012 that have switchable graphics.  I tried my damndest and even opened a Line 6 trouble ticket (to no avail...they ended up telling me to contact Microsoft) to get this solved, but I just stumbled on this and now I can finally open the Line 6 Helix editor without errors.  Hope this helps someone!
  • Upvote 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...