Jump to content

Helix Editor Crashing


Goooner1
 Share

Recommended Posts

Got my Helix on Saturday, updated the firmware to 2.0, all good, working as it should. If I try and run the Helix Edit app on my PC, it'll run for maybe 10 seconds, then a box pops up saying it's stopped working and closes, tried uninstalling and reinstalling, no difference.

​Any suggestions? Running Win 10.

Link to comment
Share on other sites

Possibly a corrupted download, I guess some people missed this. When you click the GET DOWNLOAD button for the Helix app on the website, it opens the Software License Agreement page, just above the Decline/Accept and Download buttons there is a blue Attention! box.

 

Edit!!!! See below

Link to comment
Share on other sites

Possibly a corrupted download, I guess some people missed this. When you click the GET DOWNLOAD button for the Helix app on the website, it opens the Software License Agreement page, just above the Decline/Accept and Download buttons there is a blue Attention! box.

Just had another look and it seems to be missing, it said to

go into Microsoft Explorer11/Edge settings, advanced settings, and turn off 'Help protect me from malicious sites and downloads with Smartscreen filter' as that can cause problems

Link to comment
Share on other sites

Tried deleting everything, downloaded again using chrome and reinstalled. Also tried putting a blank preset on the Helix before starting the app and also disconnecting everything from the Helix apart from the USB before starting the app. No good.

Link to comment
Share on other sites

Tried deleting everything, downloaded again using chrome and reinstalled. Also tried putting a blank preset on the Helix before starting the app and also disconnecting everything from the Helix apart from the USB before starting the app. No good.

Make sure you are pulling up the 2.0 version of the editor, if you see the camera icon in the upper left hand corner for the snapshots you probably have the right version. Did you do the global reset with footswitches 9 & 10 after upgrading (backup your presets first)? This is critical. Also, after the reset completes and you have restored your old presets, restart the Helix another time as there is a final rebuilding of the presets. Good luck!

Link to comment
Share on other sites

Yeo, did all that. Editor shows version 2.00.1

 

Didn't have any presets to back up or reload as it's a completely new unit. Bought it Saturday and all I've had time to do with it is update the firmware to 2.0 and try out the factory presets.

 

Going to try downloading the Helix software on my work PC, on the offchance it may make a difference.

Link to comment
Share on other sites


I'm downloading it from work PC, that's currently running Win 7, using Chrome, don't suppose it'll make a difference but worth a shot. Will delete everything Line 6 from my PC, reboot and start again. If that fails, I'll try my wife's laptop.



 



Weird thing is, after I'd update on Saturday, but restarted using 7 & 8 as that's what it said on the screen and Helix Edit was working then in the brief time I tried it.



 



Since then, all I've done is reboot the Helix doing the 9 & 10 thing. Didn't touch the PC, so nothing has changed that side, all that's changed is whatever the Helix does differently between 7 & 8 and 9 & 10. Tried it last night and got the crashing.

Link to comment
Share on other sites

Update in case it helps anyone with a similar issue, I've just gone into Windows task manager and disabled something called Realtek HD Audio Manager from starting with Windows, rebooted and the Helix app seems to be playing nicely. Guessing as it's obviously audio there was some conflict with the Helix app. No idea if I ever used the Realtek thing, but I can always enable it again when I know I won't be using the Helix app.

​Fingers crossed that is indeed the answer.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...