Jump to content

Helix freezes


SlowHand2000
 Share

Recommended Posts

I have a brand new unit. Only powerd it up 5 times...I updated it to Firmware 2.0.

 

I just wanted to go through the presets and suddenly when I reached "Deep Clean" everything freezed. No reaction by any button at all.

When I powerd up again I could choose one sound of the current bank - then it freezed again. I tried this 5 times - everytime the same result. Only a Factory reset could help (Powering up and holding down buttons 9/10)

 

I am just unsure whether I would really want to use this unit on stage.  At least not with the possibility of freezing again.

 

 

Any help please...?

 

 

Link to comment
Share on other sites

You probably just need to update your Helix Editor on your computer.

 
2. Use your CURRENT EXISTING Helix application to back up all of your presets and IRs (if you want to keep them). If you’re running Helix FW 1.12, your current Helix application version should be 1.12.

 

NOTE: You may want to back up individual Setlists so you can restore them to empty setlists without affecting the new 2.0 factory presets.

 

3. Quit the CURRENT EXISTING Helix editor application and download and install the NEW Helix editor application (2.00), available here: http://line6.com/software/ This also installs the newest version of Line 6 Updater (1.09).
 
You may or may not need to do this final step.
As outlined by Line6 on the instructions for the update, read this again carefully please.
 

7. Turn off Helix/Helix Rack.
HELIX FLOOR: While holding footswitches 9 and 10 (middle two switches on the bottom row), turn on Helix.
HELIX RACK: While holding knobs 5 and 6 below the screen, turn on Helix Rack. DO NOT LET THE SWITCHES GO UNTIL YOU SEE THE MESSAGE“Will reset Globals and restore stock Presets, Setlists and IRs…†to appear and then let go of the switches. YOU MUST RESET GLOBALS AND RESTORE PRESETS, OTHERWISE HELIX 2.0 WILL NOT WORK PROPERLY.
Link to comment
Share on other sites

Got mine in april and i thought i was the only one with this problem as there was no one else posting about it. No problems until I flashed the 2.00. The 2.00 firmware worked for a day then started freezing. I also re flashed 1.12 and it worked for about an hr then froze. I been in contact with line 6 and tried their fix and got the same, still froze. The unit is toast for now. Hopefully I just got a bad one and this wont be a big problem. I also wanted it fixed and not just by re flashing as I would always worry about it quitting after the warranty runs out. I really like the helix also just think I got a bad one. For now back to the pod hd pro.

Link to comment
Share on other sites

It can't hurt to try it again. Here are the detailed instructions. Pay particular attention to items 2, 3 & 7.

IMPORTANT! YOU *MUST* FOLLOW THESE INSTRUCTIONS TO INSTALL 2.0!

 

1. Shut down all Line 6 software as well as any software that streams audio, including, but not limited to: iTunes, Spotify, DAWs, etc.

 

2. Use your CURRENT EXISTING Helix application to back up all of your presets and IRs (if you want to keep them). If you’re running Helix FW 1.12, your current Helix application version should be 1.12.

 

NOTE: You may want to back up individual Setlists so you can restore them to empty setlists without affecting the new 2.0 factory presets.

 

3. Quit the CURRENT EXISTING Helix editor application and download and install the NEW Helix editor application (2.00), available here: http://line6.com/software/ This also installs the newest version of Line 6 Updater (1.09).

 

4. If you’re using Helix Rack with Helix Control, turn off Helix Control.

 

5. Using the latest Line 6 Updater (1.09), update Helix/Helix Rack to the newest firmware (2.00). At the end of the update process, Helix/Helix Rack will reboot automatically and begin rebuilding presets. Wait for this process to complete.

 

6. If you’re using Helix Control with Helix Rack, connect and power on Helix Control. The inspector will ask if you want to update its firmware. Press Knob 6 (OK). Wait for the update to finish.

 

7. Turn off Helix/Helix Rack.
HELIX FLOOR: While holding footswitches 9 and 10 (middle two switches on the bottom row), turn on Helix.
HELIX RACK: While holding knobs 5 and 6 below the screen, turn on Helix Rack. DO NOT LET THE SWITCHES GO UNTIL YOU SEE THE MESSAGE“Will reset Globals and restore stock Presets, Setlists and IRs…†to appear and then let go of the switches. YOU MUST RESET GLOBALS AND RESTORE PRESETS, OTHERWISE HELIX 2.0 WILL NOT WORK PROPERLY.
Link to comment
Share on other sites

I followed all these instructions carefully, restored all my patches and IRs. I am occasionally getting Helix freezes when editing a patch. Audio works, but the display and buttons become unresponsive. Have to reboot to recover.

 

This doesn't seem to be a timing issue, I've left the Helix on for a number of hours with no problems, And it's never frozen just playing. Only when editing my old patches.

 

There could be bugs lingering, and it might be a good idea rebuild the patches from scratch in some cases.

Link to comment
Share on other sites

I followed all these instructions carefully, restored all my patches and IRs. I am occasionally getting Helix freezes when editing a patch. Audio works, but the display and buttons become unresponsive. Have to reboot to recover.

 

This doesn't seem to be a timing issue, I've left the Helix on for a number of hours with no problems, And it's never frozen just playing. Only when editing my old patches.

 

There could be bugs lingering, and it might be a good idea rebuild the patches from scratch in some cases.

 

I know you have probably seen me post this before but I have found that making a slight modification to the preset and saving it usually works to prevent it from ever causing a freeze again.

Link to comment
Share on other sites

My first helix had this problem. At first factory resets would resolve the issue for 15 min or so, then the time would decrease. Eventually, I could not even get the unit to boot, and had to return it. It is a bit concerning to me that others are struggling. I am hoping that there is no internal flaw in the helix that might cause this problem when certain criteria occur. My replacement has never crashed even 1x. Updated to 2.0 day 1.

Link to comment
Share on other sites

My first helix had this problem. At first factory resets would resolve the issue for 15 min or so, then the time would decrease. Eventually, I could not even get the unit to boot, and had to return it. It is a bit concerning to me that others are struggling. I am hoping that there is no internal flaw in the helix that might cause this problem when certain criteria occur. My replacement has never crashed even 1x. Updated to 2.0 day 1.

Yes. Hence my post. http://line6.com/support/topic/21773-i-might-do-it-maybe/?do=findComment&comment=164992

I'd love to hear of your experience with 2.0 in the following days/weeks of use.

 

Thanks.

Link to comment
Share on other sites

  • 3 months later...

I'm experiencing similar issues with my Helix now after many months of no issues.

I've used it for a few gigs, after the 2.0 update without issues.

 

The past few days I am getting constant intermittent freezes.  In the PC Editior, or editing patches.  It seems to be triggered mostly by editing and occasionally the controller will just freeze up.  The only change is I started using the Helix in the effects loop of my Mesa.  Before I was using the AMP and CAB sims.

 

Very frustrating.  Yes I have tried backing up my patches, re-flashing, re-setting and re-loading.  I have tried modifying and re-saving my patches too.  Not having any joy.

 

Anyone else in the same boat?

Link to comment
Share on other sites

I got it working after some hints from support. There appears to have been something wrong with my presets. I went back to the factory presets, restated the Helix and had no issues for 30 mins. Then I made a new set of my own presets and everything worked. No freezes, no USB disconnects or freezes in the editor.

 

Luckily I was in the process of creating all new presets and setting up midi to work with my Mesa JP-2C anyway... so I didn't worry too much about losing my old setup.

 

Still kind of scary that a corrupted patch(es) can make the whole thing freeze. I won't use any of the old patches because there is no way to tell which one(s) may have been corrupted.

 

Now I am having some midi programming limitation challenges but that is another story...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...