Jump to content
Sign in to follow this  
Rocco_Crocco

Weird bug with Helix, Windows 10 and YouTube

Recommended Posts

I wanted to see if anyone else is experiencing this...

 

When I plug my Helix into the USB port of my Windows 10 laptop to jam alomg with YouTube videos, my mouse becomes very unresponsive. It will move the cursor but very slow, and I have to click several times to open a video, hit play or pause, etc.

 

This seems to be a recent issue for me. Maybe related to V2.0? The issue never occurred before.

 

 

Any thoughts?

Share this post


Link to post
Share on other sites

I'm the farthest thing in the world from an IT guy, but it seems more like a computer horsepower issue, than anything else...you've got audio and video bouncing around at once. How much RAM is it sporting?

Share this post


Link to post
Share on other sites

I do this all the time with a meager i3 and 4GB RAM, and haven't noticed any cursor/click issues. Do you have all the "digital nanny" crap that comes with Windows 10 disabled?

Share this post


Link to post
Share on other sites

I am not sure about RAM and all that, but I can say I have been using this exact setup for several months, and it had only become an issue last  week. 

 

I ran spybot and did an anti-virus scan and that didn't help.

 

I am aware it could very well be an issue with my computer and not the Helix, but I wanted to see if anyone else has the same issue.

Share this post


Link to post
Share on other sites

I'd try moving your mouse to a completely different USB port on the computer if possible (assuming it is a USB mouse). I'd also see if there's a newer driver update for your video card. It could also be that a recent Windows update changed some things resulting in a problem. It sounds like your computer is struggling to display your mouse cursor and streaming video at the same time, so it seems related to video and/or video RAM - just a guess, but probably where I'd start troubleshooting!

  • Upvote 1

Share this post


Link to post
Share on other sites

I'd try moving your mouse to a completely different USB port on the computer if possible (assuming it is a USB mouse). I'd also see if there's a newer driver update for your video card. It could also be that a recent Windows update changed some things resulting in a problem. It sounds like your computer is struggling to display your mouse cursor and streaming video at the same time, so it seems related to video and/or video RAM - just a guess, but probably where I'd start troubleshooting!

 

Sometimes USB ports are internally shared, much like if you had a USB hub.  Best thing is to switch ports and ensure you are using the latest drivers.  

Share this post


Link to post
Share on other sites

I have been having other issues with my new Windows 10 system mainly using Explorer 11 seems to be the problem. I am going to switch over to Google Chrome and see of that helps with the install file problems I have. Might be it is not the Windows but the Browser. Explorer 11 is giving me fits.

Share this post


Link to post
Share on other sites

I had already tried moving the mouse to a different USB. port. Same results.

 

I will check into the video card driver.

 

I run Chrome, but will try  different browser to see if that helps.

Share this post


Link to post
Share on other sites

I wanted to see if anyone else is experiencing this...

 

When I plug my Helix into the USB port of my Windows 10 laptop to jam alomg with YouTube videos, my mouse becomes very unresponsive. It will move the cursor but very slow, and I have to click several times to open a video, hit play or pause, etc.

 

This seems to be a recent issue for me. Maybe related to V2.0? The issue never occurred before.

 

 

Any thoughts?

 

Changing browsers to Chrome or Firefox may help but one possible solution may to be to disable/enable the hardware acceleration in any of these browsers. Here is how to do it in IE 11

 

To disable hardware acceleration, follow these steps:
  1. Click Start, and then click Internet Explorer.
  2. Click the Tools icon in the upper-right corner, and then click Internet Options.
  3. Click the Advanced tab, and then under Accelerated graphics, select the Use software rendering instead of GPU rendering check box.
  • Upvote 1

Share this post


Link to post
Share on other sites

 

Changing browsers to Chrome or Firefox may help but one possible solution may to be to disable/enable the hardware acceleration in any of these browsers. Here is how to do it in IE 11

 

To disable hardware acceleration, follow these steps:
  1. Click Start, and then click Internet Explorer.
  2. Click the Tools icon in the upper-right corner, and then click Internet Options.
  3. Click the Advanced tab, and then under Accelerated graphics, select the Use software rendering instead of GPU rendering check box.

 

Thanks! I finally got around to applying this process to Chrome earlier this week, and it worked!

Share this post


Link to post
Share on other sites

Thanks! I finally got around to applying this process to Chrome earlier this week, and it worked!

 

Excellent, glad to hear it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...