Jump to content

Line 6 Corp Service Center


jpdennis
 Share

Recommended Posts

Amazing repair work.

 

I sent my Helix to Line 6 So. Cal. on a RMA.  They received it early on the 12th of August and I just got it back this morning around 9:30am Pacific.  I then uploaded 25 IRs and 4 User setlists; not all the setlists are at 100% so maybe 120 presets all together.  And I did install the setlists not the individual presets just for the heck of it.  Then I overwrote several of the presets with other presets as a test.

 

Before I sent it in I could recreate my issue repeatedly.  After stress testing it and doing everything I could to recreate the issue there was not one hiccup other then the rebuilding presets the first time I restarted the unit after loading my presets.  Other than that I have had several hours of trouble free performance.

 

But there is more!  The reverb and echo FX blocks I use are ...  "WOW" ... crystal, more pronounced, and almost sound like higher then high fidelity components got installed.  I am now toning down my reverb and echo FX blocks as well as reducing the gain to below 0.0 on my normal global EQ setting.

 

Playing a Fair this Thursday.  Can't wait

 

Thank you to Line 6 repair

 

Dennis

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...