Jump to content
Sign in to follow this  
zuvvy

Second MIDI PC Message Resets Preset

Recommended Posts

I'm getting some odd behavior sending program change midi messages to the helix from Ableton.  The first time I send a given PC message, the preset selects fine.  But then the second time I send the same PC, the helix always selects preset 000 in the same bank.  (So if it's PC 3, the first time it correctly selects PC 003, and then on the second PC 003, the helix switchs to preset 000.)  

 

I don't have a midi sniffer attached (since on PC you can only attach one midi device to the helix interface as far as I can tell), but I'm pretty certain I'm only sending the one PC message, but I'm not sure if there's something with helix echoing it's own PC messages somehow.  (The Send/Receive PC messge option is naturally on, nothing else in the midi chain, latest firmware, no instant commands.) 

 

Any one else observing something similar?  Any suggestions or potentially obvious issues?  (I'm fairly new to midi in ableton, could certainly be something silly on my end!) 

 

Much obliged!

 

Share this post


Link to post
Share on other sites

Line 6 know this problem since May 18, when I submitted this bug and they acknowledged it.

 

And yes, they still didn't resolve it after almost 4 months.

 

It drives me mad that an annoying bug like this one take that long to be fixed.

 

By the way, I think you're using MIDI over USB? In my experience with the Helix, MIDI via USB is far less stable than MIDI via MIDI cables, and that particular bug doesn't occur with MIDI cables in the MIDI In/Out ports. Also, if the Helix is connected to a computer to send MIDI signals via USB, and the computer is connected via an USB soundcard to the PA to launch samples, use virtual instruments, etc, if your electric system is not top notch, there will be a lot of noises. And those noises are disappearing when using MIDI cables instead of USB.

 

(Also, on a not-so-far topic, I'm pretty pissed right now, because I found plenty of these bugs, and I lost a lot of time because of them, and now I've got two options: loose lot more time by trying to reproduce them, identify them, and then submitting them one by one to Line 6 - Line 6 that doesn't seem to be quick to fix them anyway, so why bother? -, or selling the Helix and try another setup. People at Helix team: you've got a great concept, you should not allow that many bugs - better test procedure? -, or at least, you should be really quick for fixing them. At this price point, part of your customer base are professional musicians, when you can't save a preset and restore it because when it's restored the snapshots are not restored correctly and it destroy your preset, and even in some cases make the Helix freeze, for frack's sake!)

Share this post


Link to post
Share on other sites

Okay, now that explains my problems as well. For an odd reason Helix does not react very reproducibly on midi signals sent in sequence from my iPad app (I use Onsong).

 

Initial program changes from song to song work, but a second one like a CC to Switch on the looper or to adjust Tap/Tempo does not always. even if you add 3 second delay between the two midi Events... 

 

I always thought the problem is within my brain or within the onsong app, and I spent already hours to find a solution. It appears now that this must be just this or a similar Helix bug with midi reception that has obviously been acknowledged by Line6 already.

 

I really hope for a new software release that adresses such midi issues. Might be that the majority of users would never notice these, but Helix within a midi Network is such an incredibly powerful tool. 

 

Please fix this, Line6. 

Share this post


Link to post
Share on other sites

I'm sure some of us here would like to help you, but your description really doesn't give much useful information. How are they they connected (USB, Midi cables, Mac, PC, other, etc..).  What did you do to troubleshoot?  For example, did you try MIDI Monitor if you are using a Mac (do this first) ?  What CCs are you using?  MIDI can be difficult, do you have experience with other MIDI devices? 

Share this post


Link to post
Share on other sites

I control my entire rig with IPAD running ONSONG app. Use a Bluetooth Midi Adapter with 5-pole DIN plugs. run into a voicelive3 (TC Helicon) , chained to Helix (set to midi thru) chained to Eventide H9 pedal, Midi out back to the Adapter. Each Receiver is set to respond to a distinct midi channel (Helix@0, Voicelive@2, H9@15). Each unit responds and reacts perfectly to its PC messages. This works really well for all devices in the chain...

 

However. the following command from the app 

 

          MIDI: 0@0, WAIT2, CC67:127@0

 

is supposed to do the following - as per owners manual:

 

1) set Helix to Patch 1A  [works great, Helix reacts as intended]

2) Wait 2 Seconds [Works, Midi Monitoring showing this delay until next message]

3) Switch to looper footswitch layout on Helix so I can start... [This CC Message is detected in Midi Monitoring, but Helix does never Switch to Looper Mode!] Of course, Looper is inside Patch 1A on path 2...

 

When I select another song later, all PC Messages then are well executed again from all the pedals...

Also, when I exchange the last command from CC67:127@0 to e.g. CC69:1@0 -rest unchanged- Helix would react perfectly by selecting patch 1A and after 2 seconds engage another snapshot.

 

So I really do not understand that behaviour. Does anybody see that this might be related to a known bug of Helix (for me most likely), or any other idea?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...