Jump to content
spankygtr

Easiest way to assign snapshots to footswitches

Recommended Posts

How do I assign a footswitch to a snapshot? I poked around for a good hour last night, and it seemed to be impossible to find this out from your manual or editor. Some videos demonstrated aspects of snapshots, and I was able to create some, but that final step of assigning them to switches seemed to be left out. I tried hitting the menu button, then pressing knob 1. Manual said I'd see "footswich assign", but instead I saw "bypass assign". Hit a couple of knobs and switches, then I seemed to be frozen, couldnt get ANYTHING to happen till I rebooted. Very alarming, may have to return the Helix.

Share this post


Link to post
Share on other sites

You can't assign snapshots to footswitches... There a few different ways to view snapshots, though. You can always get to snapshot mode by pressing the Bank Up and Bank Down footswitches simultaneously. You can also change Preset Mode to display snapshots - you can have all 8 footswitches show snapshots (effectively making preset mode the same as snapshot mode) or you can have the upper row of switches be 4 snapshots, and the lower row be 8 presets. Or you can have that reversed. Or you can have 4 stomp switches and 4 snapshots... Check out page 50 of the manual to get the full rundown.

  • Like 1

Share this post


Link to post
Share on other sites

Another option is to jump MIDI out to MIDI in and assign a footswitch in Stomp mode to send the proper command to activate the snapshot you want. Not perfect, the footswitch doesn't stay illuminated to show that it's active, but it's workable.

  • Upvote 1

Share this post


Link to post
Share on other sites

Another option is to jump MIDI out to MIDI in and assign a footswitch in Stomp mode to send the proper command to activate the snapshot you want. Not perfect, the footswitch doesn't stay illuminated to show that it's active, but it's workable.

 

That's a pretty sick workaround.  I prefer 10 stomp mode myself.  So now having the option to assign a stomp to midi switch itself to snapshots is awesome.  I'm going to spend/waste a lot of time playing around with that. Thank you!

Share this post


Link to post
Share on other sites

That's a pretty sick workaround.  I prefer 10 stomp mode myself.  So now having the option to assign a stomp to midi switch itself to snapshots is awesome.  I'm going to spend/waste a lot of time playing around with that. Thank you!

 

Credit goes to DI, I believe it was his clever proposition initially, but glad to share it!

Share this post


Link to post
Share on other sites

That's a pretty sick workaround.  I prefer 10 stomp mode myself.  So now having the option to assign a stomp to midi switch itself to snapshots is awesome.  I'm going to spend/waste a lot of time playing around with that. Thank you!

 

One caveat with this workaround. I spent some time messing with this last week, and there are few issues. First of all, if you go into looper mode with this, you'll create a MIDI feedback loop. The reason for this is that the footswitches send out CC messages for each looper function. Right now, there's not a way to turn this functionality off. I have a MIDI Solutions Event Processor, so I was able to filter these messages out and get it to work. So basically, right now, if you use the looper, there's no way to make this trick work unless you have an external means of filtering the offending CCs.

 

The other issue is the way the CC Value command works when you assign it to a footswitch. There's a bug right now that makes it so a specific CC value is saved with each snapshot. Beyond that, this value is treated an Instant Command, and it's shot out when the snapshot is triggered. For example, if you go into the Command Center and set up a footswitch for CC69, value 2 - that does call up Snapshot 3 (with the MIDI cable trick mentioned here). The issue is that the value for CC69 stays at 0 for the other snapshots until you go and change it in each one. So if you don't do that and hit this footswitch, you'll go to Snapshot 3, but upon loading Snapshot 3, CC69, Value 0 is shot out and you go right back to Snapshot 1. So the workaround is to go into the Command Center in each snapshot and make sure you set the CC69 value to be the same thing in every one.

  • Upvote 1

Share this post


Link to post
Share on other sites

That's just gross, sorry. Nice idea, but way more warts on it than I want to deal with, at least for now.

 

We really need some other way of mixing switch types, and/or as I keep mentioning, having the Mode switch cycle through multiple different layouts instead of toggling between just two.

Share this post


Link to post
Share on other sites

That's just gross, sorry. Nice idea, but way more warts on it than I want to deal with, at least for now.

Not something I actually use, but I just wanted to test it out after some folks said they were having problems with it on the Helix Facebook group. Really, the thing with the CC Value and saving the value per snapshot isn't a big deal, and the workaround is simple (takes about all of 10 seconds to do in the editor), but the thing with looper is a big deal and could be a deal-breaker for some people.

Share this post


Link to post
Share on other sites

One caveat with this workaround. I spent some time messing with this last week, and there are few issues. First of all, if you go into looper mode with this, you'll create a MIDI feedback loop. The reason for this is that the footswitches send out CC messages for each looper function. Right now, there's not a way to turn this functionality off. I have a MIDI Solutions Event Processor, so I was able to filter these messages out and get it to work. So basically, right now, if you use the looper, there's no way to make this trick work unless you have an external means of filtering the offending CCs.

 

I don't use the looper for anything performance based so thats not an issue for me.  I can see how it might be for others though - I never even add it to presets.  I have to add it in when I do feel like practicing with it.

Share this post


Link to post
Share on other sites

That's just gross, sorry. Nice idea, but way more warts on it than I want to deal with, at least for now.

 

We really need some other way of mixing switch types, and/or as I keep mentioning, having the Mode switch cycle through multiple different layouts instead of toggling between just two.

I agree, once the bug is fixed it will still be nice workaround, but I would love to see the ability to just assign the snapshots to any FS in Stomp mode.  Honestly though, I've been completely satisfied just sitting in Snapshots mode this week.  I thought it would be harder to give up the individual stomp mode than it is.

Share this post


Link to post
Share on other sites

I've changed over to 4 snap and 4 stomp switches mode, and have been gradually converting my most-used patches to work that way. It's working pretty well, but I do also hit the Mode switch to access more stomps, which I definitely use.

 

Helix Pro, with its 20 footswitches and scribble strips, should be about right (;-)

Share this post


Link to post
Share on other sites

I've migrated to 4 Stomps/4 Snaps as well, stomps on top, snaps on bottom. It is certainly adequate, especially when you incorporate a few things on switches accessible in Stomp mode just one click away. The thing that leaves it lacking for me is the wasted real estate. Most of my patches have just two or three snaps, the rest is handled with the stomps. That leaves one or two footswitches wasted as they are allocated to snaps that I don't have. I think the ability to assign snaps to footswitches in Stomp mode would be the ultimate. I started an Ideascale topic on it, vote it on up if you're of like-mind!

 

http://line6.ideascale.com/a/dtd/Option-to-assign-Snapshots-to-switches-in-10-Switch-Stomp-Mode/833058-23508

  • Like 1

Share this post


Link to post
Share on other sites

I am unable to change the view of the snapshots. Either all are showing, or none. Even though I change the buttons telling to show snapshots at the top and stom down, its not happening. Is there a bug or am I doing something wrong? I use the latest version of firmware on the helix (2.01)

 

You can't assign snapshots to footswitches... There a few different ways to view snapshots, though. You can always get to snapshot mode by pressing the Bank Up and Bank Down footswitches simultaneously. You can also change Preset Mode to display snapshots - you can have all 8 footswitches show snapshots (effectively making preset mode the same as snapshot mode) or you can have the upper row of switches be 4 snapshots, and the lower row be 8 presets. Or you can have that reversed. Or you can have 4 stomp switches and 4 snapshots... Check out page 50 of the manual to get the full rundown.

Share this post


Link to post
Share on other sites

I am unable to change the view of the snapshots. Either all are showing, or none. Even though I change the buttons telling to show snapshots at the top and stom down, its not happening. Is there a bug or am I doing something wrong? I use the latest version of firmware on the helix (2.01)

 

In Snapshot Mode, you'll always see 8 snapshots. The different view settings apply to what's displayed in Preset Mode.

Share this post


Link to post
Share on other sites

In Snapshot Mode, you'll always see 8 snapshots. The different view settings apply to what's displayed in Preset Mode.

Yep, sounds like "Snapshot Mode" (both Bank buttons pushed simultaneously). Selecting just one Bank button and then a preset should put you in the mode to reflect your "snapshots top - stomps bottom" view.

 

Also this note from the manual regarding how you have the "Snapshot Mode Switches" parameter set.

"If you don’t want Snapshot footswitches to disappear after selecting one, set "Global Settings > Footswitches" > Knob 4 (Snapshot Mode Switches) to “Manual Return.†In this case, Helix stays in Snapshot footswitch mode until you press FS6 (CANCEL). "

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×